summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-11-02 21:57:14 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-11-02 21:57:14 +0000
commit3781cf81213d0d10b26581ba981a841b5d1415e3 (patch)
tree29b03dae71676a37951a276d4157e9f13689748e /games-arcade
parentstable ppc, bug #197752 (diff)
downloadgentoo-2-3781cf81213d0d10b26581ba981a841b5d1415e3.tar.gz
gentoo-2-3781cf81213d0d10b26581ba981a841b5d1415e3.tar.bz2
gentoo-2-3781cf81213d0d10b26581ba981a841b5d1415e3.zip
patching goes in src_unpack
(Portage version: 2.1.3.16)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/amphetamine/amphetamine-0.8.10.ebuild34
-rw-r--r--games-arcade/amphetamine/files/amphetamine-0.8.10-64bit.patch (renamed from games-arcade/amphetamine/files/020_assumed_sizeof_long.diff)0
-rw-r--r--games-arcade/amphetamine/files/amphetamine-0.8.10-gentoo.patch11
3 files changed, 20 insertions, 25 deletions
diff --git a/games-arcade/amphetamine/amphetamine-0.8.10.ebuild b/games-arcade/amphetamine/amphetamine-0.8.10.ebuild
index 5c236b33d470..34954beafa17 100644
--- a/games-arcade/amphetamine/amphetamine-0.8.10.ebuild
+++ b/games-arcade/amphetamine/amphetamine-0.8.10.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/amphetamine/amphetamine-0.8.10.ebuild,v 1.4 2007/11/02 21:23:52 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/amphetamine/amphetamine-0.8.10.ebuild,v 1.5 2007/11/02 21:57:14 nyhm Exp $
-inherit eutils games toolchain-funcs
+inherit eutils toolchain-funcs games
-DESCRIPTION="a cool Jump'n Run game offering some unique visual effects."
+DESCRIPTION="a cool Jump'n Run game offering some unique visual effects"
HOMEPAGE="http://n.ethz.ch/student/loehrerl/amph/amph.html"
SRC_URI="http://n.ethz.ch/student/loehrerl/amph/files/${P}.tar.bz2
http://n.ethz.ch/student/loehrerl/amph/files/${PN}-data-0.8.6.tar.bz2"
@@ -17,22 +17,28 @@ IUSE=""
DEPEND="media-libs/libsdl
x11-libs/libXpm"
-src_compile() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
- epatch "${FILESDIR}"/020_assumed_sizeof_long.diff
- sed -i -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" Makefile
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die "emake failed."
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-64bit.patch
+ sed -i \
+ -e "/^INSTALL_DIR /s:=.*:= ${GAMES_DATADIR}/${PN}:" \
+ -e "/^CFLAGS /s:$: ${CFLAGS}:" \
+ -e "/^CXXFLAGS /s:-O9.*:${CXXFLAGS}:" \
+ -e "/^DEPENDFLAGS /s:-g ::" \
+ -e "/^LINKER /s:$: ${LDFLAGS}:" \
+ -e "s:gcc:$(tc-getCC):" \
+ -e "s:g++:$(tc-getCXX):" \
+ Makefile \
+ || die "sed failed"
}
src_install() {
- newgamesbin amph ${PN}
-
+ newgamesbin amph ${PN} || die "newgamesbin failed"
insinto "${GAMES_DATADIR}"/${PN}
- doins -r ../amph/* || die "doins failed."
-
- dodoc BUGS ChangeLog NEWS README || die "dodoc failed."
+ doins -r ../amph/* || die "doins failed"
newicon amph.xpm ${PN}.xpm
make_desktop_entry ${PN} Amphetamine ${PN}
-
+ dodoc BUGS ChangeLog NEWS README
prepgamesdirs
}
diff --git a/games-arcade/amphetamine/files/020_assumed_sizeof_long.diff b/games-arcade/amphetamine/files/amphetamine-0.8.10-64bit.patch
index b7588face714..b7588face714 100644
--- a/games-arcade/amphetamine/files/020_assumed_sizeof_long.diff
+++ b/games-arcade/amphetamine/files/amphetamine-0.8.10-64bit.patch
diff --git a/games-arcade/amphetamine/files/amphetamine-0.8.10-gentoo.patch b/games-arcade/amphetamine/files/amphetamine-0.8.10-gentoo.patch
deleted file mode 100644
index ee55897a84a9..000000000000
--- a/games-arcade/amphetamine/files/amphetamine-0.8.10-gentoo.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.old 2007-02-08 21:17:12.000000000 +0100
-+++ Makefile 2007-02-08 21:22:07.000000000 +0100
-@@ -4,7 +4,7 @@
-
- # Install Paths
- PREFIX := /usr/local
--INSTALL_DIR := ${PREFIX}/games/amph
-+INSTALL_DIR := @GENTOO_DATADIR@
-
- # Libraries
- USE_LIB_XPM := TRUE