summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-12-04 09:06:22 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-12-04 09:06:22 +0000
commit99983505173f30d21e8542fc083d590345c2440b (patch)
treec440eef5018926c20a108ecdc7a1c4ad11db1787 /games-arcade/yarsrevenge
parentx11-proto/xcb-proto: bump to 1.6 (diff)
downloadgentoo-2-99983505173f30d21e8542fc083d590345c2440b.tar.gz
gentoo-2-99983505173f30d21e8542fc083d590345c2440b.tar.bz2
gentoo-2-99983505173f30d21e8542fc083d590345c2440b.zip
Fix build with sys-devel/patch-2.6 Bug #295304
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-arcade/yarsrevenge')
-rw-r--r--games-arcade/yarsrevenge/ChangeLog6
-rw-r--r--games-arcade/yarsrevenge/files/0.99-math.patch4
-rw-r--r--games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild5
3 files changed, 10 insertions, 5 deletions
diff --git a/games-arcade/yarsrevenge/ChangeLog b/games-arcade/yarsrevenge/ChangeLog
index 3916a3bc2dd7..ab7497f027c9 100644
--- a/games-arcade/yarsrevenge/ChangeLog
+++ b/games-arcade/yarsrevenge/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/yarsrevenge
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/yarsrevenge/ChangeLog,v 1.10 2009/06/18 00:16:46 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/yarsrevenge/ChangeLog,v 1.11 2009/12/04 09:06:21 tupone Exp $
+
+ 04 Dec 2009; Tupone Alfredo <tupone@gentoo.org> files/0.99-math.patch,
+ yarsrevenge-0.99.ebuild:
+ Fix build with sys-devel/patch-2.6 Bug #295304 by flameeyes@gentoo.org
18 Jun 2009; Tristan Heaven <nyhm@gentoo.org> yarsrevenge-0.99.ebuild,
+files/yarsrevenge-0.99-gcc44.patch:
diff --git a/games-arcade/yarsrevenge/files/0.99-math.patch b/games-arcade/yarsrevenge/files/0.99-math.patch
index bd6feb039899..5d7d4619d9c5 100644
--- a/games-arcade/yarsrevenge/files/0.99-math.patch
+++ b/games-arcade/yarsrevenge/files/0.99-math.patch
@@ -1,5 +1,5 @@
---- yar-0.99/yar/graphics.cpp.orig 2004-06-02 14:14:38.174071320 -0400
-+++ yar-0.99/yar/graphics.cpp 2004-06-02 14:14:50.352219960 -0400
+--- yar/graphics.cpp.orig 2004-06-02 14:14:38.174071320 -0400
++++ yar/graphics.cpp 2004-06-02 14:14:50.352219960 -0400
@@ -18,2 +18,3 @@
#include "yar.hxx"
+#include <cmath>
diff --git a/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild b/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild
index 1528391b71c2..fcc4ff4658b3 100644
--- a/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild
+++ b/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild,v 1.10 2009/06/18 00:16:46 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild,v 1.11 2009/12/04 09:06:21 tupone Exp $
EAPI=2
inherit eutils games
@@ -14,7 +14,8 @@ SLOT="0"
KEYWORDS="amd64 ~ppc sparc x86 ~x86-fbsd"
IUSE=""
-DEPEND="media-libs/libsdl"
+RDEPEND="media-libs/libsdl"
+DEPEND="${RDEPEND}"
S=${WORKDIR}/yar-${PV}