summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-01-04 22:35:55 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-01-04 22:35:55 +0000
commit8fd1aeb39882c95d7a2f756ecb2f6d4f8b83b475 (patch)
treee05a9051c1da848276e320c2e3350958cf4a553e /dev-vcs
parentfix dev-libs/DirectFB requirement (diff)
downloadgentoo-2-8fd1aeb39882c95d7a2f756ecb2f6d4f8b83b475.tar.gz
gentoo-2-8fd1aeb39882c95d7a2f756ecb2f6d4f8b83b475.tar.bz2
gentoo-2-8fd1aeb39882c95d7a2f756ecb2f6d4f8b83b475.zip
Add (masked until dependencies are keyworded) support for mediawiki, use subslot dependency on perl
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/ChangeLog10
-rw-r--r--dev-vcs/git/files/git-1.8.5-mw-destdir.patch37
-rw-r--r--dev-vcs/git/files/git-1.8.5-mw-vendor.patch39
-rw-r--r--dev-vcs/git/git-1.8.5.2.ebuild28
-rw-r--r--dev-vcs/git/git-9999.ebuild25
-rw-r--r--dev-vcs/git/metadata.xml1
6 files changed, 130 insertions, 10 deletions
diff --git a/dev-vcs/git/ChangeLog b/dev-vcs/git/ChangeLog
index ab738143de41..777c3422d79a 100644
--- a/dev-vcs/git/ChangeLog
+++ b/dev-vcs/git/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/git
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.236 2013/12/18 12:19:15 polynomial-c Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.237 2014/01/04 22:35:55 dilfridge Exp $
+
+ 04 Jan 2014; Andreas K. Huettel <dilfridge@gentoo.org> git-1.8.5.2.ebuild,
+ +files/git-1.8.5-mw-destdir.patch, +files/git-1.8.5-mw-vendor.patch,
+ git-9999.ebuild, metadata.xml:
+ Add (masked until dependencies are keyworded) support for mediawiki, use
+ subslot dependency on perl
*git-1.8.5.2 (18 Dec 2013)
diff --git a/dev-vcs/git/files/git-1.8.5-mw-destdir.patch b/dev-vcs/git/files/git-1.8.5-mw-destdir.patch
new file mode 100644
index 000000000000..ea4f1758059f
--- /dev/null
+++ b/dev-vcs/git/files/git-1.8.5-mw-destdir.patch
@@ -0,0 +1,37 @@
+diff --git a/contrib/mw-to-git/Makefile b/contrib/mw-to-git/Makefile
+index f206f96..a4b6f7a 100644
+--- a/contrib/mw-to-git/Makefile
++++ b/contrib/mw-to-git/Makefile
+@@ -18,9 +18,13 @@ SCRIPT_PERL+=git-mw.perl
+ GIT_ROOT_DIR=../..
+ HERE=contrib/mw-to-git/
+
++INSTALL = install
++
+ SCRIPT_PERL_FULL=$(patsubst %,$(HERE)/%,$(SCRIPT_PERL))
+ INSTLIBDIR=$(shell $(MAKE) -C $(GIT_ROOT_DIR)/perl \
+ -s --no-print-directory instlibdir)
++DESTDIR_SQ = $(subst ','\'',$(DESTDIR))
++INSTLIBDIR_SQ = $(subst ','\'',$(INSTLIBDIR))
+
+ all: build
+
+@@ -30,7 +34,9 @@ test: all
+ check: perlcritic test
+
+ install_pm:
+- install $(GIT_MEDIAWIKI_PM) $(INSTLIBDIR)/$(GIT_MEDIAWIKI_PM)
++ $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(INSTLIBDIR_SQ)/Git'
++ $(INSTALL) -m 644 $(GIT_MEDIAWIKI_PM) \
++ '$(DESTDIR_SQ)$(INSTLIBDIR_SQ)/$(GIT_MEDIAWIKI_PM)'
+
+ build:
+ $(MAKE) -C $(GIT_ROOT_DIR) SCRIPT_PERL="$(SCRIPT_PERL_FULL)" \
+@@ -43,7 +49,6 @@ install: install_pm
+ clean:
+ $(MAKE) -C $(GIT_ROOT_DIR) SCRIPT_PERL="$(SCRIPT_PERL_FULL)" \
+ clean-perl-script
+- rm $(INSTLIBDIR)/$(GIT_MEDIAWIKI_PM)
+
+ perlcritic:
+ perlcritic -5 $(SCRIPT_PERL)
diff --git a/dev-vcs/git/files/git-1.8.5-mw-vendor.patch b/dev-vcs/git/files/git-1.8.5-mw-vendor.patch
new file mode 100644
index 000000000000..54302ef26c91
--- /dev/null
+++ b/dev-vcs/git/files/git-1.8.5-mw-vendor.patch
@@ -0,0 +1,39 @@
+diff --git a/contrib/mw-to-git/Makefile b/contrib/mw-to-git/Makefile
+index a4b6f7a..d83df2c 100644
+--- a/contrib/mw-to-git/Makefile
++++ b/contrib/mw-to-git/Makefile
+@@ -22,7 +22,7 @@ INSTALL = install
+
+ SCRIPT_PERL_FULL=$(patsubst %,$(HERE)/%,$(SCRIPT_PERL))
+ INSTLIBDIR=$(shell $(MAKE) -C $(GIT_ROOT_DIR)/perl \
+- -s --no-print-directory instlibdir)
++ -s --no-print-directory instvendorlibdir)
+ DESTDIR_SQ = $(subst ','\'',$(DESTDIR))
+ INSTLIBDIR_SQ = $(subst ','\'',$(INSTLIBDIR))
+
+diff --git a/perl/Makefile b/perl/Makefile
+index 15d96fc..91348c6 100644
+--- a/perl/Makefile
++++ b/perl/Makefile
+@@ -12,7 +12,7 @@ ifndef V
+ QUIET = @
+ endif
+
+-all install instlibdir: $(makfile)
++all install instlibdir instvendorlibdir: $(makfile)
+ $(QUIET)$(MAKE) -f $(makfile) $@
+
+ clean:
+diff --git a/perl/Makefile.PL b/perl/Makefile.PL
+index 3f29ba9..c0b3508 100644
+--- a/perl/Makefile.PL
++++ b/perl/Makefile.PL
+@@ -17,6 +17,8 @@ sub MY::postamble {
+ return <<'MAKE_FRAG';
+ instlibdir:
+ @echo '$(INSTALLSITELIB)'
++instvendorlibdir:
++ @echo '$(INSTALLVENDORLIB)'
+
+ ifneq (,$(DESTDIR))
+ ifeq (0,$(shell expr '$(MM_VERSION)' '>' 6.10))
diff --git a/dev-vcs/git/git-1.8.5.2.ebuild b/dev-vcs/git/git-1.8.5.2.ebuild
index 048f393a4764..eed3e55c1982 100644
--- a/dev-vcs/git/git-1.8.5.2.ebuild
+++ b/dev-vcs/git/git-1.8.5.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.8.5.2.ebuild,v 1.1 2013/12/18 12:19:16 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.8.5.2.ebuild,v 1.2 2014/01/04 22:35:55 dilfridge Exp $
EAPI=5
@@ -40,14 +40,14 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg gtk highlight +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg gtk highlight +iconv mediawiki +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
dev-libs/openssl
sys-libs/zlib
pcre? ( dev-libs/libpcre )
- perl? ( dev-lang/perl[-build(-)] )
+ perl? ( dev-lang/perl:=[-build(-)] )
tk? ( dev-lang/tk )
curl? (
net-misc/curl
@@ -58,6 +58,7 @@ CDEPEND="
RDEPEND="${CDEPEND}
gpg? ( app-crypt/gnupg )
+ mediawiki? ( dev-perl/MediaWiki-API )
perl? ( dev-perl/Error
dev-perl/Net-SMTP-SSL
dev-perl/Authen-SASL
@@ -100,6 +101,7 @@ S="${WORKDIR}/${MY_P}"
REQUIRED_USE="
cgi? ( perl )
cvs? ( perl )
+ mediawiki? ( perl )
subversion? ( perl )
webdav? ( curl )
gtk? ( python )
@@ -222,6 +224,13 @@ src_prepare() {
# bug #350330 - automagic CVS when we don't want it is bad.
epatch "${FILESDIR}"/git-1.8.5-optional-cvs.patch
+ # honor and correctly quote DISTDIR (from upstream git master)
+ epatch "${FILESDIR}"/git-1.8.5-mw-destdir.patch
+
+ # install mediawiki perl modules also in vendor_dir
+ # hack, needs better upstream solution
+ epatch "${FILESDIR}"/git-1.8.5-mw-vendor.patch
+
sed -i \
-e 's:^\(CFLAGS[[:space:]]*=\).*$:\1 $(OPTCFLAGS) -Wall:' \
-e 's:^\(LDFLAGS[[:space:]]*=\).*$:\1 $(OPTLDFLAGS):' \
@@ -329,6 +338,11 @@ src_compile() {
cd "${S}"/contrib/subtree
git_emake
use doc && git_emake doc
+
+ if use mediawiki ; then
+ cd "${S}"/contrib/mw-to-git
+ git_emake
+ fi
}
src_install() {
@@ -390,6 +404,12 @@ src_install() {
dodoc git-subtree.txt
cd "${S}"
+ if use mediawiki ; then
+ cd "${S}"/contrib/mw-to-git
+ git_emake install
+ cd "${S}"
+ fi
+
# git-diffall
dobin contrib/diffall/git-diffall
newdoc contrib/diffall/README git-diffall.txt
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 4d4ee50fc370..ddf19afb635c 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.50 2013/12/11 10:27:22 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.51 2014/01/04 22:35:55 dilfridge Exp $
EAPI=5
@@ -40,14 +40,14 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg gtk highlight +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg gtk highlight +iconv mediawiki +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
dev-libs/openssl
sys-libs/zlib
pcre? ( dev-libs/libpcre )
- perl? ( dev-lang/perl[-build(-)] )
+ perl? ( dev-lang/perl:=[-build(-)] )
tk? ( dev-lang/tk )
curl? (
net-misc/curl
@@ -58,6 +58,7 @@ CDEPEND="
RDEPEND="${CDEPEND}
gpg? ( app-crypt/gnupg )
+ mediawiki? ( dev-perl/MediaWiki-API )
perl? ( dev-perl/Error
dev-perl/Net-SMTP-SSL
dev-perl/Authen-SASL
@@ -100,6 +101,7 @@ S="${WORKDIR}/${MY_P}"
REQUIRED_USE="
cgi? ( perl )
cvs? ( perl )
+ mediawiki? ( perl )
subversion? ( perl )
webdav? ( curl )
gtk? ( python )
@@ -222,6 +224,10 @@ src_prepare() {
# bug #350330 - automagic CVS when we don't want it is bad.
epatch "${FILESDIR}"/git-1.8.5-optional-cvs.patch
+ # install mediawiki perl modules also in vendor_dir
+ # hack, needs better upstream solution
+ epatch "${FILESDIR}"/git-1.8.5-mw-vendor.patch
+
sed -i \
-e 's:^\(CFLAGS[[:space:]]*=\).*$:\1 $(OPTCFLAGS) -Wall:' \
-e 's:^\(LDFLAGS[[:space:]]*=\).*$:\1 $(OPTLDFLAGS):' \
@@ -329,6 +335,11 @@ src_compile() {
cd "${S}"/contrib/subtree
git_emake
use doc && git_emake doc
+
+ if use mediawiki ; then
+ cd "${S}"/contrib/mw-to-git
+ git_emake
+ fi
}
src_install() {
@@ -390,6 +401,12 @@ src_install() {
dodoc git-subtree.txt
cd "${S}"
+ if use mediawiki ; then
+ cd "${S}"/contrib/mw-to-git
+ git_emake install
+ cd "${S}"
+ fi
+
# git-diffall
dobin contrib/diffall/git-diffall
newdoc contrib/diffall/README git-diffall.txt
diff --git a/dev-vcs/git/metadata.xml b/dev-vcs/git/metadata.xml
index 106f3a85dabe..6f4d4eeaa37f 100644
--- a/dev-vcs/git/metadata.xml
+++ b/dev-vcs/git/metadata.xml
@@ -33,6 +33,7 @@
<flag name="gpg">Pull in gnupg for signing -- without gnupg, attempts at signing will fail at runtime!</flag>
<flag name="gtk">Include the gitview contrib tool</flag>
<flag name="highlight">GitWeb support for app-text/highlight</flag>
+ <flag name="mediawiki">Support pulling and pushing from MediaWiki</flag>
<flag name="ppcsha1">Make use of a bundled routine that is optimized for the PPC arch</flag>
<flag name="subversion">Include git-svn for <pkg>dev-vcs/subversion</pkg> support</flag>
<flag name="webdav">Adds support for push'ing to HTTP/HTTPS repositories via DAV</flag>