summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-20 12:44:43 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-20 12:44:43 +0000
commiteb27542dfacbd84af0c8489f141fa447f2c21183 (patch)
tree432110f5363edd1c1363f25294cb155e6a3f22ba /dev-vcs/cvsps
parentVersion bump fixing tests, a lot of bugs and allowing Google Contacts' user d... (diff)
downloadgentoo-2-eb27542dfacbd84af0c8489f141fa447f2c21183.tar.gz
gentoo-2-eb27542dfacbd84af0c8489f141fa447f2c21183.tar.bz2
gentoo-2-eb27542dfacbd84af0c8489f141fa447f2c21183.zip
Respect CC, #243992
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/cvsps')
-rw-r--r--dev-vcs/cvsps/ChangeLog8
-rw-r--r--dev-vcs/cvsps/cvsps-2.1-r1.ebuild8
-rw-r--r--dev-vcs/cvsps/cvsps-2.1.ebuild8
3 files changed, 16 insertions, 8 deletions
diff --git a/dev-vcs/cvsps/ChangeLog b/dev-vcs/cvsps/ChangeLog
index 5daf411669dc..d8e1a56d1c55 100644
--- a/dev-vcs/cvsps/ChangeLog
+++ b/dev-vcs/cvsps/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/cvsps
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvsps/ChangeLog,v 1.3 2010/10/19 05:33:59 leio Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvsps/ChangeLog,v 1.4 2011/04/20 12:44:43 jlec Exp $
+
+ 20 Apr 2011; Justin Lecher <jlec@gentoo.org> cvsps-2.1.ebuild,
+ cvsps-2.1-r1.ebuild:
+ Respect CC, #243992
19 Oct 2010; Mart Raudsepp <leio@gentoo.org> cvsps-2.1.ebuild:
Drop to ~mips
diff --git a/dev-vcs/cvsps/cvsps-2.1-r1.ebuild b/dev-vcs/cvsps/cvsps-2.1-r1.ebuild
index c39ce9da6459..7c9134a113b7 100644
--- a/dev-vcs/cvsps/cvsps-2.1-r1.ebuild
+++ b/dev-vcs/cvsps/cvsps-2.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvsps/cvsps-2.1-r1.ebuild,v 1.2 2010/09/03 12:30:58 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvsps/cvsps-2.1-r1.ebuild,v 1.3 2011/04/20 12:44:43 jlec Exp $
-inherit eutils
+inherit eutils toolchain-funcs
MY_P="${P/_/}"
DESCRIPTION="Generates patchset information from a CVS repository"
@@ -15,6 +15,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
IUSE=""
DEPEND="sys-libs/zlib"
+RDPEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -27,6 +28,7 @@ src_unpack() {
if [[ ${CHOST} == *-solaris* ]] ; then
sed -i -e '/^LDLIBS+=/s/$/ -lsocket/' Makefile || die
fi
+ tc-export CC
}
src_install() {
diff --git a/dev-vcs/cvsps/cvsps-2.1.ebuild b/dev-vcs/cvsps/cvsps-2.1.ebuild
index d703d1e9797a..e576965fac73 100644
--- a/dev-vcs/cvsps/cvsps-2.1.ebuild
+++ b/dev-vcs/cvsps/cvsps-2.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvsps/cvsps-2.1.ebuild,v 1.2 2010/10/19 05:33:59 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvsps/cvsps-2.1.ebuild,v 1.3 2011/04/20 12:44:43 jlec Exp $
-inherit eutils
+inherit eutils toolchain-funcs
MY_P="${P/_/}"
DESCRIPTION="Generates patchset information from a CVS repository"
@@ -15,6 +15,7 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbs
IUSE=""
DEPEND="sys-libs/zlib"
+RDPEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -22,6 +23,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-build.patch
+ tc-export CC
}
src_install() {