summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-03-10 09:55:02 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-03-10 09:55:02 +0000
commit05b4daf09bb9768c09321db2cc9485673f060a9b (patch)
tree6c593e7c023cbca665a56c3bfaa59f08ee9c2bde /dev-tex/hevea
parentremove old (diff)
downloadgentoo-2-05b4daf09bb9768c09321db2cc9485673f060a9b.tar.gz
gentoo-2-05b4daf09bb9768c09321db2cc9485673f060a9b.tar.bz2
gentoo-2-05b4daf09bb9768c09321db2cc9485673f060a9b.zip
version bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-tex/hevea')
-rw-r--r--dev-tex/hevea/ChangeLog7
-rw-r--r--dev-tex/hevea/hevea-2.03.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-tex/hevea/ChangeLog b/dev-tex/hevea/ChangeLog
index 790d2ff3ff6f..68b07019a5af 100644
--- a/dev-tex/hevea/ChangeLog
+++ b/dev-tex/hevea/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/hevea
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/hevea/ChangeLog,v 1.37 2013/03/10 09:51:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/hevea/ChangeLog,v 1.38 2013/03/10 09:55:02 aballier Exp $
+
+*hevea-2.03 (10 Mar 2013)
+
+ 10 Mar 2013; Alexis Ballier <aballier@gentoo.org> +hevea-2.03.ebuild:
+ version bump
10 Mar 2013; Alexis Ballier <aballier@gentoo.org> hevea-2.02.ebuild:
eapi5: slot dep on ocaml
diff --git a/dev-tex/hevea/hevea-2.03.ebuild b/dev-tex/hevea/hevea-2.03.ebuild
new file mode 100644
index 000000000000..2d1f7f74bf1f
--- /dev/null
+++ b/dev-tex/hevea/hevea-2.03.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/hevea/hevea-2.03.ebuild,v 1.1 2013/03/10 09:55:02 aballier Exp $
+
+EAPI=5
+
+inherit eutils multilib
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="HeVeA is a quite complete and fast LaTeX to HTML translator"
+HOMEPAGE="http://hevea.inria.fr/"
+SRC_URI="http://hevea.inria.fr/distri/${P}.tar.gz"
+
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ rm -f config.sh
+ emake PREFIX=/usr DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)/hevea" LATEXLIBDIR="/usr/share/texmf-site/tex/latex/hevea" config.sh || die "Failed to create config.sh"
+ if use ocamlopt; then
+ emake PREFIX=/usr || die "Failed to build native code binaries"
+ else
+ emake PREFIX=/usr TARGET=byte || die "Failed to build bytecode binaries"
+ fi
+}
+
+src_install() {
+ if use ocamlopt; then
+ emake DESTDIR="${D}" PREFIX=/usr install || die "Install failed"
+ else
+ emake DESTDIR="${D}" PREFIX=/usr TARGET=byte install || die "Install failed"
+ fi
+
+ dodoc README CHANGES
+}
+
+# If texmf-update is present this means we have a latex install; update it so
+# that hevea.sty can be found
+# Do not (r)depend on latex though because hevea does not need it itself
+# If latex is installed later, it will see hevea.sty
+
+pkg_postinst() {
+ if [ "$ROOT" = "/" ] && [ -x /usr/sbin/texmf-update ] ; then
+ /usr/sbin/texmf-update
+ fi
+}
+
+pkg_postrm() {
+ if [ "$ROOT" = "/" ] && [ -x /usr/sbin/texmf-update ] ; then
+ /usr/sbin/texmf-update
+ fi
+}