summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-01-25 17:53:16 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-01-25 17:53:16 +0000
commit8a628a21529fc2af64684f49ff9f950fe1753569 (patch)
treed615e3ccd7cd09d79a6e69bcb6175c3cbab6d28a /dev-scheme
parentFixing compilation of paludis-0.16.0 (when using =gcc-3.4*), bug #163729. (diff)
downloadgentoo-2-8a628a21529fc2af64684f49ff9f950fe1753569.tar.gz
gentoo-2-8a628a21529fc2af64684f49ff9f950fe1753569.tar.bz2
gentoo-2-8a628a21529fc2af64684f49ff9f950fe1753569.zip
fix missing '\' from configure causing all options and use flags to be ignored
(Portage version: 2.1.2-r2)
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/guile/ChangeLog7
-rw-r--r--dev-scheme/guile/files/digest-guile-1.8.1-r1 (renamed from dev-scheme/guile/files/digest-guile-1.8.1)0
-rw-r--r--dev-scheme/guile/guile-1.8.1-r1.ebuild53
3 files changed, 59 insertions, 1 deletions
diff --git a/dev-scheme/guile/ChangeLog b/dev-scheme/guile/ChangeLog
index 3bb4dfb482bb..85d0324266ed 100644
--- a/dev-scheme/guile/ChangeLog
+++ b/dev-scheme/guile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/guile
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/ChangeLog,v 1.3 2007/01/22 18:24:37 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/ChangeLog,v 1.4 2007/01/25 17:53:16 hkbst Exp $
+
+*guile-1.8.1-r1 (25 Jan 2007)
+
+ 25 Jan 2007; Marijn Schouten <hkBst@gentoo.org> +guile-1.8.1-r1.ebuild:
+ fix missing \ from configure causing all options and use flags to be ignored
*guile-1.8.1 (22 Jan 2007)
diff --git a/dev-scheme/guile/files/digest-guile-1.8.1 b/dev-scheme/guile/files/digest-guile-1.8.1-r1
index 1b93a92fe5ec..1b93a92fe5ec 100644
--- a/dev-scheme/guile/files/digest-guile-1.8.1
+++ b/dev-scheme/guile/files/digest-guile-1.8.1-r1
diff --git a/dev-scheme/guile/guile-1.8.1-r1.ebuild b/dev-scheme/guile/guile-1.8.1-r1.ebuild
new file mode 100644
index 000000000000..54fbcc8837e5
--- /dev/null
+++ b/dev-scheme/guile/guile-1.8.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.1-r1.ebuild,v 1.1 2007/01/25 17:53:16 hkbst Exp $
+
+inherit autotools
+
+DESCRIPTION="Scheme interpreter"
+HOMEPAGE="http://www.gnu.org/software/guile/"
+SRC_URI="mirror://gnu/guile/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DEPEND=">=dev-libs/gmp-4.1
+ >=sys-devel/libtool-1.5.6"
+
+# Guile seems to contain some slotting support, /usr/share/guile/ is slotted, but there are lots of collisions. Most in /usr/share/libguile. Therefore I'm slotting this in the same slot as guile-1.6* for now.
+SLOT="12"
+MAJOR="1.8"
+
+IUSE="networking regex discouraged deprecated elisp nls debug-freelist debug-malloc debug threads"
+
+src_compile() {
+#will fail for me if posix is disabled or without modules -- hkBst
+ econf \
+ --disable-error-on-warning \
+ --disable-static \
+ --enable-posix \
+ $(use_enable networking) \
+ $(use_enable regex) \
+ $(use_enable discouraged) \
+ $(use_enable deprecated) \
+ $(use_enable elisp) \
+ $(use_enable nls) \
+ --disable-rpath \
+ $(use_enable debug-freelist) \
+ $(use_enable debug-malloc) \
+ $(use_enable debug guile-debug) \
+ $(use_with threads) \
+ --with-modules
+
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die "install failed"
+
+ dodoc AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README SNAPSHOTS THANKS
+
+ # texmacs needs this, closing bug #23493
+ dodir /etc/env.d
+ echo "GUILE_LOAD_PATH=\"/usr/share/guile/${MAJOR}\"" > ${D}/etc/env.d/50guile
+} \ No newline at end of file