summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-05-27 05:48:34 +0000
committerHans de Graaff <graaff@gentoo.org>2010-05-27 05:48:34 +0000
commit1db227b18ae563815f0675ba6ee865f49d806a99 (patch)
tree3685f26525447b61cd1acb99145a173d5fa11506 /dev-ruby/will_paginate
parentVersion bump. Dropped old. (diff)
downloadgentoo-2-1db227b18ae563815f0675ba6ee865f49d806a99.tar.gz
gentoo-2-1db227b18ae563815f0675ba6ee865f49d806a99.tar.bz2
gentoo-2-1db227b18ae563815f0675ba6ee865f49d806a99.zip
Better compatibility with Rails 2.3.8. Remove specific rack dependency since tests now work fine with rack 1.1.x.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/will_paginate')
-rw-r--r--dev-ruby/will_paginate/ChangeLog9
-rw-r--r--dev-ruby/will_paginate/will_paginate-2.3.14.ebuild22
2 files changed, 30 insertions, 1 deletions
diff --git a/dev-ruby/will_paginate/ChangeLog b/dev-ruby/will_paginate/ChangeLog
index bac5b0dd8af8..265caf2a1d88 100644
--- a/dev-ruby/will_paginate/ChangeLog
+++ b/dev-ruby/will_paginate/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/will_paginate
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/will_paginate/ChangeLog,v 1.4 2010/04/19 22:02:14 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/will_paginate/ChangeLog,v 1.5 2010/05/27 05:48:34 graaff Exp $
+
+*will_paginate-2.3.14 (27 May 2010)
+
+ 27 May 2010; Hans de Graaff <graaff@gentoo.org>
+ +will_paginate-2.3.14.ebuild:
+ Better compatibility with Rails 2.3.8. Remove specific rack dependency
+ since tests now work fine with rack 1.1.x.
19 Apr 2010; Diego E. Pettenò <flameeyes@gentoo.org>
will_paginate-2.3.12.ebuild:
diff --git a/dev-ruby/will_paginate/will_paginate-2.3.14.ebuild b/dev-ruby/will_paginate/will_paginate-2.3.14.ebuild
new file mode 100644
index 000000000000..faa544b05d7e
--- /dev/null
+++ b/dev-ruby/will_paginate/will_paginate-2.3.14.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/will_paginate/will_paginate-2.3.14.ebuild,v 1.1 2010/05/27 05:48:34 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Most awesome pagination solution for Ruby "
+HOMEPAGE="http://github.com/mislav/will_paginate/"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/mocha dev-ruby/rack )"
+ruby_add_rdepend '>=dev-ruby/activesupport-1.4.4'