summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-01-15 17:01:34 +0000
committerHans de Graaff <graaff@gentoo.org>2011-01-15 17:01:34 +0000
commit1255469e6ba42aa006c7b65aecd315ca4564c856 (patch)
tree465468821637f81d825f207d60d00b12dce37808 /dev-ruby/rspec-expectations
parentVersion bumped, bug #336497. (diff)
downloadgentoo-2-1255469e6ba42aa006c7b65aecd315ca4564c856.tar.gz
gentoo-2-1255469e6ba42aa006c7b65aecd315ca4564c856.tar.bz2
gentoo-2-1255469e6ba42aa006c7b65aecd315ca4564c856.zip
Version bump for RSpec 2.4.0.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rspec-expectations')
-rw-r--r--dev-ruby/rspec-expectations/ChangeLog10
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.4.0.ebuild45
2 files changed, 53 insertions, 2 deletions
diff --git a/dev-ruby/rspec-expectations/ChangeLog b/dev-ruby/rspec-expectations/ChangeLog
index 48bc63aa8235..5fef622b16c1 100644
--- a/dev-ruby/rspec-expectations/ChangeLog
+++ b/dev-ruby/rspec-expectations/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec-expectations
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.4 2010/12/27 20:56:27 grobian Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.5 2011/01/15 17:01:34 graaff Exp $
+
+*rspec-expectations-2.4.0 (15 Jan 2011)
+
+ 15 Jan 2011; Hans de Graaff <graaff@gentoo.org>
+ +rspec-expectations-2.4.0.ebuild:
+ Version bump for RSpec 2.4.0.
27 Dec 2010; Fabian Groffen <grobian@gentoo.org>
rspec-expectations-2.0.0_beta22.ebuild:
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.4.0.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.4.0.ebuild
new file mode 100644
index 000000000000..7d0a0c3990d1
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-2.4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-2.4.0.ebuild,v 1.1 2011/01/15 17:01:34 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md Upgrade.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.1.2"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-core-2.4.0:2
+ dev-ruby/rspec-mocks:2
+ )"
+
+# Not clear yet to what extend we need those (now)
+# >=dev-ruby/cucumber-0.6.2
+# >=dev-ruby/aruba-0.1.1"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -S rake spec
+
+ # There are features but they require aruba which we don't have yet.
+}