summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-28 07:24:44 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-28 07:24:44 +0000
commitd9f654cb3dabee82b72c562c40e727c705f0dcd2 (patch)
tree1d1410e4d9921a6c7d85185137918f5612c406d4 /dev-ruby/actionpack
parentVersion bump for Rails 3.0.10 (diff)
downloadgentoo-2-d9f654cb3dabee82b72c562c40e727c705f0dcd2.tar.gz
gentoo-2-d9f654cb3dabee82b72c562c40e727c705f0dcd2.tar.bz2
gentoo-2-d9f654cb3dabee82b72c562c40e727c705f0dcd2.zip
Version bump for Rails 3.0.10
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/actionpack')
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-3.0.10.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 0c54f292579b..fb9e659ca740 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.192 2011/09/09 08:09:35 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.193 2011/09/28 07:24:44 graaff Exp $
+
+*actionpack-3.0.10 (28 Sep 2011)
+
+ 28 Sep 2011; Hans de Graaff <graaff@gentoo.org> +actionpack-3.0.10.ebuild:
+ Version bump for Rails 3.0.10
09 Sep 2011; Fabian Groffen <grobian@gentoo.org> actionpack-3.0.9.ebuild:
Marked ~sparc-solaris
diff --git a/dev-ruby/actionpack/actionpack-3.0.10.ebuild b/dev-ruby/actionpack/actionpack-3.0.10.ebuild
new file mode 100644
index 000000000000..44eacc336a73
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-3.0.10.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-3.0.10.ebuild,v 1.1 2011/09/28 07:24:44 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionpack"
+
+ruby_add_rdepend "
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-2.1.2:0
+ >=dev-ruby/erubis-2.6.6
+ >=dev-ruby/i18n-0.5.0:0.5
+ >=dev-ruby/rack-1.2.1:1.2
+ >=dev-ruby/rack-mount-0.6.14:0.6
+ >=dev-ruby/rack-test-0.5.7:0.5
+ >=dev-ruby/tzinfo-0.3.23"
+
+ruby_add_bdepend "
+ test? (
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Loosen erubis dependency since this is not slotted.
+ sed -i -e 's/~> 2.6.6/>= 2.6.6/' actionpack.gemspec || die
+}