summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-30 23:54:02 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-30 23:54:02 +0000
commit9caa446aa2239e2ceca566c064a4e9710dbc9b8c (patch)
tree8eb2545fcd35f7afbcf17240e39ab1afa5c62974 /dev-python
parentVersion bump for Gnome 3.14, bug #534040. (diff)
downloadgentoo-2-9caa446aa2239e2ceca566c064a4e9710dbc9b8c.tar.gz
gentoo-2-9caa446aa2239e2ceca566c064a4e9710dbc9b8c.tar.bz2
gentoo-2-9caa446aa2239e2ceca566c064a4e9710dbc9b8c.zip
revbump; conversion -> distutils-r1
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/iconvcodec/ChangeLog10
-rw-r--r--dev-python/iconvcodec/iconvcodec-1.1.2-r1.ebuild26
2 files changed, 33 insertions, 3 deletions
diff --git a/dev-python/iconvcodec/ChangeLog b/dev-python/iconvcodec/ChangeLog
index 57a95ba2fdcf..3b45f859d6af 100644
--- a/dev-python/iconvcodec/ChangeLog
+++ b/dev-python/iconvcodec/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/iconvcodec
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/iconvcodec/ChangeLog,v 1.12 2012/02/25 22:25:30 marienz Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/iconvcodec/ChangeLog,v 1.13 2014/12/30 23:54:02 idella4 Exp $
+
+*iconvcodec-1.1.2-r1 (30 Dec 2014)
+
+ 30 Dec 2014; Ian Delaney <idella4@gentoo.org> +iconvcodec-1.1.2-r1.ebuild:
+ revbump; conversion -> distutils-r1
25 Feb 2012; Marien Zwart <marienz@gentoo.org> iconvcodec-1.1.2.ebuild:
Restrict pypy, see comment in the ebuild.
@@ -41,4 +46,3 @@
28 Jun 2003; Alastair Tse <liquidx@gentoo.org> iconvcodec-1.1.1.ebuild:
iconv codecs for python
-
diff --git a/dev-python/iconvcodec/iconvcodec-1.1.2-r1.ebuild b/dev-python/iconvcodec/iconvcodec-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..909818168cd6
--- /dev/null
+++ b/dev-python/iconvcodec/iconvcodec-1.1.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/iconvcodec/iconvcodec-1.1.2-r1.ebuild,v 1.1 2014/12/30 23:54:02 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Codecs for Iconv Encodings"
+HOMEPAGE="http://cjkpython.i18n.org/"
+SRC_URI="mirror://berlios/cjkpython/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PYTHON_MODNAME="iconv_codec.py"
+
+src_compile() {
+ distutils-r1_src_compile --with-libc
+}