summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-02-07 23:40:47 +0000
committerMike Gilbert <floppym@gentoo.org>2013-02-07 23:40:47 +0000
commit090a6d5bc6a9ae0b79ebcf6c1a320fa3b68dbd43 (patch)
tree7bcbf2034f01b223e50ba30b2f10b6a2298ee934 /dev-python
parentMove Creative Commons licenses to shorter names. (diff)
downloadgentoo-2-090a6d5bc6a9ae0b79ebcf6c1a320fa3b68dbd43.tar.gz
gentoo-2-090a6d5bc6a9ae0b79ebcf6c1a320fa3b68dbd43.tar.bz2
gentoo-2-090a6d5bc6a9ae0b79ebcf6c1a320fa3b68dbd43.zip
Apply encoding fix and disable strict aliasing in the latest ebuild.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/http-parser/ChangeLog5
-rw-r--r--dev-python/http-parser/http-parser-0.7.12.ebuild14
2 files changed, 16 insertions, 3 deletions
diff --git a/dev-python/http-parser/ChangeLog b/dev-python/http-parser/ChangeLog
index 530a545163ac..546f8b08c405 100644
--- a/dev-python/http-parser/ChangeLog
+++ b/dev-python/http-parser/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/http-parser
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/http-parser/ChangeLog,v 1.8 2013/01/21 11:21:51 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/http-parser/ChangeLog,v 1.9 2013/02/07 23:40:47 floppym Exp $
+
+ 07 Feb 2013; Mike Gilbert <floppym@gentoo.org> http-parser-0.7.12.ebuild:
+ Apply encoding fix and disable strict aliasing in the latest ebuild.
21 Jan 2013; Agostino Sarubbo <ago@gentoo.org> http-parser-0.7.8.ebuild:
Stable for x86, wrt bug #451608
diff --git a/dev-python/http-parser/http-parser-0.7.12.ebuild b/dev-python/http-parser/http-parser-0.7.12.ebuild
index 5fbd018ccfe5..90a9b09d51ac 100644
--- a/dev-python/http-parser/http-parser-0.7.12.ebuild
+++ b/dev-python/http-parser/http-parser-0.7.12.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/http-parser/http-parser-0.7.12.ebuild,v 1.2 2013/01/12 15:53:33 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/http-parser/http-parser-0.7.12.ebuild,v 1.3 2013/02/07 23:40:47 floppym Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2} pypy{1_9,2_0} )
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
DESCRIPTION="HTTP request/response parser for python in C"
HOMEPAGE="http://github.com/benoitc/http-parser"
@@ -22,6 +22,16 @@ DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/cython"
+PATCHES=( "${FILESDIR}/${PN}-0.7.8-setup.patch" )
+
+python_compile() {
+ if [[ ${EPYTHON} != python3* ]]; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
src_install() {
distutils-r1_src_install
if use examples; then