summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-16 10:57:09 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-16 10:57:09 +0000
commit3151a509019a0faead2bc3c6da0e4e4336bf872a (patch)
treea8c90724c16edd001103b2afcfd9ead8365cd627 /dev-python/whoosh
parentdev-vcs/git-cola: Fix tests and docs (diff)
downloadgentoo-2-3151a509019a0faead2bc3c6da0e4e4336bf872a.tar.gz
gentoo-2-3151a509019a0faead2bc3c6da0e4e4336bf872a.tar.bz2
gentoo-2-3151a509019a0faead2bc3c6da0e4e4336bf872a.zip
rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/whoosh')
-rw-r--r--dev-python/whoosh/ChangeLog8
-rw-r--r--dev-python/whoosh/whoosh-2.4.1.ebuild35
-rw-r--r--dev-python/whoosh/whoosh-2.5.7.ebuild41
3 files changed, 6 insertions, 78 deletions
diff --git a/dev-python/whoosh/ChangeLog b/dev-python/whoosh/ChangeLog
index bd3c9be81213..d5290c9eb231 100644
--- a/dev-python/whoosh/ChangeLog
+++ b/dev-python/whoosh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/whoosh
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/whoosh/ChangeLog,v 1.25 2014/12/28 12:09:11 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/whoosh/ChangeLog,v 1.26 2015/01/16 10:57:09 idella4 Exp $
+
+ 16 Jan 2015; Ian Delaney <idella4@gentoo.org> -whoosh-2.4.1.ebuild,
+ -whoosh-2.5.7.ebuild:
+ rm old
28 Dec 2014; Agostino Sarubbo <ago@gentoo.org> whoosh-2.6.0.ebuild:
Stable for x86, wrt bug #531028
diff --git a/dev-python/whoosh/whoosh-2.4.1.ebuild b/dev-python/whoosh/whoosh-2.4.1.ebuild
deleted file mode 100644
index 3106f7397582..000000000000
--- a/dev-python/whoosh/whoosh-2.4.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/whoosh/whoosh-2.4.1.ebuild,v 1.7 2012/12/16 16:20:10 ago Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="*:2.6"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="setup.py"
-PYTHON_MODNAME="whoosh"
-RESTRICT_PYTHON_ABIS="2.5 2.5-jython"
-
-MY_PN="Whoosh"
-
-inherit distutils
-
-DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library"
-HOMEPAGE="http://bitbucket.org/mchaput/whoosh/wiki/Home/ http://pypi.python.org/pypi/Whoosh/"
-SRC_URI="mirror://pypi/W/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- insinto "/usr/share/doc/${PF}/"
- doins -r docs/build/html/_sources/* || die
- fi
-}
diff --git a/dev-python/whoosh/whoosh-2.5.7.ebuild b/dev-python/whoosh/whoosh-2.5.7.ebuild
deleted file mode 100644
index 5b89f934610a..000000000000
--- a/dev-python/whoosh/whoosh-2.5.7.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/whoosh/whoosh-2.5.7.ebuild,v 1.4 2014/11/27 11:48:16 idella4 Exp $
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-MY_PN="Whoosh"
-
-inherit distutils-r1
-
-DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library"
-HOMEPAGE="http://bitbucket.org/mchaput/whoosh/wiki/Home/ http://pypi.python.org/pypi/Whoosh/"
-SRC_URI="mirror://pypi/W/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_prepare_all() {
- # (backport from upstream)
- sed -i -e '/cmdclass/s:pytest:PyTest:' setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- local DOCS=( README.txt )
- use doc && local HTML_DOCS=( docs/build/html/_sources/. )
- distutils-r1_python_install_all
-}
-
-python_test() {
- esetup.py test
-}