summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-01 19:56:22 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-01 19:56:22 +0000
commit66f798b04473be57c015c05733cbc18f411e3e13 (patch)
treee182b5c91a553bc4f14f6c702d28e46352139d5f /dev-python/pythondialog
parentNot sparc (diff)
downloadgentoo-2-66f798b04473be57c015c05733cbc18f411e3e13.tar.gz
gentoo-2-66f798b04473be57c015c05733cbc18f411e3e13.tar.bz2
gentoo-2-66f798b04473be57c015c05733cbc18f411e3e13.zip
Fix dependencies. Set SUPPORT_PYTHON_ABIS.
(Portage version: 2.2.0_alpha11_p6/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pythondialog')
-rw-r--r--dev-python/pythondialog/ChangeLog8
-rw-r--r--dev-python/pythondialog/pythondialog-2.7.ebuild26
2 files changed, 22 insertions, 12 deletions
diff --git a/dev-python/pythondialog/ChangeLog b/dev-python/pythondialog/ChangeLog
index 2538bf604007..355215de1ec8 100644
--- a/dev-python/pythondialog/ChangeLog
+++ b/dev-python/pythondialog/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pythondialog
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pythondialog/ChangeLog,v 1.16 2006/08/21 18:17:26 wolf31o2 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythondialog/ChangeLog,v 1.17 2011/01/01 19:56:22 arfrever Exp $
+
+ 01 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pythondialog-2.7.ebuild:
+ Fix dependencies. Set SUPPORT_PYTHON_ABIS.
21 Aug 2006; Chris Gianelloni <wolf31o2@gentoo.org>
pythondialog-2.7.ebuild:
diff --git a/dev-python/pythondialog/pythondialog-2.7.ebuild b/dev-python/pythondialog/pythondialog-2.7.ebuild
index d042296988e5..16212a6cb829 100644
--- a/dev-python/pythondialog/pythondialog-2.7.ebuild
+++ b/dev-python/pythondialog/pythondialog-2.7.ebuild
@@ -1,23 +1,29 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pythondialog/pythondialog-2.7.ebuild,v 1.10 2006/08/21 18:17:26 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythondialog/pythondialog-2.7.ebuild,v 1.11 2011/01/01 19:56:22 arfrever Exp $
-inherit eutils distutils
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
DESCRIPTION="A Python module for making simple text/console-mode user interfaces."
HOMEPAGE="http://pythondialog.sourceforge.net/"
SRC_URI="mirror://sourceforge/pythondialog/${PF}.tar.bz2"
+LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc sparc x86"
-LICENSE="LGPL-2"
IUSE=""
-DEPEND="virtual/python
- dev-util/dialog"
+DEPEND="dev-util/dialog"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="dialog.py"
-src_unpack() {
- unpack ${A}
- cd ${S}
- sed -ie "s:/usr/local:/usr:g" setup.cfg
+src_prepare() {
+ distutils_src_prepare
+ sed -e "/^prefix=/d" -i setup.cfg || die "sed failed"
}