summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda XU <heroxbd@gentoo.org>2013-08-30 10:49:59 +0000
committerBenda XU <heroxbd@gentoo.org>2013-08-30 10:49:59 +0000
commit3d561fe063396b298f73b5226026544cb3c677fb (patch)
tree5e2a28774b067b5398b7f91192962af857cef330 /dev-python/pyplusplus
parentinitial commit (diff)
downloadgentoo-2-3d561fe063396b298f73b5226026544cb3c677fb.tar.gz
gentoo-2-3d561fe063396b298f73b5226026544cb3c677fb.tar.bz2
gentoo-2-3d561fe063396b298f73b5226026544cb3c677fb.zip
initial commit. bug 212014. Credits to k0001, yury and Ross for creating and refining the ebuild.
(Portage version: 2.2.0/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pyplusplus')
-rw-r--r--dev-python/pyplusplus/ChangeLog10
-rw-r--r--dev-python/pyplusplus/Manifest3
-rw-r--r--dev-python/pyplusplus/metadata.xml9
-rw-r--r--dev-python/pyplusplus/pyplusplus-1.0.0.ebuild46
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/pyplusplus/ChangeLog b/dev-python/pyplusplus/ChangeLog
new file mode 100644
index 000000000000..7650cebcb6e4
--- /dev/null
+++ b/dev-python/pyplusplus/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/pyplusplus
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyplusplus/ChangeLog,v 1.1 2013/08/30 10:49:59 heroxbd Exp $
+
+*pyplusplus-1.0.0 (30 Aug 2013)
+
+ 30 Aug 2013; Benda Xu <heroxbd@gentoo.org> +metadata.xml,
+ +pyplusplus-1.0.0.ebuild:
+ initial commit. bug 212014. Credits to k0001, yury and Ross for creating and
+ refining the ebuild.
diff --git a/dev-python/pyplusplus/Manifest b/dev-python/pyplusplus/Manifest
new file mode 100644
index 000000000000..e50f677653ea
--- /dev/null
+++ b/dev-python/pyplusplus/Manifest
@@ -0,0 +1,3 @@
+DIST pyplusplus-1.0.0.zip 7886416 SHA256 dc749514642846d85de148735b44c5f5e03dc0b62feceb0727698f4069d3c963 SHA512 04a9d6f06d8d22da9ac3b4ec1efdf001f0e4a2453ff5d70d6a15b808d7247ace630c4064ab2476a28ed3dede9cdb867c0650810a0c72a0a6474912fc7ef65812 WHIRLPOOL ab12d4c2432155226e66081f72007406c71da11aae5f7e2e4bf80e3e28680cef5ec0370a8fc442f86ed14793bc340f85d203903f348982d355f48f4a52c4f89a
+EBUILD pyplusplus-1.0.0.ebuild 920 SHA256 0e29b3946ed3b5735b07596e11c010d54f0b8bd3b22302c7b52c187f54497dea SHA512 ecc26e15b17b0632be83ae7c047d096cdaac2716490479b9b24a7ccfcb994e6da7b6bc1f31963969eb377acce3d254e3b04328928a93a147447e312c7d7a41d6 WHIRLPOOL a13f8a348a1df24dcd623d0af07965c9af7277d2752789d93acf70f10bd63dced166700060fd328c53ef30faef3403cff18af7500c21e3dc9a54e77cbdbc4a64
+MISC metadata.xml 363 SHA256 ec195dc684fced97f662ae7af30595946a8d73d577fcdcc1fc7199bab3a0e8cc SHA512 a3ed613fcf17698359dd8940b212e168b12b6375c12766abdf67645daa494d22421cd10071833845202c196942196c4fe3f835ac85115ab776808be9665278cc WHIRLPOOL 9aa102d7f2a4f71d19655ccdcef7df0d11861093e0e088e3ed470a3d223d0f12bdcf1ea4efbe47f0c3d028156bdb8b1c1b91e66f75efe4a8815948c77d864461
diff --git a/dev-python/pyplusplus/metadata.xml b/dev-python/pyplusplus/metadata.xml
new file mode 100644
index 000000000000..0a0f5ce66fc6
--- /dev/null
+++ b/dev-python/pyplusplus/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>heroxbd@gentoo.org</email>
+ <name>Benda Xu</name>
+ </maintainer>
+ <longdescription>pyplusplus is an object-oriented framework for creating a code generator for boost.python library.</longdescription>
+</pkgmetadata>
diff --git a/dev-python/pyplusplus/pyplusplus-1.0.0.ebuild b/dev-python/pyplusplus/pyplusplus-1.0.0.ebuild
new file mode 100644
index 000000000000..b1a9b36416a8
--- /dev/null
+++ b/dev-python/pyplusplus/pyplusplus-1.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyplusplus/pyplusplus-1.0.0.ebuild,v 1.1 2013/08/30 10:49:59 heroxbd Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Object-oriented framework for creating a code generator for Boost.Python library"
+HOMEPAGE="http://www.language-binding.net/"
+SRC_URI="mirror://sourceforge/pygccxml/${P}.zip"
+
+LICENSE="freedist Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND="doc? ( >=dev-python/epydoc-3 )
+ app-arch/unzip"
+RDEPEND="=dev-python/pygccxml-1.0.0"
+
+S=${WORKDIR}/Py++-${PV}
+
+python_compile_all() {
+ if use doc; then
+ python_export_best
+ "$(PYTHON)" setup.py doc
+ fi
+}
+
+python_test() {
+ "$(PYTHON)" unittests/test_all.py
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/documentation/apidocs/* )
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ distutils-r1_python_install_all
+}