summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-01-07 20:53:53 +0000
committerJeroen Roovers <jer@gentoo.org>2010-01-07 20:53:53 +0000
commit7bb32c54b3a6d2bbdd892ac0e818c4c7c5d1da43 (patch)
tree92d4f36c5c1e1876b40e5c6c614002f01386c475 /dev-python/pyparted
parentVersion bump. Set empty HOMEPAGE and LICENSE (diff)
downloadgentoo-2-7bb32c54b3a6d2bbdd892ac0e818c4c7c5d1da43.tar.gz
gentoo-2-7bb32c54b3a6d2bbdd892ac0e818c4c7c5d1da43.tar.bz2
gentoo-2-7bb32c54b3a6d2bbdd892ac0e818c4c7c5d1da43.zip
Add python_need_rebuild thanks to Ali Polatel (bug #244612). Use canonical CC. Update HOMEPAGE and SRC_URI.
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'dev-python/pyparted')
-rw-r--r--dev-python/pyparted/ChangeLog10
-rw-r--r--dev-python/pyparted/pyparted-1.8.9-r1.ebuild30
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-python/pyparted/ChangeLog b/dev-python/pyparted/ChangeLog
index a3c111e5ec77..bff18a2606cd 100644
--- a/dev-python/pyparted/ChangeLog
+++ b/dev-python/pyparted/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyparted
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.38 2009/04/24 16:08:31 arfrever Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.39 2010/01/07 20:53:53 jer Exp $
+
+*pyparted-1.8.9-r1 (07 Jan 2010)
+
+ 07 Jan 2010; Jeroen Roovers <jer@gentoo.org> +pyparted-1.8.9-r1.ebuild:
+ Add python_need_rebuild thanks to Ali Polatel (bug #244612). Use canonical
+ CC. Update HOMEPAGE and SRC_URI.
24 Apr 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-pyparted-1.6.9-r1.ebuild, -pyparted-1.7.0.ebuild:
diff --git a/dev-python/pyparted/pyparted-1.8.9-r1.ebuild b/dev-python/pyparted/pyparted-1.8.9-r1.ebuild
new file mode 100644
index 000000000000..f49ddae332c6
--- /dev/null
+++ b/dev-python/pyparted/pyparted-1.8.9-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-1.8.9-r1.ebuild,v 1.1 2010/01/07 20:53:53 jer Exp $
+
+inherit multilib python toolchain-funcs
+
+DESCRIPTION="Python bindings for parted"
+HOMEPAGE="https://fedorahosted.org/pyparted/"
+SRC_URI="https://fedorahosted.org/releases/p/y/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses
+ >=dev-lang/python-2.4
+ >=sys-apps/parted-1.7.0"
+
+src_compile() {
+ sed -i \
+ "s/\$(shell rpm --eval \"%{_libdir}\")/usr\/$(get_libdir)/" \
+ Makefile || die "cannot fix libdir"
+ emake CC=$(tc-getCC) || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog
+ python_need_rebuild
+}