summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-01-21 20:55:53 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-01-21 20:55:53 +0000
commit6eaed1c4d2a2c8cdc28bebf0ff40950d26b1ba6e (patch)
tree461b93c9cf3ff28bd19d725568e13c06d2785084 /dev-python/pyparted
parentAdded ~ppc. (diff)
downloadgentoo-2-6eaed1c4d2a2c8cdc28bebf0ff40950d26b1ba6e.tar.gz
gentoo-2-6eaed1c4d2a2c8cdc28bebf0ff40950d26b1ba6e.tar.bz2
gentoo-2-6eaed1c4d2a2c8cdc28bebf0ff40950d26b1ba6e.zip
Added -fPIC to allow successful compilation on amd64.
(Portage version: 2.0.51-r14)
Diffstat (limited to 'dev-python/pyparted')
-rw-r--r--dev-python/pyparted/ChangeLog6
-rw-r--r--dev-python/pyparted/pyparted-1.6.9.ebuild8
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-python/pyparted/ChangeLog b/dev-python/pyparted/ChangeLog
index 64bf12ceaeaf..05d80597fdc2 100644
--- a/dev-python/pyparted/ChangeLog
+++ b/dev-python/pyparted/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pyparted
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.8 2005/01/04 18:28:06 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.9 2005/01/21 20:55:53 cryos Exp $
+
+ 21 Jan 2005; Marcus D. Hanwell <cryos@gentoo.org> pyparted-1.6.9.ebuild:
+ Added append-flags -fPIC as this is needed for compilation on amd64. Applied
+ globally as this package only produces one shared object.
04 Jan 2005; Chris Gianelloni <wolf31o2@gentoo.org> pyparted-1.6.9.ebuild:
Marking stable on x86 and amd64 in preparation for 2005.0's release.
diff --git a/dev-python/pyparted/pyparted-1.6.9.ebuild b/dev-python/pyparted/pyparted-1.6.9.ebuild
index aaeaceaad4cd..cd9579a8b3fe 100644
--- a/dev-python/pyparted/pyparted-1.6.9.ebuild
+++ b/dev-python/pyparted/pyparted-1.6.9.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-1.6.9.ebuild,v 1.3 2005/01/04 18:28:06 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-1.6.9.ebuild,v 1.4 2005/01/21 20:55:53 cryos Exp $
RH_EXTRAVERSION="2"
-inherit eutils rpm
+inherit eutils rpm flag-o-matic
DESCRIPTION="Python bindings for parted"
HOMEPAGE="http://fedora.redhat.com"
@@ -24,6 +24,10 @@ src_unpack() {
src_compile() {
cd ${S}
+ # -fPIC needed for compilation on amd64, applied globally as only one shared
+ # lib is produced by this package.
+ append-flags -fPIC
+
# This is needed otherwise it won't build
# If anyone wants to figure out why... go ahead!
export LDFLAGS="-ldl"