summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-09-01 08:39:07 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-09-01 08:39:07 +0000
commit7cac46b299356309ce5c4897bf0ff61be1bdf7da (patch)
treedd5f27c6d5917b38b54c9066b5d75f8ca7d699da /dev-python/pyparsing
parent Fix installation of missing documentation. Closes bug #315811. (diff)
downloadgentoo-2-7cac46b299356309ce5c4897bf0ff61be1bdf7da.tar.gz
gentoo-2-7cac46b299356309ce5c4897bf0ff61be1bdf7da.tar.bz2
gentoo-2-7cac46b299356309ce5c4897bf0ff61be1bdf7da.zip
Version bump pyparsing to 1.5.5 (bug 335442).
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyparsing')
-rw-r--r--dev-python/pyparsing/ChangeLog7
-rw-r--r--dev-python/pyparsing/pyparsing-1.5.5.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/pyparsing/ChangeLog b/dev-python/pyparsing/ChangeLog
index e67ea3313bf8..a854aec85c62 100644
--- a/dev-python/pyparsing/ChangeLog
+++ b/dev-python/pyparsing/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyparsing
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparsing/ChangeLog,v 1.56 2010/08/28 17:10:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparsing/ChangeLog,v 1.57 2010/09/01 08:39:07 djc Exp $
+
+*pyparsing-1.5.5 (01 Sep 2010)
+
+ 01 Sep 2010; Dirkjan Ochtman <djc@gentoo.org> +pyparsing-1.5.5.ebuild:
+ Version bump to 1.5.5 (bug 335442).
28 Aug 2010; Raúl Porcel <armin76@gentoo.org> pyparsing-1.5.3.ebuild:
alpha/ia64/sparc stable wrt #330607
diff --git a/dev-python/pyparsing/pyparsing-1.5.5.ebuild b/dev-python/pyparsing/pyparsing-1.5.5.ebuild
new file mode 100644
index 000000000000..46b4b9f7ace0
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-1.5.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparsing/pyparsing-1.5.5.ebuild,v 1.1 2010/09/01 08:39:07 djc Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+DESCRIPTION="pyparsing is an easy-to-use Python module for text parsing"
+HOMEPAGE="http://pyparsing.wikispaces.com/ http://pypi.python.org/pypi/pyparsing"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+PYTHON_MODNAME="pyparsing.py"
+
+src_prepare() {
+ sed \
+ -e "s/pyparsing_py3 as pyparsing/pyparsing/" \
+ -e "s/pyparsing_py3/pyparsing/" \
+ -i pyparsing_py3.py || die "sed failed"
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+
+ dohtml HowToUsePyparsing.html
+ dodoc CHANGES
+
+ if use doc; then
+ dohtml -r htmldoc/*
+ insinto /usr/share/doc/${PF}
+ doins docs/*.pdf
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}