summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-08-23 10:38:58 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-08-23 10:38:58 +0000
commitce934b88b74b2314f51061b59a0b775648e34e67 (patch)
tree22a1fac7c095a1ffb3133b188851d774596d3334 /dev-python/pygtk
parentold (diff)
downloadgentoo-2-ce934b88b74b2314f51061b59a0b775648e34e67.tar.gz
gentoo-2-ce934b88b74b2314f51061b59a0b775648e34e67.tar.bz2
gentoo-2-ce934b88b74b2314f51061b59a0b775648e34e67.zip
codegen patch doesn't work properly without eautomake, bug #233337..
(Portage version: 2.2_rc8/cvs/Linux 2.6.24-gentoo-r8 i686)
Diffstat (limited to 'dev-python/pygtk')
-rw-r--r--dev-python/pygtk/ChangeLog6
-rw-r--r--dev-python/pygtk/pygtk-2.12.1-r2.ebuild12
2 files changed, 12 insertions, 6 deletions
diff --git a/dev-python/pygtk/ChangeLog b/dev-python/pygtk/ChangeLog
index 756c4d8bb1a4..990de9f3b3fb 100644
--- a/dev-python/pygtk/ChangeLog
+++ b/dev-python/pygtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pygtk
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.187 2008/08/12 13:30:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.188 2008/08/23 10:38:58 eva Exp $
+
+ 23 Aug 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ pygtk-2.12.1-r2.ebuild:
+ codegen patch doesn't work properly without eautomake, bug #233337.
12 Aug 2008; Raúl Porcel <armin76@gentoo.org> pygtk-2.12.1-r2.ebuild:
alpha/ia64/sparc stable wrt #229709
diff --git a/dev-python/pygtk/pygtk-2.12.1-r2.ebuild b/dev-python/pygtk/pygtk-2.12.1-r2.ebuild
index 0b03802178c9..b2e4cd7bb99f 100644
--- a/dev-python/pygtk/pygtk-2.12.1-r2.ebuild
+++ b/dev-python/pygtk/pygtk-2.12.1-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.12.1-r2.ebuild,v 1.5 2008/08/12 13:30:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.12.1-r2.ebuild,v 1.6 2008/08/23 10:38:58 eva Exp $
-inherit gnome.org python flag-o-matic eutils virtualx
+inherit autotools gnome.org python flag-o-matic eutils virtualx
DESCRIPTION="GTK+2 bindings for Python"
HOMEPAGE="http://www.pygtk.org/"
@@ -36,6 +36,8 @@ src_unpack() {
# fix for bug #194343
epatch "${FILESDIR}/${PN}-2.12.1-fix-codegen-location.patch"
+ AT_M4DIR="m4" eautomake
+
# disable pyc compiling
mv "${S}"/py-compile "${S}"/py-compile.orig
ln -s $(type -P true) "${S}"/py-compile
@@ -43,14 +45,14 @@ src_unpack() {
src_compile() {
use hppa && append-flags -ffunction-sections
- econf $(use_enable doc docs) --enable-thread || die
+ econf $(use_enable doc docs) --enable-thread
# possible problems with parallel builds (#45776)
#emake -j1 || die
- emake || die
+ emake || die "emake failed"
}
src_install() {
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog INSTALL MAPPING NEWS README THREADS TODO
if use examples; then