summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-12-24 04:10:37 +0000
committerTim Harder <radhermit@gentoo.org>2014-12-24 04:10:37 +0000
commitdbdc4b650cc87ea4a46c01560aa1f1e22b02eb68 (patch)
tree19205ae2f34b6be2571adf97a4fe144fbb01c869 /dev-python/pip
parentBump persistent to 2.1.1.3, remove recently added 2.1.1.2 since 2.1.1.3 is ve... (diff)
downloadgentoo-2-dbdc4b650cc87ea4a46c01560aa1f1e22b02eb68.tar.gz
gentoo-2-dbdc4b650cc87ea4a46c01560aa1f1e22b02eb68.tar.bz2
gentoo-2-dbdc4b650cc87ea4a46c01560aa1f1e22b02eb68.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/ChangeLog7
-rw-r--r--dev-python/pip/pip-6.0.3.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/pip/ChangeLog b/dev-python/pip/ChangeLog
index e647beeb4ccd..fb5631cd01e8 100644
--- a/dev-python/pip/ChangeLog
+++ b/dev-python/pip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pip
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.48 2014/12/23 21:21:51 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.49 2014/12/24 04:10:37 radhermit Exp $
+
+*pip-6.0.3 (24 Dec 2014)
+
+ 24 Dec 2014; Tim Harder <radhermit@gentoo.org> +pip-6.0.3.ebuild:
+ Version bump.
23 Dec 2014; Mike Gilbert <floppym@gentoo.org> pip-1.5.6.ebuild,
pip-6.0.2.ebuild:
diff --git a/dev-python/pip/pip-6.0.3.ebuild b/dev-python/pip/pip-6.0.3.ebuild
new file mode 100644
index 000000000000..46b9948e4b30
--- /dev/null
+++ b/dev-python/pip/pip-6.0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-6.0.3.ebuild,v 1.1 2014/12/24 04:10:37 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Installs python packages -- replacement for easy_install"
+HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+# required test data isn't bundled with the tarball
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-6.0.2-disable-version-check.patch )
+
+python_install_all() {
+ local DOCS=( AUTHORS.txt docs/*.rst )
+ distutils-r1_python_install_all
+
+ COMPLETION="${T}"/completion.tmp
+
+ ${EPYTHON} pip/__init__.py completion --bash > "${COMPLETION}" || die
+ newbashcomp "${COMPLETION}" ${PN}
+
+ ${EPYTHON} pip/__init__.py completion --zsh > "${COMPLETION}" || die
+ insinto /usr/share/zsh/site-functions
+ newins "${COMPLETION}" _pip
+}