summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-05-13 11:45:44 +0000
committerAli Polatel <hawking@gentoo.org>2008-05-13 11:45:44 +0000
commitea8e6388ce18e6e6fc99b3d580ae5fcf3a6aa18d (patch)
treefd3bff3deb4649d7f0bf47eacd5068ae0b9ed757 /dev-python/pastedeploy
parentalpha/sparc stable wrt #221801 (diff)
downloadgentoo-2-ea8e6388ce18e6e6fc99b3d580ae5fcf3a6aa18d.tar.gz
gentoo-2-ea8e6388ce18e6e6fc99b3d580ae5fcf3a6aa18d.tar.bz2
gentoo-2-ea8e6388ce18e6e6fc99b3d580ae5fcf3a6aa18d.zip
Added pygments to DEPEND when doc USE is set, thanks to Jan-Matthias
Braun, #219991. Added RESTRICT="test" until someone finds a neat way to fix them. (Portage version: 2.1.5_rc10)
Diffstat (limited to 'dev-python/pastedeploy')
-rw-r--r--dev-python/pastedeploy/ChangeLog7
-rw-r--r--dev-python/pastedeploy/pastedeploy-1.3.1.ebuild19
2 files changed, 17 insertions, 9 deletions
diff --git a/dev-python/pastedeploy/ChangeLog b/dev-python/pastedeploy/ChangeLog
index b0dcb583fa0b..eb5652037766 100644
--- a/dev-python/pastedeploy/ChangeLog
+++ b/dev-python/pastedeploy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pastedeploy
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastedeploy/ChangeLog,v 1.3 2008/04/18 13:09:14 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastedeploy/ChangeLog,v 1.4 2008/05/13 11:45:44 hawking Exp $
+
+ 13 May 2008; Ali Polatel <hawking@gentoo.org> pastedeploy-1.3.1.ebuild:
+ Added pygments to DEPEND when doc USE is set, thanks to Jan-Matthias
+ Braun, #219991. Added RESTRICT="test" until someone finds a neat way to
+ fix them.
*pastedeploy-1.3.1 (18 Apr 2008)
diff --git a/dev-python/pastedeploy/pastedeploy-1.3.1.ebuild b/dev-python/pastedeploy/pastedeploy-1.3.1.ebuild
index 09507476c15f..0df960a4cde6 100644
--- a/dev-python/pastedeploy/pastedeploy-1.3.1.ebuild
+++ b/dev-python/pastedeploy/pastedeploy-1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastedeploy/pastedeploy-1.3.1.ebuild,v 1.1 2008/04/18 13:09:14 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastedeploy/pastedeploy-1.3.1.ebuild,v 1.2 2008/05/13 11:45:44 hawking Exp $
NEED_PYTHON=2.4
@@ -21,12 +21,13 @@ IUSE="doc test"
RDEPEND="dev-python/paste"
DEPEND="${RDEPEND}
dev-python/setuptools
- doc? ( dev-python/pudge dev-python/buildutils )
+ doc? ( dev-python/buildutils dev-python/pygments dev-python/pudge )
test? ( dev-python/nose dev-python/py )"
S=${WORKDIR}/${MY_P}
PYTHON_MODNAME="paste/deploy"
+RESTRICT="test"
src_compile() {
distutils_src_compile
@@ -42,12 +43,14 @@ src_install() {
}
src_test() {
- # Tests can't import paste from site-packages
- # so we copy them over.
- # The files that will be installed are already copied to build/lib
- # so this shouldn't generate any collisions.
distutils_python_version
- cp -pPR /usr/$(get_libdir)/python${PYVER}/site-packages/paste/* paste/
- PYTHONPATH=. "${python}" setup.py nosetests || die "tests failed"
+ # Tests can't import paste from site-packages
+ # So we copy pastedeploy and paste under T.
+ # FIXME This doesn't work. Couldn't figure out why -hawking.
+ cp -pPR build/lib/paste "${T}" || die "couldn't copy pastedeploy."
+ cp -pPR /usr/$(get_libdir)/python${PYVER}/site-packages/paste/* \
+ "${T}"/paste/ || die "couldn't copy paste."
+
+ PYTHONPATH="${T}" "${python}" setup.py nosetests || die "tests failed"
}