summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-06-25 11:40:55 +0000
committerAli Polatel <hawking@gentoo.org>2008-06-25 11:40:55 +0000
commit246784fbb35a5fbb5e2b8da7cc3a5859560ae806 (patch)
treecc696a1f3b2569770cd8c234793b1a5a01c2270f /dev-python/optcomplete
parentVersion bump (diff)
downloadgentoo-2-246784fbb35a5fbb5e2b8da7cc3a5859560ae806.tar.gz
gentoo-2-246784fbb35a5fbb5e2b8da7cc3a5859560ae806.tar.bz2
gentoo-2-246784fbb35a5fbb5e2b8da7cc3a5859560ae806.zip
İnitial ebuild for optcomplete.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r1 x86_64)
Diffstat (limited to 'dev-python/optcomplete')
-rw-r--r--dev-python/optcomplete/ChangeLog10
-rw-r--r--dev-python/optcomplete/Manifest4
-rw-r--r--dev-python/optcomplete/metadata.xml22
-rw-r--r--dev-python/optcomplete/optcomplete-1.2.ebuild28
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/optcomplete/ChangeLog b/dev-python/optcomplete/ChangeLog
new file mode 100644
index 000000000000..a11fd6c67f56
--- /dev/null
+++ b/dev-python/optcomplete/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/optcomplete
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/optcomplete/ChangeLog,v 1.1 2008/06/25 11:40:55 hawking Exp $
+
+*optcomplete-1.2 (25 Jun 2008)
+
+ 25 Jun 2008; Ali Polatel <hawking@gentoo.org> +metadata.xml,
+ +optcomplete-1.2.ebuild:
+ Initial ebuild for optcomplete.
+
diff --git a/dev-python/optcomplete/Manifest b/dev-python/optcomplete/Manifest
new file mode 100644
index 000000000000..16d94036f86e
--- /dev/null
+++ b/dev-python/optcomplete/Manifest
@@ -0,0 +1,4 @@
+DIST optcomplete-1.2.tar.bz2 15358 RMD160 65f3dae4243ba1aa3959ed854b795941a5cc9e17 SHA1 e9845c3733c66c09fccbc9bee00dd200f3b63c35 SHA256 628481e3908d1f78faae34380b1873cecb3027ce40a18f94a98a2fe8de11e71a
+EBUILD optcomplete-1.2.ebuild 545 RMD160 11e2f698c3e09de0b65f4259649c058ed8588e3c SHA1 786ef5a03e620503028cdb18ed921f38a913db17 SHA256 90cdb44730cd96dc550c01d250871e82b5e4df3e0deaf4ebdd10d3b6d99dcf2f
+MISC ChangeLog 280 RMD160 93af7280c1b7185a13a593cd18c34de275e879f0 SHA1 cdc538b146013ebf497ee4cb77fc5213f3368f5e SHA256 8912062cc230f393bcb6837cde828baf328c03f94f18e512a97be3537250ccc3
+MISC metadata.xml 873 RMD160 d1a931e0055b6a53bcd432cc8f885ff2b9e02c26 SHA1 0eca789ca6dcdf1c0c6e31599221689c3a3847f3 SHA256 14cc4c76f4203b10bb928948a28b97c0c1c2c3638c8936f3fcd7f72ebd6493f0
diff --git a/dev-python/optcomplete/metadata.xml b/dev-python/optcomplete/metadata.xml
new file mode 100644
index 000000000000..2fd9bb5409ca
--- /dev/null
+++ b/dev-python/optcomplete/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>hawking@gentoo.org</email>
+ <name>Ali Polatel</name>
+ </maintainer>
+ <longdescription lang="en">
+ This Python module aims at providing almost automatically shell completion
+ for any Python program that already uses the optparse module.
+
+ This module aims at placing the shell completion routine and the option
+ parsing code in a single location: in the program itself.
+
+ The logic is that since a program already knows about its options, and in
+ Python we have a standard module to specify them programmatically since
+ Python-2.3 (optparse), the program itself is in the best position to suggest
+ completions for an incomplete command-line to a shell that invokes it.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/dev-python/optcomplete/optcomplete-1.2.ebuild b/dev-python/optcomplete/optcomplete-1.2.ebuild
new file mode 100644
index 000000000000..93bec45c783a
--- /dev/null
+++ b/dev-python/optcomplete/optcomplete-1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/optcomplete/optcomplete-1.2.ebuild,v 1.1 2008/06/25 11:40:55 hawking Exp $
+
+inherit distutils
+
+DESCRIPTION="Shell completion self-generator for python"
+HOMEPAGE="http://furius.ca/optcomplete/"
+SRC_URI="http://furius.ca/downloads/${PN}/releases/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+DOCS="CHANGES"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins bin/* || die "doins failed"
+ fi
+}