summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-03-23 13:17:29 +0000
committerIan Delaney <idella4@gentoo.org>2014-03-23 13:17:29 +0000
commit41c8d39e4b30fa5f15d190e144a96d9a23eb13f1 (patch)
tree68ef3cf99547ba5394936ced498d6cb2f913485d /dev-python/doit
parentRemove old. (diff)
downloadgentoo-2-41c8d39e4b30fa5f15d190e144a96d9a23eb13f1.tar.gz
gentoo-2-41c8d39e4b30fa5f15d190e144a96d9a23eb13f1.tar.bz2
gentoo-2-41c8d39e4b30fa5f15d190e144a96d9a23eb13f1.zip
Correct deps, set test phase pypy capable and adjust for failures under pypy & py2.6, all wrt to the Bug #503616. Thx to Chicago for test support in irc. New release due in coming days set to fix most failed tests
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/doit')
-rw-r--r--dev-python/doit/ChangeLog7
-rw-r--r--dev-python/doit/doit-0.23.0-r1.ebuild24
2 files changed, 24 insertions, 7 deletions
diff --git a/dev-python/doit/ChangeLog b/dev-python/doit/ChangeLog
index 15fe5fd1f059..8056b70776cb 100644
--- a/dev-python/doit/ChangeLog
+++ b/dev-python/doit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/doit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/doit/ChangeLog,v 1.7 2014/03/21 07:00:31 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/doit/ChangeLog,v 1.8 2014/03/23 13:17:29 idella4 Exp $
+
+ 23 Mar 2014; Ian Delaney <idella4@gentoo.org> doit-0.23.0-r1.ebuild:
+ Correct deps, set test phase pypy capable and adjust for failures under pypy &
+ py2.6, all wrt to the Bug #503616. Thx to Chicago for test support in irc.
+ New release due in coming days set to fix most failed tests
*doit-0.23.0-r1 (21 Mar 2014)
diff --git a/dev-python/doit/doit-0.23.0-r1.ebuild b/dev-python/doit/doit-0.23.0-r1.ebuild
index 79591be82f25..edf137fb7999 100644
--- a/dev-python/doit/doit-0.23.0-r1.ebuild
+++ b/dev-python/doit/doit-0.23.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/doit/doit-0.23.0-r1.ebuild,v 1.1 2014/03/21 07:00:31 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/doit/doit-0.23.0-r1.ebuild,v 1.2 2014/03/23 13:17:29 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
@@ -15,9 +15,13 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE="test"
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
RDEPEND="dev-python/pyinotify[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+# Required for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
DOCS=( AUTHORS CHANGES README TODO.txt dev_requirements.txt )
python_prepare_all() {
@@ -36,11 +40,19 @@ python_prepare_all() {
python_test() {
# Testsuite is designed to be run by py.test, called by runtests.py
- if [[ "${EPYTHON}" == 'pypy-c2.0' ]]; then
- einfo "some tests are not supported by pypy"
- else
- "${PYTHON}" runtests.py
+ # https://bitbucket.org/schettino72/doit/issue/78/tests-that-fail-under-pypy
+ if [[ "${EPYTHON}" == pypy-c2.0 ]]; then
+ sed -e 's:test_corrupted_file:_&:' \
+ -e 's:test_corrupted_file_unrecognized_excep_pdep:_&:' \
+ -i tests/test_dependency.py || die
+ elif [[ "${EPYTHON}" == python2.6 ]]; then
+ rm -f tests/test___main__.py || die
+ sed -e 's:test_invalid_param_stdout:_&:' \
+ -i tests/test_action.py || die
+ sed -e 's:test_run_wait:_&:' \
+ -i tests/test_cmd_auto.py || die
fi
+ "${PYTHON}" runtests.py
}
src_install() {