summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-07 09:43:51 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-07 09:43:51 +0000
commit306d6c55ea78cde2bf43fd78e92d9d18944e282a (patch)
treebe2c96ea4c23645ebbcc27c60daedf6f34cb7f89 /dev-python/cryptography
parentAdd github to remote-id in metadata.xml (diff)
downloadgentoo-2-306d6c55ea78cde2bf43fd78e92d9d18944e282a.tar.gz
gentoo-2-306d6c55ea78cde2bf43fd78e92d9d18944e282a.tar.bz2
gentoo-2-306d6c55ea78cde2bf43fd78e92d9d18944e282a.zip
Version Bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-python/cryptography')
-rw-r--r--dev-python/cryptography/ChangeLog7
-rw-r--r--dev-python/cryptography/cryptography-0.9.1.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/cryptography/ChangeLog b/dev-python/cryptography/ChangeLog
index d0ec78eaaccd..e1e7ae64902b 100644
--- a/dev-python/cryptography/ChangeLog
+++ b/dev-python/cryptography/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cryptography
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cryptography/ChangeLog,v 1.47 2015/05/28 18:50:42 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cryptography/ChangeLog,v 1.48 2015/06/07 09:43:51 jlec Exp $
+
+*cryptography-0.9.1 (07 Jun 2015)
+
+ 07 Jun 2015; Justin Lecher <jlec@gentoo.org> +cryptography-0.9.1.ebuild:
+ Version Bump
28 May 2015; Justin Lecher <jlec@gentoo.org> cryptography-0.8.2.ebuild,
cryptography-0.9.ebuild:
diff --git a/dev-python/cryptography/cryptography-0.9.1.ebuild b/dev-python/cryptography/cryptography-0.9.1.ebuild
new file mode 100644
index 000000000000..d2d9884c4147
--- /dev/null
+++ b/dev-python/cryptography/cryptography-0.9.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cryptography/cryptography-0.9.1.ebuild,v 1.1 2015/06/07 09:43:51 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Library providing cryptographic recipes and primitives"
+HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.python.org/pypi/cryptography/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/openssl:0
+ $(python_gen_cond_dep '>=dev-python/cffi-0.8:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3 pypy)
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/ipaddress[$(python_gen_usedep python2_7 pyp)]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
+ dev-python/iso8601[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}