summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-20 19:54:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-20 19:54:43 +0000
commitf21698fca52a65f934146d0a9fa3d007cc4a4bc1 (patch)
tree5fca9943fe05e94477d90e7385d1bf3542a9ee4e /dev-python/apsw
parentRemove useless ewarn. (diff)
downloadgentoo-2-f21698fca52a65f934146d0a9fa3d007cc4a4bc1.tar.gz
gentoo-2-f21698fca52a65f934146d0a9fa3d007cc4a4bc1.tar.bz2
gentoo-2-f21698fca52a65f934146d0a9fa3d007cc4a4bc1.zip
Version bump.
(Portage version: 2.2.0_alpha24_p17/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/ChangeLog10
-rw-r--r--dev-python/apsw/apsw-3.7.5.1.ebuild53
2 files changed, 61 insertions, 2 deletions
diff --git a/dev-python/apsw/ChangeLog b/dev-python/apsw/ChangeLog
index 385b252cf6a7..bdd9fa0c4f45 100644
--- a/dev-python/apsw/ChangeLog
+++ b/dev-python/apsw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/apsw
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/ChangeLog,v 1.34 2010/12/19 13:03:02 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/ChangeLog,v 1.35 2011/02/20 19:54:43 arfrever Exp $
+
+*apsw-3.7.5.1 (20 Feb 2011)
+
+ 20 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +apsw-3.7.5.1.ebuild:
+ Version bump.
*apsw-3.7.4.1 (19 Dec 2010)
diff --git a/dev-python/apsw/apsw-3.7.5.1.ebuild b/dev-python/apsw/apsw-3.7.5.1.ebuild
new file mode 100644
index 000000000000..77b0b756b43c
--- /dev/null
+++ b/dev-python/apsw/apsw-3.7.5.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/apsw-3.7.5.1.ebuild,v 1.1 2011/02/20 19:54:43 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit distutils eutils versionator
+
+MY_PV="$(replace_version_separator 3 -r)"
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="http://code.google.com/p/apsw/"
+SRC_URI="http://apsw.googlecode.com/files/${PN}-${MY_PV}.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-db/sqlite-$(get_version_component_range 1-3)[extensions]"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${PN}-3.6.20.1-fix_tests.patch"
+}
+
+src_compile() {
+ distutils_src_compile --enable=load_extension
+}
+
+src_test() {
+ echo "$(PYTHON -f)" setup.py build_test_extension
+ "$(PYTHON -f)" setup.py build_test_extension || die "Building of test loadable extension failed"
+
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" tests.py -v
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ dodoc doc/_sources/* || die "dodoc failed"
+ dohtml -r doc/* || die "dohtml failed"
+}