summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-03 04:14:13 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-03 04:14:13 +0000
commitad791779248e49ae0773f9e9ad074dd04fde9728 (patch)
tree7c689691f3dd3d9ec482bc2863265533877c352a /dev-python/PyPDF2
parentprofiles/prefix: Switched linux-standalone profiles to the same multilib sett... (diff)
downloadgentoo-2-ad791779248e49ae0773f9e9ad074dd04fde9728.tar.gz
gentoo-2-ad791779248e49ae0773f9e9ad074dd04fde9728.tar.bz2
gentoo-2-ad791779248e49ae0773f9e9ad074dd04fde9728.zip
ebuild written by me, Jan 3. Required in the bump of xhtml2pdf-0.0.6 to substitute dev-python/pyPdf, of which PyPDF2 is a fork. The original name using camel case is retained since it poses no problem once installed. Conversion to lowercase causes far more pain than it cures.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/PyPDF2')
-rw-r--r--dev-python/PyPDF2/ChangeLog12
-rw-r--r--dev-python/PyPDF2/Manifest3
-rw-r--r--dev-python/PyPDF2/PyPDF2-1.24.ebuild22
-rw-r--r--dev-python/PyPDF2/metadata.xml5
4 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/PyPDF2/ChangeLog b/dev-python/PyPDF2/ChangeLog
new file mode 100644
index 000000000000..6f4d69682966
--- /dev/null
+++ b/dev-python/PyPDF2/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-python/PyPDF2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyPDF2/ChangeLog,v 1.1 2015/01/03 04:14:13 idella4 Exp $
+
+*PyPDF2-1.24 (03 Jan 2015)
+
+ 03 Jan 2015; Ian Delaney <idella4@gentoo.org> +PyPDF2-1.24.ebuild,
+ +metadata.xml:
+ ebuild written by me, Jan 3. Required in the bump of xhtml2pdf-0.0.6 to
+ substitute dev-python/pyPdf, of which PyPDF2 is a fork. The original name
+ using camel case is retained since it poses no problem once installed.
+ Conversion to lowercase causes far more pain than it cures.
diff --git a/dev-python/PyPDF2/Manifest b/dev-python/PyPDF2/Manifest
new file mode 100644
index 000000000000..051b336c939c
--- /dev/null
+++ b/dev-python/PyPDF2/Manifest
@@ -0,0 +1,3 @@
+DIST PyPDF2-1.24.tar.gz 59891 SHA256 aca40d5155524120fceaf2eb4ae054480b8a2b6ffcfa0a2e77e3e45666428c64 SHA512 91a9338b0338eee1cfddc25dd0f21494f73696e630b08a71ff9195fe7b0fc77cf6c07b38a0c6aa4856536be6fe0a474c3b292c13fdd0187b62cb8848e69b29f9 WHIRLPOOL b5d33c209d5e0ce7d2d567d9266faacbbc6c1e49ac714e0063eeeb3879f400482a3fa887bd165b364a7216b4240b5236dec1954683ade632ea802a36a5272303
+EBUILD PyPDF2-1.24.ebuild 643 SHA256 f81a16d7716eede30f25062a7e6a1619f7e70d0ef58bdf9cc102ab5ea2b3fbcd SHA512 e0c0f328b42c36f8d2e33bedd637a8b5921a6824dae61d0dacc9844d96a388fd4f37eb89cbb8d0140e973ee0176ada5c4362953283ddcdf8c853a720a27b147a WHIRLPOOL 49f74c9ace00b9ea0e5de2d175174af54c82b66e197d8a8198236c4779c5b6c973f669e95d4616cc849a04060df34737a776f0c75f495cbecd45e2f459aadc5e
+MISC metadata.xml 160 SHA256 6cd954a9de2307c57d32b25fa3599dee2908a4ddc6a98594f593d53577307a3a SHA512 7c02a1de1ddcb6b7c6378cceff0458da3a15d5381417f7cdf01874e7c372664b8899863f41b3a2fd8d6ad67ceb732dac6da0cc17575bf8e3e6d89480417c6628 WHIRLPOOL ed2795e4466eda8c804d5067c87386e269a59fe959393057ca5ddc36851e00f5210c4da1adf4bbdfdbb7d1d3d5c60aced25727ca12fdc8305d9e263a3aca9b13
diff --git a/dev-python/PyPDF2/PyPDF2-1.24.ebuild b/dev-python/PyPDF2/PyPDF2-1.24.ebuild
new file mode 100644
index 000000000000..a4a94d38df2f
--- /dev/null
+++ b/dev-python/PyPDF2/PyPDF2-1.24.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyPDF2/PyPDF2-1.24.ebuild,v 1.1 2015/01/03 04:14:13 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to work with pdf files"
+HOMEPAGE="http://pypi.python.org/pypi/${PN}/ http://mstamy2.github.com/PyPDF2"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+python_install_all() {
+ use examples && local EXAMPLES=( Sample_Code/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/PyPDF2/metadata.xml b/dev-python/PyPDF2/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/PyPDF2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>