summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-05-18 22:24:27 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-05-18 22:24:27 +0000
commitbef39ec9c8f6b97540d777e1cdf25a3aa78bbebd (patch)
treea156a8160636ba264174251c0224ad367e5c4bde /dev-lisp
parentaraneida, mod_lisp and aserve USE flags for dev-lisp/cl-ucw (diff)
downloadgentoo-2-bef39ec9c8f6b97540d777e1cdf25a3aa78bbebd.tar.gz
gentoo-2-bef39ec9c8f6b97540d777e1cdf25a3aa78bbebd.tar.bz2
gentoo-2-bef39ec9c8f6b97540d777e1cdf25a3aa78bbebd.zip
.
(Portage version: 2.0.51.22)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-ucw/ChangeLog19
-rw-r--r--dev-lisp/cl-ucw/Manifest6
-rw-r--r--dev-lisp/cl-ucw/cl-ucw-0.3.9.ebuild62
-rw-r--r--dev-lisp/cl-ucw/files/0.3.9-gentoo.patch24
-rw-r--r--dev-lisp/cl-ucw/files/README.Gentoo54
-rw-r--r--dev-lisp/cl-ucw/files/digest-cl-ucw-0.3.91
-rw-r--r--dev-lisp/cl-ucw/metadata.xml5
7 files changed, 171 insertions, 0 deletions
diff --git a/dev-lisp/cl-ucw/ChangeLog b/dev-lisp/cl-ucw/ChangeLog
new file mode 100644
index 000000000000..48ff7be7a2e8
--- /dev/null
+++ b/dev-lisp/cl-ucw/ChangeLog
@@ -0,0 +1,19 @@
+# ChangeLog for dev-lisp/cl-ucw
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-ucw/ChangeLog,v 1.1 2005/05/18 22:24:27 mkennedy Exp $
+
+*cl-ucw-0.3.9 (18 May 2005)
+
+ 18 May 2005; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/0.3.9-gentoo.patch, +files/README.Gentoo, +metadata.xml,
+ +cl-ucw-0.3.9.ebuild:
+ New upstream version; Removed old ebuilds.
+
+*cl-ucw-0.3.7 (22 Mar 2005)
+*cl-ucw-0.3.6 (22 Mar 2005)
+
+ 22 Mar 2005; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/0.3.6-tal-paths-gentoo.patch, +files/0.3.7-tal-paths-gentoo.patch,
+ +metadata.xml, +cl-ucw-0.3.6.ebuild, +cl-ucw-0.3.7.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-ucw/Manifest b/dev-lisp/cl-ucw/Manifest
new file mode 100644
index 000000000000..824becc88848
--- /dev/null
+++ b/dev-lisp/cl-ucw/Manifest
@@ -0,0 +1,6 @@
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
+MD5 eac2ff72e2cc3185f3cdca2b5696004a ChangeLog 441
+MD5 46bc7af29ca67927a7f41bdccfe788bb cl-ucw-0.3.9.ebuild 1747
+MD5 9292ebcab6412018da010e6ffbc1e6a6 files/digest-cl-ucw-0.3.9 62
+MD5 b360ffcb2884a4493d878357bef9da9a files/0.3.9-gentoo.patch 873
+MD5 436d39dbd5e4cf973da1e18ba9503357 files/README.Gentoo 1863
diff --git a/dev-lisp/cl-ucw/cl-ucw-0.3.9.ebuild b/dev-lisp/cl-ucw/cl-ucw-0.3.9.ebuild
new file mode 100644
index 000000000000..be47201878b9
--- /dev/null
+++ b/dev-lisp/cl-ucw/cl-ucw-0.3.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-ucw/cl-ucw-0.3.9.ebuild,v 1.1 2005/05/18 22:24:27 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DESCRIPTION="UnCommon Web is a continuation based, component oriented dynamic web application framework written in Common Lisp."
+HOMEPAGE="http://common-lisp.net/project/ucw/index.html"
+SRC_URI="ftp://ftp.common-lisp.net/pub/project/ucw/ucw_${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="mod_lisp araneida aserve doc"
+
+DEPEND=">=dev-lisp/cl-iterate-1.4
+ >=dev-lisp/cl-rfc2388-0.9
+ >=dev-lisp/cl-arnesi-1.4.0_p5
+ >=dev-lisp/cl-yaclml-0.5_p26
+ dev-lisp/cl-icu
+ mod_lisp? ( || ( www-apache/mod_lisp www-apache/mod_lisp2 ) )
+ araneida? ( dev-lisp/cl-araneida )
+ aserve? ( dev-lisp/cl-aserve )
+ || ( app-emacs/slime app-emacs/slime-cvs )
+ doc? ( virtual/tetex)"
+
+CLPACKAGE=ucw
+
+S=${WORKDIR}/ucw_${PV}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-gentoo.patch || die
+ find ${S}/ -type d -name .arch-ids -exec rm -rf '{}' \; &>/dev/null
+}
+
+src_compile() {
+ if use doc; then
+ einfo "Won't build documentation for the time being."
+# make -C docs
+ fi
+}
+
+src_install() {
+ dodir /usr/share/common-lisp/source/ucw
+ dodir /usr/share/common-lisp/systems
+ insinto /usr/share/common-lisp/source/ucw/
+ doins -r src examples
+ common-lisp-install ucw.asd
+ common-lisp-system-symlink
+ dodoc README CHANGES
+ dohtml -r docs/html/*
+ insinto /usr/share/doc/${PF}/
+ doins bin/*
+ insinto /var/lib/ucw
+ doins -r wwwroot
+ dodoc ${FILESDIR}/README.Gentoo
+ keepdir /var/logs/ucw
+}
+
+pkg_postinst() {
+ while read line; do einfo "${line}"; done <${FILESDIR}/README.Gentoo
+}
diff --git a/dev-lisp/cl-ucw/files/0.3.9-gentoo.patch b/dev-lisp/cl-ucw/files/0.3.9-gentoo.patch
new file mode 100644
index 000000000000..93681ad23fb5
--- /dev/null
+++ b/dev-lisp/cl-ucw/files/0.3.9-gentoo.patch
@@ -0,0 +1,24 @@
+diff -ur ucw_0.3.9.orig/bin/start.lisp ucw_0.3.9/bin/start.lisp
+--- ucw_0.3.9.orig/bin/start.lisp 2005-05-09 12:33:49.000000000 -0500
++++ ucw_0.3.9/bin/start.lisp 2005-05-18 15:59:32.000000000 -0500
+@@ -43,18 +43,14 @@
+
+ ;;;; 3) Setup teh default TAL root
+
+-(setf *ucw-tal-root* (find-tal-root))
++(setf *ucw-tal-root* #p"/var/lib/ucw/wwwroot/")
+
+ ;;;; 4) Setup the loggers
+
+ ;;;; We put all the log files (ucw.log and ucw.backend.log by default)
+ ;;;; in the directory ucw/logs/
+
+-(setup-loggers (make-pathname :name nil :type nil
+- :directory (append (pathname-directory *load-truename*)
+- (list :up "logs"))
+- :defaults *load-truename*)
+- +info+)
++(setup-loggers #p"/var/logs/ucw/" +info+)
+
+ ;;;; ** Site Specific initialization/configuration
+
diff --git a/dev-lisp/cl-ucw/files/README.Gentoo b/dev-lisp/cl-ucw/files/README.Gentoo
new file mode 100644
index 000000000000..54dfd7c799da
--- /dev/null
+++ b/dev-lisp/cl-ucw/files/README.Gentoo
@@ -0,0 +1,54 @@
+ -*-outline-*-
+This file is README.Gentoo, from /usr/share/docs/cl-ucw-*/
+
+* Introduction
+
+UCW requires some configuration before use. For example, you must choose the
+web-server backend UCW will use (araneida, mod_lisp, aserve, httpd etc.),
+choose the location of the UCW TAL root, adjust loggers, debugging verbosity
+etc.
+
+UCW provides some examples in the form of start.lisp, and utils.lisp. Both
+of which can be found in /usr/share/docs/cl-ucw-*/. Use those examples as
+templates for your own configurations. Your start.lisp and utils.lisp should
+be located in the same directory.
+
+* Gentoo Defaults
+
+Gentoo installs a default TAL root in /var/lib/ucw/wwwroot/
+
+Gentoo installs a default logger path at /var/logs/ucw/
+
+The start.lisp included in the Gentoo distribution of UCW makes use of the
+above paths by default (see the sections 3. TAL root and section 4. Setup
+loggers in start.lisp). If you wish to change the details of a web-server
+backend, you'll need to change utils.lisp.
+
+You will need to adjust the permissions of /var/logs/ucw/ to suit whatever
+system user ID you intend to run UCW under. Alternatively you could set the
+path passed to SETUP-LOGGERS to your own choice in logging directory.
+
+* Starting UCW
+
+Once you have adjusted your start.lisp and utils.lisp, start UCW within your
+Lisp REPL like this:
+
+ (asdf:oos 'adsf:load-op :ucw)
+ (load "/path/to/start.lisp")
+
+By default, the admin and examples applications are available at:
+
+ http://127.0.0.1:<port>/ucw/admin/index.ucw
+ http://127.0.0.1:<port>/ucw/examples/index.ucw
+
+Where <port> is 8080 for the "httpd" backend, 3001 for the "mod-lisp" backend
+and 8080 for the "aserve" or "araneida" backends.
+
+* Bugs
+
+Report bugs to http://bugs.gentoo.org/
+
+* Maintainer
+
+Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-ucw/files/digest-cl-ucw-0.3.9 b/dev-lisp/cl-ucw/files/digest-cl-ucw-0.3.9
new file mode 100644
index 000000000000..70d11ebba269
--- /dev/null
+++ b/dev-lisp/cl-ucw/files/digest-cl-ucw-0.3.9
@@ -0,0 +1 @@
+MD5 f179582d8d45b0e880b0ec300f0c3d4b ucw_0.3.9.tar.gz 1170864
diff --git a/dev-lisp/cl-ucw/metadata.xml b/dev-lisp/cl-ucw/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-ucw/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>