summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-09-26 17:29:08 +0000
committerPacho Ramos <pacho@gentoo.org>2011-09-26 17:29:08 +0000
commit995a24d8a9cafb9d1296f8e91b3910866db5d791 (patch)
tree56308cea0bb08e0995ce4999b37c85acfe712141 /dev-libs
parentVersion bump, remove old. (diff)
downloadgentoo-2-995a24d8a9cafb9d1296f8e91b3910866db5d791.tar.gz
gentoo-2-995a24d8a9cafb9d1296f8e91b3910866db5d791.tar.bz2
gentoo-2-995a24d8a9cafb9d1296f8e91b3910866db5d791.zip
Version bump.
(Portage version: 2.1.10.19/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libgee/ChangeLog7
-rw-r--r--dev-libs/libgee/libgee-0.7.1.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-libs/libgee/ChangeLog b/dev-libs/libgee/ChangeLog
index 570c3e8cba5b..aa34138d2a49 100644
--- a/dev-libs/libgee/ChangeLog
+++ b/dev-libs/libgee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libgee
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgee/ChangeLog,v 1.28 2011/09/14 14:24:52 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgee/ChangeLog,v 1.29 2011/09/26 17:29:08 pacho Exp $
+
+*libgee-0.7.1 (26 Sep 2011)
+
+ 26 Sep 2011; Pacho Ramos <pacho@gentoo.org> +libgee-0.7.1.ebuild:
+ Version bump.
*libgee-0.6.2.1 (14 Sep 2011)
diff --git a/dev-libs/libgee/libgee-0.7.1.ebuild b/dev-libs/libgee/libgee-0.7.1.ebuild
new file mode 100644
index 000000000000..ea6e54a5b998
--- /dev/null
+++ b/dev-libs/libgee/libgee-0.7.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgee/libgee-0.7.1.ebuild,v 1.1 2011/09/26 17:29:08 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 multilib
+
+DESCRIPTION="GObject-based interfaces and classes for commonly used data structures."
+HOMEPAGE="http://live.gnome.org/Libgee"
+
+LICENSE="LGPL-2.1"
+SLOT="0.8"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-linux"
+IUSE="+introspection"
+
+# FIXME: add doc support, requires valadoc
+RDEPEND=">=dev-libs/glib-2.12:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-lang/vala-0.9.3:0.14"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog* MAINTAINERS NEWS README"
+ G2CONF="${G2CONF}
+ $(use_enable introspection)
+ VALAC=$(type -P valac-0.14)"
+}