summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-24 18:01:46 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-24 18:01:46 +0000
commit8470a45d339654a76bbe9519fadf19f335cd7f7b (patch)
treebff6ce05d057e90b0cf91e3cce5d4a780f41ba84 /dev-libs
parentFix building with GCC 4.4 wrt #276956. (diff)
downloadgentoo-2-8470a45d339654a76bbe9519fadf19f335cd7f7b.tar.gz
gentoo-2-8470a45d339654a76bbe9519fadf19f335cd7f7b.tar.bz2
gentoo-2-8470a45d339654a76bbe9519fadf19f335cd7f7b.zip
Build shared library.
(Portage version: 13850-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/crypto++/ChangeLog8
-rw-r--r--dev-libs/crypto++/crypto++-5.6.0-r1.ebuild51
-rw-r--r--dev-libs/crypto++/files/crypto++-5.6.0-fix_build_system.patch120
3 files changed, 178 insertions, 1 deletions
diff --git a/dev-libs/crypto++/ChangeLog b/dev-libs/crypto++/ChangeLog
index b547c16cc6d5..2b91b4a5e8bb 100644
--- a/dev-libs/crypto++/ChangeLog
+++ b/dev-libs/crypto++/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/crypto++
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/crypto++/ChangeLog,v 1.50 2009/07/07 18:30:05 gengor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/crypto++/ChangeLog,v 1.51 2009/07/24 18:01:46 arfrever Exp $
+
+*crypto++-5.6.0-r1 (24 Jul 2009)
+
+ 24 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +crypto++-5.6.0-r1.ebuild, +files/crypto++-5.6.0-fix_build_system.patch:
+ Build shared library.
07 Jul 2009; Gordon Malm <gengor@gentoo.org> metadata.xml:
Minor grammar/spelling fixes.
diff --git a/dev-libs/crypto++/crypto++-5.6.0-r1.ebuild b/dev-libs/crypto++/crypto++-5.6.0-r1.ebuild
new file mode 100644
index 000000000000..fbd672d20d28
--- /dev/null
+++ b/dev-libs/crypto++/crypto++-5.6.0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/crypto++/crypto++-5.6.0-r1.ebuild,v 1.1 2009/07/24 18:01:46 arfrever Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Crypto++ is a C++ class library of cryptographic schemes"
+HOMEPAGE="http://cryptopp.com"
+SRC_URI="mirror://sourceforge/cryptopp/cryptopp${PV//.}.zip"
+
+LICENSE="cryptopp"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+DEPEND="app-arch/unzip"
+RDEPEND=""
+IUSE="sse3"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix_build_system.patch"
+}
+
+src_compile() {
+ # More than -O1 gives problems.
+ replace-flags -O? -O1
+ filter-flags -fomit-frame-pointer
+ use sse3 || append-flags -DCRYPTOPP_DISABLE_SSE2
+ emake -f GNUmakefile \
+ LIBDIR="$(get_libdir)" \
+ CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" || die "emake failed"
+}
+
+src_test() {
+ # Make sure all test vectors have unix line endings.
+ for file in TestVectors/*; do
+ edos2unix ${file}
+ done
+
+ if ! emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" test; then
+ eerror "Crypto++ self-tests failed."
+ eerror "Try to remove some optimization flags and reemerge Crypto++."
+ die "emake test failed"
+ fi;
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="$(get_libdir)" install || die "emake install failed"
+}
diff --git a/dev-libs/crypto++/files/crypto++-5.6.0-fix_build_system.patch b/dev-libs/crypto++/files/crypto++-5.6.0-fix_build_system.patch
new file mode 100644
index 000000000000..abb07e784388
--- /dev/null
+++ b/dev-libs/crypto++/files/crypto++-5.6.0-fix_build_system.patch
@@ -0,0 +1,120 @@
+--- GNUmakefile
++++ GNUmakefile
+@@ -1,3 +1,5 @@
++LIBTOOL = libtool
++LIBDIR = lib
+ CXXFLAGS = -DNDEBUG -g -O2
+ #CXXFLAGS = -g
+ # -fPIC is supported. Please report any breakage of -fPIC as a bug.
+@@ -7,8 +9,9 @@
+ # LDFLAGS += -Wl,--gc-sections
+ ARFLAGS = -cr # ar needs the dash on OpenBSD
+ RANLIB = ranlib
+-CP = cp
++LN_S = ln -s
+ MKDIR = mkdir
++INSTALL = install
+ EGREP = egrep
+ UNAME = $(shell uname)
+ ISX86 = $(shell uname -m | $(EGREP) -c "i.86|x86|i86|amd64")
+@@ -98,42 +101,45 @@
+ SRCS = $(shell echo *.cpp)
+ endif
+
+-OBJS = $(SRCS:.cpp=.o)
+-# test.o needs to be after bench.o for cygwin 1.1.4 (possible ld bug?)
+-TESTOBJS = bench.o bench2.o test.o validat1.o validat2.o validat3.o adhoc.o datatest.o regtest.o fipsalgt.o dlltest.o
++OBJS = $(SRCS:.cpp=.lo)
++# test.lo needs to be after bench.lo for cygwin 1.1.4 (possible ld bug?)
++TESTOBJS = bench.lo bench2.lo test.lo validat1.lo validat2.lo validat3.lo adhoc.lo datatest.lo regtest.lo fipsalgt.lo dlltest.lo
+ LIBOBJS = $(filter-out $(TESTOBJS),$(OBJS))
+
+ DLLSRCS = algebra.cpp algparam.cpp asn.cpp basecode.cpp cbcmac.cpp channels.cpp cryptlib.cpp des.cpp dessp.cpp dh.cpp dll.cpp dsa.cpp ec2n.cpp eccrypto.cpp ecp.cpp eprecomp.cpp files.cpp filters.cpp fips140.cpp fipstest.cpp gf2n.cpp gfpcrypt.cpp hex.cpp hmac.cpp integer.cpp iterhash.cpp misc.cpp modes.cpp modexppc.cpp mqueue.cpp nbtheory.cpp oaep.cpp osrng.cpp pch.cpp pkcspad.cpp pubkey.cpp queue.cpp randpool.cpp rdtables.cpp rijndael.cpp rng.cpp rsa.cpp sha.cpp simple.cpp skipjack.cpp strciphr.cpp trdlocal.cpp
+-DLLOBJS = $(DLLSRCS:.cpp=.export.o)
+-LIBIMPORTOBJS = $(LIBOBJS:.o=.import.o)
+-TESTIMPORTOBJS = $(TESTOBJS:.o=.import.o)
+-DLLTESTOBJS = dlltest.dllonly.o
++DLLOBJS = $(DLLSRCS:.cpp=.export.lo)
++LIBIMPORTOBJS = $(LIBOBJS:.lo=.import.lo)
++TESTIMPORTOBJS = $(TESTOBJS:.lo=.import.lo)
++DLLTESTOBJS = dlltest.dllonly.lo
+
+-all: cryptest.exe
++all: libcrypto++.la
+
+-test: cryptest.exe
+- ./cryptest.exe v
++test: cryptest
++ ./cryptest v
+
+ clean:
+- $(RM) cryptest.exe libcryptopp.a $(LIBOBJS) $(TESTOBJS) cryptopp.dll libcryptopp.dll.a libcryptopp.import.a cryptest.import.exe dlltest.exe $(DLLOBJS) $(LIBIMPORTOBJS) $(TESTIMPORTOBJS) $(DLLTESTOBJS)
++ $(RM) -f .libs cryptest libcrypto++.* libcryptopp.* $(LIBOBJS) $(TESTOBJS) cryptopp.dll cryptest.import dlltest $(DLLOBJS) $(LIBIMPORTOBJS) $(TESTIMPORTOBJS) $(DLLTESTOBJS)
+
+ install:
+- $(MKDIR) -p $(PREFIX)/include/cryptopp $(PREFIX)/lib $(PREFIX)/bin
+- $(CP) *.h $(PREFIX)/include/cryptopp
+- $(CP) *.a $(PREFIX)/lib
+- $(CP) *.exe $(PREFIX)/bin
++ $(MKDIR) -p $(DESTDIR)$(PREFIX)/include/crypto++ $(DESTDIR)$(PREFIX)/$(LIBDIR)
++ $(INSTALL) -m 644 *.h $(DESTDIR)$(PREFIX)/include/crypto++
++ $(LN_S) crypto++ $(DESTDIR)$(PREFIX)/include/cryptopp
++ $(LIBTOOL) --mode=install $(INSTALL) libcrypto++.la $(DESTDIR)$(PREFIX)/$(LIBDIR)
++ $(LN_S) libcrypto++.a $(DESTDIR)$(PREFIX)/$(LIBDIR)/libcryptopp.a
++ $(LN_S) libcrypto++.so.0.0.0 $(DESTDIR)$(PREFIX)/$(LIBDIR)/libcryptopp.so
++ $(LN_S) libcrypto++.so.0.0.0 $(DESTDIR)$(PREFIX)/$(LIBDIR)/libcryptopp.so.0
++ $(LN_S) libcrypto++.so.0.0.0 $(DESTDIR)$(PREFIX)/$(LIBDIR)/libcryptopp.so.0.0.0
+
+-libcryptopp.a: $(LIBOBJS)
+- $(AR) $(ARFLAGS) $@ $(LIBOBJS)
+- $(RANLIB) $@
++libcrypto++.la: $(LIBOBJS)
++ $(LIBTOOL) --tag=CC --mode=link $(CXX) $(LDFLAGS) -rpath $(PREFIX)/$(LIBDIR) -o $@ $(LIBOBJS)
+
+-cryptest.exe: libcryptopp.a $(TESTOBJS)
+- $(CXX) -o $@ $(CXXFLAGS) $(TESTOBJS) -L. -lcryptopp $(LDFLAGS) $(LDLIBS)
++cryptest: libcrypto++.la $(TESTOBJS)
++ $(LIBTOOL) --tag=CC --mode=link $(CXX) $(LDFLAGS) -o $@ $(TESTOBJS) -L. -lcrypto++ $(LDLIBS)
+
+ nolib: $(OBJS) # makes it faster to test changes
+- $(CXX) -o ct $(CXXFLAGS) $(OBJS) $(LDFLAGS) $(LDLIBS)
++ $(LIBTOOL) --tag=CC --mode=link $(CXX) -o ct $(LDFLAGS) $(OBJS) $(LDLIBS)
+
+-dll: cryptest.import.exe dlltest.exe
++dll: cryptest.import dlltest
+
+ cryptopp.dll: $(DLLOBJS)
+ $(CXX) -shared -o $@ $(CXXFLAGS) $(DLLOBJS) $(LDFLAGS) $(LDLIBS) -Wl,--out-implib=libcryptopp.dll.a
+@@ -142,10 +148,10 @@
+ $(AR) $(ARFLAGS) $@ $(LIBIMPORTOBJS)
+ $(RANLIB) $@
+
+-cryptest.import.exe: cryptopp.dll libcryptopp.import.a $(TESTIMPORTOBJS)
++cryptest.import: cryptopp.dll libcryptopp.import.a $(TESTIMPORTOBJS)
+ $(CXX) -o $@ $(CXXFLAGS) $(TESTIMPORTOBJS) -L. -lcryptopp.dll -lcryptopp.import $(LDFLAGS) $(LDLIBS)
+
+-dlltest.exe: cryptopp.dll $(DLLTESTOBJS)
++dlltest: cryptopp.dll $(DLLTESTOBJS)
+ $(CXX) -o $@ $(CXXFLAGS) $(DLLTESTOBJS) -L. -lcryptopp.dll $(LDFLAGS) $(LDLIBS)
+
+ adhoc.cpp: adhoc.cpp.proto
+@@ -155,14 +161,14 @@
+ touch adhoc.cpp
+ endif
+
+-%.dllonly.o : %.cpp
++%.dllonly.lo : %.cpp
+ $(CXX) $(CXXFLAGS) -DCRYPTOPP_DLL_ONLY -c $< -o $@
+
+-%.import.o : %.cpp
++%.import.lo : %.cpp
+ $(CXX) $(CXXFLAGS) -DCRYPTOPP_IMPORTS -c $< -o $@
+
+-%.export.o : %.cpp
++%.export.lo : %.cpp
+ $(CXX) $(CXXFLAGS) -DCRYPTOPP_EXPORTS -c $< -o $@
+
+-%.o : %.cpp
+- $(CXX) $(CXXFLAGS) -c $<
++%.lo : %.cpp
++ $(LIBTOOL) --tag=CXX --mode=compile $(CXX) $(CXXFLAGS) -c $<