summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-04-21 21:29:05 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-04-21 21:29:05 +0000
commitdb2d24068fe880eb3c7f804bcf5b33ad3dd36936 (patch)
tree3a05a64540ee9933d28a153d693b3f3e56a012a8 /dev-libs/wayland
parentremove myself as maintainer (diff)
downloadgentoo-2-db2d24068fe880eb3c7f804bcf5b33ad3dd36936.tar.gz
gentoo-2-db2d24068fe880eb3c7f804bcf5b33ad3dd36936.tar.bz2
gentoo-2-db2d24068fe880eb3c7f804bcf5b33ad3dd36936.zip
Version bumps.
(Portage version: 2.1.11.55/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/wayland')
-rw-r--r--dev-libs/wayland/ChangeLog9
-rw-r--r--dev-libs/wayland/wayland-1.0.6.ebuild48
-rw-r--r--dev-libs/wayland/wayland-1.1.0.ebuild48
3 files changed, 104 insertions, 1 deletions
diff --git a/dev-libs/wayland/ChangeLog b/dev-libs/wayland/ChangeLog
index aaa83e9bc3db..40815379d7f5 100644
--- a/dev-libs/wayland/ChangeLog
+++ b/dev-libs/wayland/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/wayland
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/ChangeLog,v 1.16 2013/02/19 18:09:24 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/ChangeLog,v 1.17 2013/04/21 21:29:05 chithanh Exp $
+
+*wayland-1.0.6 (21 Apr 2013)
+*wayland-1.1.0 (21 Apr 2013)
+
+ 21 Apr 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +wayland-1.0.6.ebuild, +wayland-1.1.0.ebuild:
+ Version bumps.
19 Feb 2013; Matt Turner <mattst88@gentoo.org> wayland-1.0.4.ebuild:
Explicitly disable documentation.
diff --git a/dev-libs/wayland/wayland-1.0.6.ebuild b/dev-libs/wayland/wayland-1.0.6.ebuild
new file mode 100644
index 000000000000..293d65f8de13
--- /dev/null
+++ b/dev-libs/wayland/wayland-1.0.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/wayland-1.0.6.ebuild,v 1.1 2013/04/21 21:29:05 chithanh Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/${PN}/${PN}"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-2"
+ EXPERIMENTAL="true"
+fi
+
+inherit autotools toolchain-funcs $GIT_ECLASS
+
+DESCRIPTION="Wayland protocol libraries"
+HOMEPAGE="http://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="http://wayland.freedesktop.org/releases/${P}.tar.xz"
+fi
+
+LICENSE="CC-BY-SA-3.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="dev-libs/expat
+ virtual/libffi"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ myconf="$(use_enable static-libs static) \
+ $(use_enable doc documentation)"
+ if tc-is-cross-compiler ; then
+ myconf+=" --disable-scanner"
+ fi
+ econf ${myconf}
+}
diff --git a/dev-libs/wayland/wayland-1.1.0.ebuild b/dev-libs/wayland/wayland-1.1.0.ebuild
new file mode 100644
index 000000000000..db071a3b8842
--- /dev/null
+++ b/dev-libs/wayland/wayland-1.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/wayland-1.1.0.ebuild,v 1.1 2013/04/21 21:29:05 chithanh Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/${PN}/${PN}"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-2"
+ EXPERIMENTAL="true"
+fi
+
+inherit autotools toolchain-funcs $GIT_ECLASS
+
+DESCRIPTION="Wayland protocol libraries"
+HOMEPAGE="http://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="http://wayland.freedesktop.org/releases/${P}.tar.xz"
+fi
+
+LICENSE="CC-BY-SA-3.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="dev-libs/expat
+ virtual/libffi"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ myconf="$(use_enable static-libs static) \
+ $(use_enable doc documentation)"
+ if tc-is-cross-compiler ; then
+ myconf+=" --disable-scanner"
+ fi
+ econf ${myconf}
+}