summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-02-27 09:39:06 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-02-27 09:39:06 +0000
commitcbd254e5b00f4fd304fc99fd7ebaaa559515ebd1 (patch)
tree1fb7196668c9500598b7307ffcb92ab4c1b187f8 /dev-libs/elfutils
parentMarked ~ppc/~ppc64 wrt #350891 (diff)
downloadgentoo-2-cbd254e5b00f4fd304fc99fd7ebaaa559515ebd1.tar.gz
gentoo-2-cbd254e5b00f4fd304fc99fd7ebaaa559515ebd1.tar.bz2
gentoo-2-cbd254e5b00f4fd304fc99fd7ebaaa559515ebd1.zip
Version bump.
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/elfutils')
-rw-r--r--dev-libs/elfutils/ChangeLog7
-rw-r--r--dev-libs/elfutils/elfutils-0.152.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-libs/elfutils/ChangeLog b/dev-libs/elfutils/ChangeLog
index 89b5383e1891..7568994b1d82 100644
--- a/dev-libs/elfutils/ChangeLog
+++ b/dev-libs/elfutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/elfutils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.150 2011/01/22 11:25:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.151 2011/02/27 09:39:06 dirtyepic Exp $
+
+*elfutils-0.152 (27 Feb 2011)
+
+ 27 Feb 2011; Ryan Hill <dirtyepic@gentoo.org> +elfutils-0.152.ebuild:
+ Version bump.
22 Jan 2011; Raúl Porcel <armin76@gentoo.org> elfutils-0.149.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #348407
diff --git a/dev-libs/elfutils/elfutils-0.152.ebuild b/dev-libs/elfutils/elfutils-0.152.ebuild
new file mode 100644
index 000000000000..4e13427ab2c3
--- /dev/null
+++ b/dev-libs/elfutils/elfutils-0.152.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/elfutils-0.152.ebuild,v 1.1 2011/02/27 09:39:06 dirtyepic Exp $
+
+inherit eutils
+
+DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
+HOMEPAGE="https://fedorahosted.org/elfutils"
+SRC_URI="https://fedorahosted.org/releases/e/l/elfutils/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2-with-exceptions"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 lzma nls zlib elibc_glibc"
+
+# This pkg does not actually seem to compile currently in a uClibc
+# environment (xrealloc errs), but we need to ensure that glibc never
+# gets pulled in as a dep since this package does not respect virtual/libc
+RDEPEND="zlib? ( >=sys-libs/zlib-1.2.2.3 )
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}
+ elibc_glibc? ( !prefix? ( >=sys-libs/glibc-2.7 ) )
+ nls? ( sys-devel/gettext )
+ >=sys-devel/flex-2.5.4a
+ sys-devel/m4
+ >=sys-devel/binutils-2.15.90.0.1
+ >=sys-devel/gcc-4.1.2
+ !dev-libs/libelf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.118-PaX-support.patch
+ epatch "${FILESDIR}"/${PN}-0.150-bashifications.patch #287130
+ find . -name Makefile.in -print0 | xargs -0 sed -i -e 's:-W\(error\|extra\)::g'
+ use test || sed -i -e 's: tests::' Makefile.in #226349
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --program-prefix="eu-" \
+ $(use_with zlib) \
+ $(use_with bzip2 bzlib) \
+ $(use_with lzma)
+
+ emake || die
+}
+
+src_test() {
+ env LD_LIBRARY_PATH="${S}/libelf:${S}/libebl:${S}/libdw:${S}/libasm" \
+ LC_ALL="C" \
+ emake -j1 check || die "test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS NOTES README THANKS TODO
+}