summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-05-11 18:37:07 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-05-11 18:37:07 +0000
commit4f5e66c3130fac691929872e550f852d4530daaf (patch)
tree2cd1a03919bf0b7e7f9416ce43b93b23f7ea50da /dev-lang/yasm
parentAdd changelog that repoman failed to commit for me (diff)
downloadgentoo-2-4f5e66c3130fac691929872e550f852d4530daaf.tar.gz
gentoo-2-4f5e66c3130fac691929872e550f852d4530daaf.tar.bz2
gentoo-2-4f5e66c3130fac691929872e550f852d4530daaf.zip
Disable automagic app-text/xmlto usage to prevent manpages from getting rebuilt unnecessarily wrt #459940 by Anton Kochkov. Use python-r1 instead of python eclass
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'dev-lang/yasm')
-rw-r--r--dev-lang/yasm/ChangeLog8
-rw-r--r--dev-lang/yasm/yasm-1.2.0-r1.ebuild23
-rw-r--r--dev-lang/yasm/yasm-9999.ebuild34
3 files changed, 36 insertions, 29 deletions
diff --git a/dev-lang/yasm/ChangeLog b/dev-lang/yasm/ChangeLog
index 3089693b0fed..1d0ea29fe8d6 100644
--- a/dev-lang/yasm/ChangeLog
+++ b/dev-lang/yasm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/yasm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.59 2013/01/15 17:31:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.60 2013/05/11 18:37:07 ssuominen Exp $
+
+ 11 May 2013; Samuli Suominen <ssuominen@gentoo.org> yasm-1.2.0-r1.ebuild,
+ yasm-9999.ebuild:
+ Disable automagic app-text/xmlto usage to prevent manpages from getting
+ rebuilt unnecessarily wrt #459940 by Anton Kochkov
+ Use python-r1.eclass instead of the obsolete python.eclass
*yasm-1.2.0-r1 (15 Jan 2013)
diff --git a/dev-lang/yasm/yasm-1.2.0-r1.ebuild b/dev-lang/yasm/yasm-1.2.0-r1.ebuild
index 75de13347ceb..55e0026d9dc5 100644
--- a/dev-lang/yasm/yasm-1.2.0-r1.ebuild
+++ b/dev-lang/yasm/yasm-1.2.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-1.2.0-r1.ebuild,v 1.1 2013/01/15 17:31:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-1.2.0-r1.ebuild,v 1.2 2013/05/11 18:37:07 ssuominen Exp $
-EAPI=4
-PYTHON_DEPEND="python? 2:2.7"
-inherit autotools eutils python
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit autotools eutils python-r1
DESCRIPTION="An assembler for x86 and x86_64 instruction sets"
HOMEPAGE="http://yasm.tortall.net/"
@@ -18,18 +18,15 @@ IUSE="nls python"
RDEPEND="nls? ( virtual/libintl )"
DEPEND="nls? ( sys-devel/gettext )
- python? ( >=dev-python/cython-0.14 )"
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/cython-0.14[${PYTHON_USEDEP}]
+ )"
DOCS=( AUTHORS )
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
src_prepare() {
+ sed -i -e 's:xmlto:&dIsAbLe:' configure.ac || die #459940
epatch "${WORKDIR}"/${P}-x32.patch #435838
chmod a+rx modules/objfmts/elf/tests/{gas,}x32/*_test.sh
epatch "${FILESDIR}/${P}-fix_cython_check.patch"
@@ -39,6 +36,8 @@ src_prepare() {
}
src_configure() {
+ use python && python_export_best
+
econf \
$(use_enable python) \
$(use_enable python python-bindings) \
diff --git a/dev-lang/yasm/yasm-9999.ebuild b/dev-lang/yasm/yasm-9999.ebuild
index 7e9a65c97505..76c5b4d6cb40 100644
--- a/dev-lang/yasm/yasm-9999.ebuild
+++ b/dev-lang/yasm/yasm-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-9999.ebuild,v 1.2 2013/01/15 02:41:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-9999.ebuild,v 1.3 2013/05/11 18:37:07 ssuominen Exp $
-EAPI=4
-PYTHON_DEPEND="python? 2:2.7"
-inherit autotools eutils python
-if [[ ${PV} == "9999"* ]] ; then
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit autotools eutils python-r1
+if [[ ${PV} == 9999* ]] ; then
EGIT_REPO_URI="git://github.com/yasm/yasm.git"
inherit git-2
else
@@ -22,30 +22,32 @@ IUSE="nls python"
RDEPEND="nls? ( virtual/libintl )"
DEPEND="nls? ( sys-devel/gettext )
- python? ( >=dev-python/cython-0.14 )"
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/cython-0.14[${PYTHON_USEDEP}]
+ )"
+if [[ ${PV} == 9999* ]]; then
+ DEPEND="${DEPEND} ${PYTHON_DEPS} app-text/xmlto"
+fi
DOCS=( AUTHORS )
-pkg_setup() {
- # Python is required for generating x86insns.c, see
- # modules/arch/x86/Makefile.inc for more details.
- if use python || [[ ${PV} == "9999" ]] ; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
src_prepare() {
+ if ! [[ ${PV} == 9999* ]]; then
+ sed -i -e 's:xmlto:&dIsAbLe:' configure.ac || die #459940
+ fi
# ksh doesn't grok $(xxx), makes aclocal fail
sed -i -e '1c\#!/usr/bin/env sh' YASM-VERSION-GEN.sh || die
eautoreconf
- if [[ ${PV} == "9999" ]] ; then
+ if [[ ${PV} == 9999* ]] ; then
./modules/arch/x86/gen_x86_insn.py || die
fi
}
src_configure() {
+ python_export_best
+
econf \
--disable-warnerror \
$(use_enable python) \