summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-10-26 20:19:04 +0000
committerFabian Groffen <grobian@gentoo.org>2010-10-26 20:19:04 +0000
commitf91b169da68bc5f5e01406c6c9fc8a71a57509ef (patch)
tree56386a9760570be5e7338c6da91290857daf6fb5 /dev-lang/orc
parentInitial commit of python-cluster. Bug #340975. Thanks to montjoie <corentin.l... (diff)
downloadgentoo-2-f91b169da68bc5f5e01406c6c9fc8a71a57509ef.tar.gz
gentoo-2-f91b169da68bc5f5e01406c6c9fc8a71a57509ef.tar.bz2
gentoo-2-f91b169da68bc5f5e01406c6c9fc8a71a57509ef.zip
Fix compilation on PPC/Darwin by dropping any optimisation level
(Portage version: 2.2.01.17086-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'dev-lang/orc')
-rw-r--r--dev-lang/orc/ChangeLog5
-rw-r--r--dev-lang/orc/orc-0.4.11.ebuild7
2 files changed, 9 insertions, 3 deletions
diff --git a/dev-lang/orc/ChangeLog b/dev-lang/orc/ChangeLog
index 814321e74995..42b8d36feaf8 100644
--- a/dev-lang/orc/ChangeLog
+++ b/dev-lang/orc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/orc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/orc/ChangeLog,v 1.10 2010/10/15 10:09:33 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/orc/ChangeLog,v 1.11 2010/10/26 20:19:04 grobian Exp $
+
+ 26 Oct 2010; Fabian Groffen <grobian@gentoo.org> orc-0.4.11.ebuild:
+ Fix compilation on PPC/Darwin by dropping any optimisation level
15 Oct 2010; Arun Raghavan <ford_prefect@gentoo.org> -orc-0.4.7.ebuild:
Prune older version.
diff --git a/dev-lang/orc/orc-0.4.11.ebuild b/dev-lang/orc/orc-0.4.11.ebuild
index defb24945d25..fa9ad4678cd5 100644
--- a/dev-lang/orc/orc-0.4.11.ebuild
+++ b/dev-lang/orc/orc-0.4.11.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/orc/orc-0.4.11.ebuild,v 1.1 2010/10/15 10:05:50 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/orc/orc-0.4.11.ebuild,v 1.2 2010/10/26 20:19:04 grobian Exp $
EAPI=3
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="The Oil Runtime Compiler"
HOMEPAGE="http://code.entropywave.com/projects/orc/"
@@ -22,6 +22,9 @@ src_prepare() {
}
src_configure() {
+ # any optimisation on PPC/Darwin yields in a complaint from the assembler
+ # Parameter error: r0 not allowed for parameter %lu (code as 0 not r0)
+ [[ ${CHOST} == powerpc*-*-darwin* ]] && filter-flags -O*
econf \
$(use_enable static-libs static) \
--disable-dependency-tracking \