summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2008-07-06 08:05:27 +0000
committerKeri Harris <keri@gentoo.org>2008-07-06 08:05:27 +0000
commitb686c5064bcebe3dd399864ac0af9024fe5f015f (patch)
tree61ffaf7e62758000ce00aefd73c8123bf0f13f28 /dev-lang/mozart
parentStable on x86 wrt #228647 (diff)
downloadgentoo-2-b686c5064bcebe3dd399864ac0af9024fe5f015f.tar.gz
gentoo-2-b686c5064bcebe3dd399864ac0af9024fe5f015f.tar.bz2
gentoo-2-b686c5064bcebe3dd399864ac0af9024fe5f015f.zip
Version bump.
(Portage version: 2.1.5.5)
Diffstat (limited to 'dev-lang/mozart')
-rw-r--r--dev-lang/mozart/ChangeLog11
-rw-r--r--dev-lang/mozart/files/mozart-1.4.0-contrib.patch273
-rw-r--r--dev-lang/mozart/files/mozart-1.4.0-dss-pic.patch10
-rw-r--r--dev-lang/mozart/files/mozart-1.4.0-dss-prefix.patch42
-rw-r--r--dev-lang/mozart/files/mozart-1.4.0-nostrip.patch11
-rw-r--r--dev-lang/mozart/files/mozart-1.4.0-ozhome.patch11
-rw-r--r--dev-lang/mozart/files/mozart-1.4.0-ozplatform-sparc.patch11
-rw-r--r--dev-lang/mozart/files/mozart-1.4.0-parallel-make.patch246
-rw-r--r--dev-lang/mozart/mozart-1.4.0.ebuild117
9 files changed, 731 insertions, 1 deletions
diff --git a/dev-lang/mozart/ChangeLog b/dev-lang/mozart/ChangeLog
index 6614cca8ee14..ba74a447183a 100644
--- a/dev-lang/mozart/ChangeLog
+++ b/dev-lang/mozart/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-lang/mozart
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mozart/ChangeLog,v 1.18 2008/06/01 22:15:21 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mozart/ChangeLog,v 1.19 2008/07/06 08:05:26 keri Exp $
+
+*mozart-1.4.0 (06 Jul 2008)
+
+ 06 Jul 2008; keri <keri@gentoo.org> +files/mozart-1.4.0-contrib.patch,
+ +files/mozart-1.4.0-dss-pic.patch, +files/mozart-1.4.0-dss-prefix.patch,
+ +files/mozart-1.4.0-nostrip.patch, +files/mozart-1.4.0-ozhome.patch,
+ +files/mozart-1.4.0-ozplatform-sparc.patch,
+ +files/mozart-1.4.0-parallel-make.patch, +mozart-1.4.0.ebuild:
+ Version bump.
01 Jun 2008; keri <keri@gentoo.org> files/mozart-1.3.2-portage.patch:
Make Unnester.ozf depend on Builtins.ozf. Closes #212558.
diff --git a/dev-lang/mozart/files/mozart-1.4.0-contrib.patch b/dev-lang/mozart/files/mozart-1.4.0-contrib.patch
new file mode 100644
index 000000000000..bf5830c61ce0
--- /dev/null
+++ b/dev-lang/mozart/files/mozart-1.4.0-contrib.patch
@@ -0,0 +1,273 @@
+diff -ur mozart-1.4.0.20080704.orig/contrib/ap/Makefile.in mozart-1.4.0.20080704/contrib/ap/Makefile.in
+--- mozart-1.4.0.20080704.orig/contrib/ap/Makefile.in 2001-08-05 10:24:45.000000000 +1200
++++ mozart-1.4.0.20080704/contrib/ap/Makefile.in 2008-07-06 12:57:25.000000000 +1200
+@@ -12,13 +12,17 @@
+ INSTALL_LIB = $(INSTALL) -m 444
+ FUNCTORS = OptionSheet.ozf
+ NEWCACHEDIR = $(PREFIX)/cache/x-oz/contrib/ap
++NEW_FUNCTORS = $(addprefix $(NEWCACHEDIR)/,$(FUNCTORS))
+ PLATFORM = @PLATFORM@
+ CYGPATH = $(SRCTOP)/share/lib/cygpath.sh
+
+ all: $(FUNCTORS)
+ %.ozf: %.oz
+ $(OZC) -z 9 -c $(shell $(CYGPATH) "$<") -o $@
+-install: $(NEWCACHEDIR) $(addprefix $(NEWCACHEDIR)/,$(FUNCTORS))
++install: $(NEWCACHEDIR) $(NEW_FUNCTORS)
++
++$(NEW_FUNCTORS): $(NEWCACHEDIR)
++
+ $(LIB_DIR) $(NEWCACHEDIR):
+ $(INSTALL_DIR) $@
+ $(LIB_DIR)/%.ozf: %.ozf
+diff -ur mozart-1.4.0.20080704.orig/contrib/compat/Makefile.in mozart-1.4.0.20080704/contrib/compat/Makefile.in
+--- mozart-1.4.0.20080704.orig/contrib/compat/Makefile.in 2003-11-26 03:53:52.000000000 +1300
++++ mozart-1.4.0.20080704/contrib/compat/Makefile.in 2008-07-06 12:58:27.000000000 +1200
+@@ -38,6 +38,9 @@
+
+ install: $(BIN_DIR) $(BIN_TARGETS) $(CACHEDIR) $(CACHE_TARGETS)
+
++$(BIN_TARGETS): $(BIN_DIR)
++$(CACHE_TARGETS): $(CACHEDIR)
++
+ $(BIN_DIR) $(CACHEDIR):
+ $(INSTALL_DIR) $@
+
+diff -ur mozart-1.4.0.20080704.orig/contrib/davinci/Makefile.in mozart-1.4.0.20080704/contrib/davinci/Makefile.in
+--- mozart-1.4.0.20080704.orig/contrib/davinci/Makefile.in 2001-08-05 10:24:45.000000000 +1200
++++ mozart-1.4.0.20080704/contrib/davinci/Makefile.in 2008-07-06 12:59:05.000000000 +1200
+@@ -53,6 +53,8 @@
+ all: $(TARGETS)
+ install: $(LIB_DIR) $(LIB_TARGETS)
+
++$(LIB_TARGETS): $(LIB_DIR)
++
+ $(LIB_DIR):
+ $(INSTALL_DIR) $@
+
+diff -ur mozart-1.4.0.20080704.orig/contrib/directory/Makefile.in mozart-1.4.0.20080704/contrib/directory/Makefile.in
+--- mozart-1.4.0.20080704.orig/contrib/directory/Makefile.in 2001-08-05 10:24:45.000000000 +1200
++++ mozart-1.4.0.20080704/contrib/directory/Makefile.in 2008-07-06 12:59:30.000000000 +1200
+@@ -56,6 +56,8 @@
+ all: $(TARGETS)
+ install: $(NEWCACHEDIR) $(NEW_TARGETS)
+
++$(NEW_TARGETS): $(NEWCACHEDIR)
++
+ $(LIB_DIR) $(NEWCACHEDIR):
+ $(INSTALL_DIR) $@
+
+diff -ur mozart-1.4.0.20080704.orig/contrib/doc/code/Makefile.in mozart-1.4.0.20080704/contrib/doc/code/Makefile.in
+--- mozart-1.4.0.20080704.orig/contrib/doc/code/Makefile.in 2002-04-02 00:31:22.000000000 +1200
++++ mozart-1.4.0.20080704/contrib/doc/code/Makefile.in 2008-07-06 13:00:26.000000000 +1200
+@@ -54,6 +54,9 @@
+ install: $(ELIB_DIR) $(ELIB_TARGETS) \
+ $(NEWCACHEDIR) $(NEW_TARGETS)
+
++$(ELIB_TARGETS): $(ELIB_DIR)
++$(NEW_TARGETS): $(NEWCACHEDIR)
++
+ $(LIB_DIR) $(ELIB_DIR) $(NEWCACHEDIR):
+ $(INSTALL_DIR) $@
+
+diff -ur mozart-1.4.0.20080704.orig/contrib/doc/sgml/Makefile.in mozart-1.4.0.20080704/contrib/doc/sgml/Makefile.in
+--- mozart-1.4.0.20080704.orig/contrib/doc/sgml/Makefile.in 2001-08-05 10:24:45.000000000 +1200
++++ mozart-1.4.0.20080704/contrib/doc/sgml/Makefile.in 2008-07-06 13:00:51.000000000 +1200
+@@ -22,6 +22,8 @@
+ all: $(TARGETS)
+ install: $(NEWCACHEDIR) $(NEW_TARGETS)
+
++$(NEW_TARGETS): $(NEWCACHEDIR)
++
+ $(LIB_DIR) $(NEWCACHEDIR):
+ $(INSTALL_DIR) $@
+
+diff -ur mozart-1.4.0.20080704.orig/contrib/fcp/Makefile.in mozart-1.4.0.20080704/contrib/fcp/Makefile.in
+--- mozart-1.4.0.20080704.orig/contrib/fcp/Makefile.in 2001-08-05 10:24:45.000000000 +1200
++++ mozart-1.4.0.20080704/contrib/fcp/Makefile.in 2008-07-06 13:08:32.000000000 +1200
+@@ -74,6 +74,8 @@
+
+ new: clean all
+
++$(LIB_TARGETS): $(LIB_DIR)
++
+ $(LIB_DIR):
+ $(INSTALL_DIR) $@
+
+diff -ur mozart-1.4.0.20080704.orig/contrib/gdbm/Makefile.in mozart-1.4.0.20080704/contrib/gdbm/Makefile.in
+--- mozart-1.4.0.20080704.orig/contrib/gdbm/Makefile.in 2003-01-08 02:40:10.000000000 +1300
++++ mozart-1.4.0.20080704/contrib/gdbm/Makefile.in 2008-07-06 13:09:02.000000000 +1200
+@@ -36,6 +36,8 @@
+ all: $(TARGETS)
+ install: $(NEWCACHEDIR) $(NEW_TARGETS)
+
++$(NEW_TARGETS): $(NEWCACHEDIR)
++
+ $(LIB_DIR) $(NEWCACHEDIR):
+ $(INSTALL_DIR) $@
+
+diff -ur mozart-1.4.0.20080704.orig/contrib/gtk/Makefile.in mozart-1.4.0.20080704/contrib/gtk/Makefile.in
+--- mozart-1.4.0.20080704.orig/contrib/gtk/Makefile.in 2003-01-08 02:40:10.000000000 +1300
++++ mozart-1.4.0.20080704/contrib/gtk/Makefile.in 2008-07-06 13:10:48.000000000 +1200
+@@ -212,7 +212,7 @@
+ all: $(TARGETS) binding
+ install: $(LIB_DIR) $(LIB_TARGETS) $(EXAMPLES_DIR) $(EXAMPLES_TARGETS) \
+ install_names
+-install_names:
++install_names: $(LIB_DIR)
+ cp ClassNames.ozp $(LIB_DIR)/ClassNames.ozp
+
+ #---------------------------------------------------------------------
+@@ -259,6 +259,9 @@
+ # Installing
+ #---------------------------------------------------------------------
+
++$(LIB_TARGETS): $(LIB_DIR)
++$(EXAMPLES_TARGETS): $(EXAMPLES_DIR)
++
+ $(LIB_DIR) $(EXAMPLES_DIR):
+ $(INSTALL_DIR) $@
+
+diff -ur mozart-1.4.0.20080704.orig/contrib/investigator/Makefile.in mozart-1.4.0.20080704/contrib/investigator/Makefile.in
+--- mozart-1.4.0.20080704.orig/contrib/investigator/Makefile.in 2001-08-05 10:24:45.000000000 +1200
++++ mozart-1.4.0.20080704/contrib/investigator/Makefile.in 2008-07-06 13:11:27.000000000 +1200
+@@ -64,6 +64,8 @@
+ install: $(LIB_DIR) $(LIB_TARGETS)
+ new: clean all
+
++$(LIB_TARGETS): $(LIB_DIR)
++
+ $(LIB_DIR):
+ $(INSTALL_DIR) $@
+
+diff -ur mozart-1.4.0.20080704.orig/contrib/lp/Makefile.in mozart-1.4.0.20080704/contrib/lp/Makefile.in
+--- mozart-1.4.0.20080704.orig/contrib/lp/Makefile.in 2003-10-10 23:14:48.000000000 +1300
++++ mozart-1.4.0.20080704/contrib/lp/Makefile.in 2008-07-06 13:11:55.000000000 +1200
+@@ -75,6 +75,8 @@
+ all: $(TARGETS)
+ install: $(LIB_DIR) $(LIB_TARGETS)
+
++$(LIB_TARGETS): $(LIB_DIR)
++
+ $(LIB_DIR):
+ $(INSTALL_DIR) $@
+
+diff -ur mozart-1.4.0.20080704.orig/contrib/maple/Makefile.in mozart-1.4.0.20080704/contrib/maple/Makefile.in
+--- mozart-1.4.0.20080704.orig/contrib/maple/Makefile.in 2001-08-05 10:24:45.000000000 +1200
++++ mozart-1.4.0.20080704/contrib/maple/Makefile.in 2008-07-06 13:12:29.000000000 +1200
+@@ -90,6 +90,8 @@
+ all: first $(TARGETS)
+ install: $(LIB_DIR) $(LIB_TARGETS)
+
++$(LIB_TARGETS): $(LIB_DIR)
++
+ $(LIB_DIR):
+ $(INSTALL_DIR) $@
+
+diff -ur mozart-1.4.0.20080704.orig/contrib/micq/Makefile.in mozart-1.4.0.20080704/contrib/micq/Makefile.in
+--- mozart-1.4.0.20080704.orig/contrib/micq/Makefile.in 2001-08-05 10:24:45.000000000 +1200
++++ mozart-1.4.0.20080704/contrib/micq/Makefile.in 2008-07-06 13:14:05.000000000 +1200
+@@ -17,6 +17,7 @@
+ INSTALL_DIR = @INSTALL_DIR@
+ INSTALL_LIB = $(INSTALL) -m 444
+ APPLETS = server.oza client.oza
++NEW_APPLETS = $(addprefix $(NEWCACHEDIR)/,$(APPLETS))
+ GIFCONV = Gif2Functor.oza
+ ICONDIR = $(SRCDIR)/Icons2
+ MAKEGIF = $(OZENGINE) $(GIFCONV)
+@@ -26,7 +27,10 @@
+ all: $(GIFCONV) $(GIFS) $(APPLETS)
+
+ install:: $(DEMO_DIR) $(DEMO_DIR)/MIM.oza \
+- $(NEWCACHEDIR) $(addprefix $(NEWCACHEDIR)/,$(APPLETS))
++ $(NEWCACHEDIR) $(NEW_APPLETS)
++
++$(DEMO_DIR)/MIM.oza: $(DEMO_DIR)
++$(NEW_APPLETS): $(NEWCACHEDIR)
+
+ $(NEWCACHEDIR)/% : %
+ $(INSTALL_LIB) $< $@
+diff -ur mozart-1.4.0.20080704.orig/contrib/os/Makefile.in mozart-1.4.0.20080704/contrib/os/Makefile.in
+--- mozart-1.4.0.20080704.orig/contrib/os/Makefile.in 2001-09-29 01:45:43.000000000 +1200
++++ mozart-1.4.0.20080704/contrib/os/Makefile.in 2008-07-06 12:53:29.000000000 +1200
+@@ -49,6 +49,8 @@
+ all: $(FUNCTORS) $(NATIVES)
+ install: $(NEWCACHEDIR) $(NEW_FUNCTORS) $(NEW_NATIVES)
+
++$(NEW_FUNCTORS) $(NEW_NATIVES): $(NEWCACHEDIR)
++
+ $(LIB_DIR) $(NEWCACHEDIR):
+ $(INSTALL_DIR) $@
+
+diff -ur mozart-1.4.0.20080704.orig/contrib/psql/Makefile.in mozart-1.4.0.20080704/contrib/psql/Makefile.in
+--- mozart-1.4.0.20080704.orig/contrib/psql/Makefile.in 2001-08-05 10:24:45.000000000 +1200
++++ mozart-1.4.0.20080704/contrib/psql/Makefile.in 2008-07-06 13:14:57.000000000 +1200
+@@ -31,6 +31,8 @@
+ all: $(TARGETS)
+ install: $(LIB_DIR) $(LIB_TARGETS)
+
++$(LIB_TARGETS): $(LIB_DIR)
++
+ $(LIB_DIR):
+ $(INSTALL_DIR) $@
+
+diff -ur mozart-1.4.0.20080704.orig/contrib/reflect/Makefile.in mozart-1.4.0.20080704/contrib/reflect/Makefile.in
+--- mozart-1.4.0.20080704.orig/contrib/reflect/Makefile.in 2001-08-05 10:24:45.000000000 +1200
++++ mozart-1.4.0.20080704/contrib/reflect/Makefile.in 2008-07-06 13:35:37.000000000 +1200
+@@ -64,6 +64,8 @@
+ all: $(TARGETS)
+ install: $(LIB_DIR) $(LIB_TARGETS)
+
++$(LIB_TARGETS): $(LIB_DIR)
++
+ $(LIB_DIR):
+ $(INSTALL_DIR) $@
+
+diff -ur mozart-1.4.0.20080704.orig/contrib/regex/Makefile.in mozart-1.4.0.20080704/contrib/regex/Makefile.in
+--- mozart-1.4.0.20080704.orig/contrib/regex/Makefile.in 2003-01-08 02:40:10.000000000 +1300
++++ mozart-1.4.0.20080704/contrib/regex/Makefile.in 2008-07-06 12:54:11.000000000 +1200
+@@ -35,6 +35,8 @@
+ all: $(TARGETS)
+ install: $(NEWCACHEDIR) $(NEW_TARGETS)
+
++$(NEW_TARGETS): $(NEWCACHEDIR)
++
+ $(LIB_DIR):
+ $(INSTALL_DIR) $@
+
+diff -ur mozart-1.4.0.20080704.orig/contrib/ri/Makefile.in mozart-1.4.0.20080704/contrib/ri/Makefile.in
+--- mozart-1.4.0.20080704.orig/contrib/ri/Makefile.in 2002-07-07 01:05:36.000000000 +1200
++++ mozart-1.4.0.20080704/contrib/ri/Makefile.in 2008-07-06 13:37:09.000000000 +1200
+@@ -78,6 +78,9 @@
+ all: first $(TARGETS)
+ install: $(LIB_DIR) $(LIB_TARGETS)
+
++$(TARGETS): first
++$(LIB_TARGETS): $(LIB_DIR)
++
+ $(LIB_DIR):
+ $(INSTALL_DIR) $@
+
+diff -ur mozart-1.4.0.20080704.orig/contrib/tk/Makefile.in mozart-1.4.0.20080704/contrib/tk/Makefile.in
+--- mozart-1.4.0.20080704.orig/contrib/tk/Makefile.in 2001-08-05 10:24:45.000000000 +1200
++++ mozart-1.4.0.20080704/contrib/tk/Makefile.in 2008-07-06 13:38:10.000000000 +1200
+@@ -11,6 +11,7 @@
+ INSTALL_DIR = @INSTALL_DIR@
+ INSTALL_LIB = $(INSTALL) -m 444
+ FUNCTORS = CheckBox.ozf ScrollFrame.ozf
++NEW_FUNCTORS = $(addprefix $(NEWCACHEDIR)/,$(FUNCTORS))
+ NEWCACHEDIR = $(PREFIX)/cache/x-oz/contrib/tk
+ PLATFORM = @PLATFORM@
+ CYGPATH = $(SRCTOP)/share/lib/cygpath.sh
+@@ -18,7 +19,10 @@
+ all: $(FUNCTORS)
+ %.ozf: %.oz
+ $(OZC) -c $(shell $(CYGPATH) "$<") -o $@
+-install: $(NEWCACHEDIR) $(addprefix $(NEWCACHEDIR)/,$(FUNCTORS))
++install: $(NEWCACHEDIR) $(NEW_FUNCTORS)
++
++$(NEW_FUNCTORS): $(NEWCACHEDIR)
++
+ $(LIB_DIR) $(NEWCACHEDIR):
+ $(INSTALL_DIR) $@
+ $(LIB_DIR)/%.ozf: %.ozf
diff --git a/dev-lang/mozart/files/mozart-1.4.0-dss-pic.patch b/dev-lang/mozart/files/mozart-1.4.0-dss-pic.patch
new file mode 100644
index 000000000000..6cf1eb0cf58f
--- /dev/null
+++ b/dev-lang/mozart/files/mozart-1.4.0-dss-pic.patch
@@ -0,0 +1,10 @@
+--- mozart-1.4.0.20080704.orig/platform/dss/configure 2008-07-03 02:57:01.000000000 +1200
++++ mozart-1.4.0.20080704/platform/dss/configure 2008-07-06 18:16:37.000000000 +1200
+@@ -5743,6 +5743,7 @@
+ { echo "$as_me:$LINENO: result: dynamic linking" >&5
+ echo "${ECHO_T}dynamic linking" >&6; }
+ ENVTYPE="lib$ENV.so"
++ CXXFLAGS="$CXXFLAGS -fPIC"
+ fi
+
+ { echo "$as_me:$LINENO: checking inclusion of examples" >&5
diff --git a/dev-lang/mozart/files/mozart-1.4.0-dss-prefix.patch b/dev-lang/mozart/files/mozart-1.4.0-dss-prefix.patch
new file mode 100644
index 000000000000..28f6f77c0a69
--- /dev/null
+++ b/dev-lang/mozart/files/mozart-1.4.0-dss-prefix.patch
@@ -0,0 +1,42 @@
+--- mozart-1.4.0.20080704.orig/platform/dss/Makefile.in 2008-07-02 20:01:31.000000000 +1200
++++ mozart-1.4.0.20080704/platform/dss/Makefile.in 2008-07-06 14:25:32.000000000 +1200
+@@ -1,5 +1,6 @@
+ # Includes necessary flags and environment
+
++PREFIX =@prefix@
+ SRCDIR =@srcdir@/src
+ VPATH = $(SRCDIR)
+ INCS = -I. -I@srcdir@/include
+@@ -64,10 +65,10 @@
+ -rm -f Makefile config.*
+
+ install: all
+- mkdir -p @prefix@
+- mkdir -p @prefix@/include
+- mkdir -p @prefix@/lib
+- @INSTALL@ @ENVTYPE@ @prefix@/lib; @EXAMPLES@
++ mkdir -p $(PREFIX)
++ mkdir -p $(PREFIX)/include
++ mkdir -p $(PREFIX)/lib
++ @INSTALL@ @ENVTYPE@ $(PREFIX)/lib; @EXAMPLES@
+ @COPY_HEADERS@
+
+ depend:: $(REALSRC)
+--- mozart-1.4.0.20080704.orig/platform/dss/configure 2008-07-03 02:57:01.000000000 +1200
++++ mozart-1.4.0.20080704/platform/dss/configure 2008-07-06 14:43:46.000000000 +1200
+@@ -5718,13 +5718,13 @@
+ { echo "$as_me:$LINENO: result: will build stand-alone messaging component" >&5
+ echo "${ECHO_T}will build stand-alone messaging component" >&6; }
+ ENV="MSL"
+- COPY_HEADERS="$INSTALL $srcdir/include/dss_comService.hh $prefix/include"
++ COPY_HEADERS="$INSTALL $srcdir/include/dss_comService.hh \$(PREFIX)/include"
+ ;;
+ *)
+ { echo "$as_me:$LINENO: result: will build full DSS" >&5
+ echo "${ECHO_T}will build full DSS" >&6; }
+ ENV="DSS"
+- COPY_HEADERS="$INSTALL $srcdir/include/*.hh $prefix/include"
++ COPY_HEADERS="$INSTALL $srcdir/include/*.hh \$(PREFIX)/include"
+ esac
+
+ { echo "$as_me:$LINENO: checking for linking choice..." >&5
diff --git a/dev-lang/mozart/files/mozart-1.4.0-nostrip.patch b/dev-lang/mozart/files/mozart-1.4.0-nostrip.patch
new file mode 100644
index 000000000000..46277f9717f6
--- /dev/null
+++ b/dev-lang/mozart/files/mozart-1.4.0-nostrip.patch
@@ -0,0 +1,11 @@
+--- mozart-1.4.0.20080704.orig/platform/tools/gump/ozflex/Makefile.in 2001-08-05 10:24:45.000000000 +1200
++++ mozart-1.4.0.20080704/platform/tools/gump/ozflex/Makefile.in 2008-07-06 16:17:19.000000000 +1200
+@@ -65,7 +65,7 @@
+
+
+ all: $(FLEX)
+- $(STRIP) $(FLEX)
++# $(STRIP) $(FLEX)
+ include $(BUILDTOP)/share/Makefile.boot
+ bootstrap: cboot-all
+
diff --git a/dev-lang/mozart/files/mozart-1.4.0-ozhome.patch b/dev-lang/mozart/files/mozart-1.4.0-ozhome.patch
new file mode 100644
index 000000000000..2479ecab2c09
--- /dev/null
+++ b/dev-lang/mozart/files/mozart-1.4.0-ozhome.patch
@@ -0,0 +1,11 @@
+--- mozart-1.4.0.20080704.orig/share/bin/oz.in 2008-04-22 20:40:41.000000000 +1200
++++ mozart-1.4.0.20080704/share/bin/oz.in 2008-07-06 19:04:46.000000000 +1200
+@@ -4,7 +4,7 @@
+ # to draw links from say /usr/local/bin to OZHOME/bin
+ # see chapter "installation" in the users manual for more information
+
+-# OZHOME=/usr/local/mozart
++OZHOME=/usr/lib/mozart
+
+
+
diff --git a/dev-lang/mozart/files/mozart-1.4.0-ozplatform-sparc.patch b/dev-lang/mozart/files/mozart-1.4.0-ozplatform-sparc.patch
new file mode 100644
index 000000000000..3601abda2780
--- /dev/null
+++ b/dev-lang/mozart/files/mozart-1.4.0-ozplatform-sparc.patch
@@ -0,0 +1,11 @@
+--- mozart-1.4.0.20080704.orig/share/bin/ozplatform 2007-09-17 17:33:08.000000000 +1200
++++ mozart-1.4.0.20080704/share/bin/ozplatform 2008-07-06 13:49:03.000000000 +1200
+@@ -40,7 +40,7 @@
+ ;;
+ m68k\ Linux\ *) OZARCH=linux-m68k
+ ;;
+- sparc\ Linux\ *) OZARCH=linux-sparc
++ sparc*\ Linux\ *) OZARCH=linux-sparc
+ ;;
+ 9000/7*HP-UX*) OZARCH=hpux-700
+ ;;
diff --git a/dev-lang/mozart/files/mozart-1.4.0-parallel-make.patch b/dev-lang/mozart/files/mozart-1.4.0-parallel-make.patch
new file mode 100644
index 000000000000..76c85a1b9a38
--- /dev/null
+++ b/dev-lang/mozart/files/mozart-1.4.0-parallel-make.patch
@@ -0,0 +1,246 @@
+diff -ur mozart-1.4.0.20080704.orig/doc/Makefile.in mozart-1.4.0.20080704/doc/Makefile.in
+--- mozart-1.4.0.20080704.orig/doc/Makefile.in 2004-02-18 18:49:19.000000000 +1300
++++ mozart-1.4.0.20080704/doc/Makefile.in 2008-07-06 12:46:26.000000000 +1200
+@@ -99,6 +99,7 @@
+ dirs="$(SUBDIRS)"; \
+ for i in $$dirs; do (cd $$i && $(MAKE) boot1st) || exit 1; done; \
+ for i in $$dirs; do (cd $$i && $(MAKE) boot2nd) || exit 1; done
++ $(MAKE) boot-THEINDEX
+
+ boot-1st boot1st:
+ -rm -f xref.db index.db
+@@ -114,7 +115,6 @@
+ # index/x-ref files got changed, the 2nd stage needs to run again
+ # COMPLETELY.
+
+-bootstrap:: boot-THEINDEX
+ all:: THEINDEX
+ THEINDEX: idx/index.html
+
+diff -ur mozart-1.4.0.20080704.orig/doc/utilities/Makefile.in mozart-1.4.0.20080704/doc/utilities/Makefile.in
+--- mozart-1.4.0.20080704.orig/doc/utilities/Makefile.in 2004-02-18 18:49:19.000000000 +1300
++++ mozart-1.4.0.20080704/doc/utilities/Makefile.in 2008-07-06 12:27:25.000000000 +1200
+@@ -85,6 +85,9 @@
+ install: $(DOCDIR) $(DOCBINFILES) $(DOCFILES)
+ installps:
+
++$(BINFILES): $(BINDIR)
++$(DOCFILES): $(DOCBINFILES)
++
+ $(BINDIR) $(DOCDIR):
+ $(INSTALL_DIR) $@
+
+diff -ur mozart-1.4.0.20080704.orig/platform/emulator/Makefile.in mozart-1.4.0.20080704/platform/emulator/Makefile.in
+--- mozart-1.4.0.20080704.orig/platform/emulator/Makefile.in 2008-06-27 01:39:31.000000000 +1200
++++ mozart-1.4.0.20080704/platform/emulator/Makefile.in 2008-07-06 10:44:17.000000000 +1200
+@@ -229,10 +229,15 @@
+ .PHONY: all first install install-bin install-inc \
+ install-dir depend tags clean cleaner distclean veryclean
+
+-all: $(TARGETS) $(DYNAMIC_MODULETARGETS)
++all: $(TARGETS) dynamic_modules
+
+ bootstrap:: all
+
++dynamic_modules: $(TARGETS)
++ for dynamic_module in $(DYNAMIC_MODULETARGETS); do \
++ $(MAKE) $$dynamic_module; \
++ done
++
+ $(MODINTERS): bidecl.perl
+ .PHONY: libDSS.a
+ libDSS.a:
+@@ -390,6 +395,8 @@
+ if test -s libDSS.so; then mkdir -p $(BINDIR)/lib; fi;
+ if test -s libDSS.so; then cp libDSS.so $(BINDIR)/lib/libDSS.so; fi;
+
++$(NEWTARGETS): $(NEWCACHEDIR)
++
+ $(NEWCACHEDIR):
+ $(INSTALL_DIR) $@
+
+diff -ur mozart-1.4.0.20080704.orig/platform/emulator/libdp/Makefile.in mozart-1.4.0.20080704/platform/emulator/libdp/Makefile.in
+--- mozart-1.4.0.20080704.orig/platform/emulator/libdp/Makefile.in 2008-06-27 01:39:31.000000000 +1200
++++ mozart-1.4.0.20080704/platform/emulator/libdp/Makefile.in 2008-07-06 10:38:40.000000000 +1200
+@@ -58,6 +58,8 @@
+ all:
+
+ # Remember the order, CREATEDFILES MUST be created before COREOBJS
++$(COREOBJS): $(CREATEDFILES)
++
+ # The DSS should be included when dynamically linked..
+ ../Glue.so-$(PLATFORM): $(CREATEDFILES) $(COREOBJS)
+ $(DYNLD) -L$(BUILDTOP)/platform/emulator -lDSS -o $@ $(COREOBJS)
+diff -ur mozart-1.4.0.20080704.orig/platform/tools/gump/Makefile.in mozart-1.4.0.20080704/platform/tools/gump/Makefile.in
+--- mozart-1.4.0.20080704.orig/platform/tools/gump/Makefile.in 2003-01-08 02:40:10.000000000 +1300
++++ mozart-1.4.0.20080704/platform/tools/gump/Makefile.in 2008-07-06 10:26:30.000000000 +1200
+@@ -63,6 +63,10 @@
+ $(INCDIR) $(INCFILES) \
+ $(NEWCACHEDIR) $(NEWCACHEFILES)
+
++$(PLATFORMFILES): $(PLATFORMDIR)
++$(INCFILES): $(INCDIR)
++$(NEWCACHEFILES): $(NEWCACHEDIR)
++
+ $(SHAREDIR) $(PLATFORMDIR) $(INCDIR) $(NEWCACHEDIR):
+ $(MKINSTALLDIRS) $@
+
+diff -ur mozart-1.4.0.20080704.orig/share/bin/Makefile.in mozart-1.4.0.20080704/share/bin/Makefile.in
+--- mozart-1.4.0.20080704.orig/share/bin/Makefile.in 2001-08-05 10:24:45.000000000 +1200
++++ mozart-1.4.0.20080704/share/bin/Makefile.in 2008-07-06 10:20:55.000000000 +1200
+@@ -54,6 +54,9 @@
+
+ install: $(BINDIR) $(LIB_SCRIPTS) $(LIB_LINKS) $(WRAPPERS)
+
++$(LIB_SCRIPTS): $(BINDIR)
++$(LIB_LINKS): $(BINDIR)
++$(WRAPPERS): $(BINDIR)
+
+ $(LIB_SCRIPTS): $(BINDIR)/% : %
+ $(INSTALL_BIN) $< $(BINDIR)
+diff -ur mozart-1.4.0.20080704.orig/share/demo/Makefile.in mozart-1.4.0.20080704/share/demo/Makefile.in
+--- mozart-1.4.0.20080704.orig/share/demo/Makefile.in 2001-10-16 23:10:03.000000000 +1300
++++ mozart-1.4.0.20080704/share/demo/Makefile.in 2008-07-06 10:18:32.000000000 +1200
+@@ -83,6 +83,10 @@
+ install:: $(OZDEMO) $(DEMOAPPLETS) \
+ $(SYSTEMDOC) $(SYSTEMOZF) $(SYSTEMOZF)/MT10.ozf $(SYSTEMDOC)/MT10.oz
+
++$(DEMOAPPLETS): $(OZDEMO)
++$(SYSTEMOZF)/MT10.ozf: $(SYSTEMOZF)
++$(SYSTEMDOC)/MT10.oz: $(SYSTEMDOC)
++
+ $(OZDEMO) $(SYSTEMDOC) $(SYSTEMOZF):
+ $(INSTALL_DIR) $@
+
+@@ -279,7 +283,10 @@
+
+ install:: $(OZIMGDIRS) $(OZIMAGES)
+
+-$(OZIMGDIRS):
++$(OZIMGDIRS): $(OZIMG)
++$(OZIMAGES): $(OZIMGDIRS)
++
++$(OZIMG) $(OZIMGDIRS):
+ $(INSTALL_DIR) $@
+ $(OZIMG)/animated-queens/%.xbm: images/animated-queens/%.xbm
+ $(INSTALL_FILE) $< $@
+diff -ur mozart-1.4.0.20080704.orig/share/elisp/Makefile.in mozart-1.4.0.20080704/share/elisp/Makefile.in
+--- mozart-1.4.0.20080704.orig/share/elisp/Makefile.in 2002-04-02 00:31:22.000000000 +1200
++++ mozart-1.4.0.20080704/share/elisp/Makefile.in 2008-07-06 10:00:36.000000000 +1200
+@@ -72,6 +72,8 @@
+
+ install: all $(ELISPDIR) $(LIBFILES)
+
++$(LIBFILES): $(ELISPDIR)
++
+ $(ELISPDIR):
+ $(INSTALL_DIR) $@
+
+diff -ur mozart-1.4.0.20080704.orig/share/examples/Makefile.in mozart-1.4.0.20080704/share/examples/Makefile.in
+--- mozart-1.4.0.20080704.orig/share/examples/Makefile.in 2003-04-23 21:49:55.000000000 +1200
++++ mozart-1.4.0.20080704/share/examples/Makefile.in 2008-07-06 09:58:52.000000000 +1200
+@@ -62,16 +62,20 @@
+ EXFUNCTORS = \
+ $(FUNCTORS:%=$(OZEX)/fd/graphics/%)
+
+-EXDIRS = \
+- sampler sampler/constraints \
+- fd grammar grammar/shieber \
+- fd/graphics
+-
++EXDIRS = fd grammar sampler
++EXFDDIRS = fd/graphics
++EXGRDIRS = grammar/shieber
++EXSAMPLERDIRS = sampler/constraints
+
+ OZEXDIRS = $(EXDIRS:%=$(OZEX)/%)
++OZEXFDDIRS = $(EXFDDIRS:%=$(OZEX)/%)
++OZEXGRDIRS = $(EXGRDIRS:%=$(OZEX)/%)
++OZEXSAMPLERDIRS = $(EXSAMPLERDIRS:%=$(OZEX)/%)
+
+
+-$(OZEX) $(OZEXDIRS):
++$(OZEXFDDIRS) $(OZEXGRDIRS) $(OZEXSAMPLERDIRS): $(OZEXDIRS)
++$(OZEXDIRS): $(OZEX)
++$(OZEX) $(OZEXDIRS) $(OZEXFDDIRS) $(OZEXGRDIRS) $(OZEXSAMPLERDIRS):
+ $(INSTALL_DIR) $@
+
+ FD = \
+@@ -116,6 +120,10 @@
+
+ install: all $(OZEX) $(OZEXDIRS) $(SAMPLER) $(EXAMPLES) $(EXFUNCTORS)
+
++$(SAMPLER): $(OZEXSAMPLERDIRS)
++$(EXAMPLES): $(OZEXFDDIRS) $(OZEXGRDIRS)
++$(EXFUNCTORS): $(OZEXFDDIRS)
++
+ clean:
+ -rm -f *~ ./*/*~ ./*/*/*~
+
+diff -ur mozart-1.4.0.20080704.orig/share/lib/Makefile.in mozart-1.4.0.20080704/share/lib/Makefile.in
+--- mozart-1.4.0.20080704.orig/share/lib/Makefile.in 2008-06-27 01:39:31.000000000 +1200
++++ mozart-1.4.0.20080704/share/lib/Makefile.in 2008-07-06 09:48:46.000000000 +1200
+@@ -291,7 +291,8 @@
+ Builtins.ozf: compiler/Builtins.oz GroundZip.ozf compiler-Builtins.oz
+
+ Unnester.ozf: compiler/Unnester.oz compiler/TupleSyntax.oz \
+- compiler/BindingAnalysis.oz compiler/UnnestFD.oz FD.ozf
++ compiler/BindingAnalysis.oz compiler/UnnestFD.oz FD.ozf \
++ Builtins.ozf
+
+ Annotate.ozf: compiler/Annotate.oz
+
+@@ -374,6 +375,11 @@
+ $(OZLIB) $(NEWINIT) \
+ $(NEWIMAGESDIR) $(NEWIMAGES)
+
++$(NEWIMAGESDIR): $(NEWCACHEDIR)
++$(NEWFUNCTORS): $(NEWCACHEDIR)
++$(NEWINIT): $(OZLIB)
++$(NEWIMAGES): $(NEWIMAGESDIR)
++
+ $(NEWCACHEDIR) $(NEWIMAGESDIR):
+ $(INSTALL_DIR) $@
+
+@@ -427,10 +433,10 @@
+ .PHONY: bootstrap check
+
+ # use the boot compiler to create the functors
+-bootstrap:
+- $(MAKE) boot-unzip boot-init boot-ozc boot-all
++bootstrap: boot-unzip
++ $(MAKE) boot-all
+
+-boot-all:
++boot-all: boot-init boot-ozc
+ $(MAKE) all \
+ OZC=$(SRCDIR)/boot-ozc.sh \
+ OZENGINE=$(SRCDIR)/oze.sh \
+diff -ur mozart-1.4.0.20080704.orig/share/tools/Makefile.in mozart-1.4.0.20080704/share/tools/Makefile.in
+--- mozart-1.4.0.20080704.orig/share/tools/Makefile.in 2002-01-30 01:39:23.000000000 +1300
++++ mozart-1.4.0.20080704/share/tools/Makefile.in 2008-07-06 09:44:12.000000000 +1200
+@@ -270,6 +270,10 @@
+ $(OZBIN) $(BINFILES) \
+ $(OZEX) $(OZEXGUMP) $(EXAMPLEFILES)
+
++$(OZEXGUMP): $(OZEX)
++$(BINFILES): $(OZBIN)
++$(EXAMPLEFILES): $(OZEXGUMP)
++
+ $(OZBIN) $(OZEX) $(OZEXGUMP):
+ $(INSTALL_DIR) $@
+
+@@ -285,6 +289,13 @@
+ $(OZCARIMAGESDIR) $(OZCARIMAGES) \
+ $(INSPECTORIMAGESDIR) $(INSPECTORIMAGES)
+
++$(IMAGESDIR): $(CACHEDIR)
++$(OZCARIMAGESDIR) $(INSPECTORIMAGESDIR): $(IMAGESDIR)
++$(TOOLSFUNCTORS): $(CACHEDIR)
++$(IMAGES): $(IMAGESDIR)
++$(OZCARIMAGES): $(OZCARIMAGESDIR)
++$(INSPECTORIMAGES): $(INSPECTORIMAGESDIR)
++
+ $(CACHEDIR) $(IMAGESDIR) $(OZCARIMAGESDIR) $(INSPECTORIMAGESDIR):
+ $(INSTALL_DIR) $@
+
diff --git a/dev-lang/mozart/mozart-1.4.0.ebuild b/dev-lang/mozart/mozart-1.4.0.ebuild
new file mode 100644
index 000000000000..a260c0074a41
--- /dev/null
+++ b/dev-lang/mozart/mozart-1.4.0.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mozart/mozart-1.4.0.ebuild,v 1.1 2008/07/06 08:05:26 keri Exp $
+
+inherit elisp-common eutils
+
+MY_P="mozart-${PV}.20080704"
+
+DESCRIPTION="Mozart is an advanced development platform for intelligent, distributed applications"
+HOMEPAGE="http://www.mozart-oz.org/"
+SRC_URI="http://www.mozart-oz.org/download/mozart-ftp/store/1.4.0-2008-07-02-tar/mozart-1.4.0.20080704-src.tar.gz
+ doc? ( http://www.mozart-oz.org/download/mozart-ftp/store/1.4.0-2008-07-02-tar/mozart-1.4.0.20080704-doc.tar.gz )"
+LICENSE="Mozart"
+
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86"
+IUSE="doc emacs gdbm static tcl threads tk"
+
+RDEPEND="dev-lang/perl
+ dev-libs/gmp
+ sys-libs/zlib
+ emacs? ( virtual/emacs )
+ gdbm? ( sys-libs/gdbm )
+ tcl? ( tk? (
+ dev-lang/tk
+ dev-lang/tcl ) )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+
+SITEFILE=50${PN}-gentoo.el
+
+S="${WORKDIR}"/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-ozhome.patch
+ epatch "${FILESDIR}"/${P}-ozplatform-sparc.patch
+ epatch "${FILESDIR}"/${P}-parallel-make.patch
+ epatch "${FILESDIR}"/${P}-contrib.patch
+ epatch "${FILESDIR}"/${P}-dss-prefix.patch
+ epatch "${FILESDIR}"/${P}-dss-pic.patch
+ epatch "${FILESDIR}"/${P}-nostrip.patch
+}
+
+src_compile() {
+ local myconf="\
+ --without-global-oz \
+ --enable-opt=none"
+
+ if use tcl && use tk ; then
+ myconf="${myconf} --enable-wish"
+ else
+ myconf="${myconf} --disable-wish"
+ fi
+
+ econf \
+ ${myconf} \
+ --disable-doc \
+ --enable-contrib \
+ --disable-contrib-micq \
+ $(use_enable doc contrib-doc) \
+ $(use_enable gdbm contrib-gdbm) \
+ $(use_enable tk contrib-tk) \
+ $(use_enable emacs compile-elisp) \
+ $(use_enable static link-static) \
+ $(use_enable threads threaded) \
+ || die "econf failed"
+
+ emake bootstrap || die "emake bootstrap failed"
+}
+
+src_test() {
+ cd "${S}"/share/test
+ emake -j1 boot-oztest || die "emake boot-oztest failed"
+ emake -j1 boot-check || die "emake boot-check failed"
+}
+
+src_install() {
+ emake \
+ PREFIX="${D}"/usr/lib/mozart \
+ ELISPDIR="${D}${SITELISP}/${PN}" \
+ install || die "emake install failed"
+
+ dosym /usr/lib/mozart/bin/convertTextPickle /usr/bin/convertTextPickle
+ dosym /usr/lib/mozart/bin/oldpickle2text /usr/bin/oldpickle2text
+ dosym /usr/lib/mozart/bin/oz /usr/bin/oz
+ dosym /usr/lib/mozart/bin/ozc /usr/bin/ozc
+ dosym /usr/lib/mozart/bin/ozd /usr/bin/ozd
+ dosym /usr/lib/mozart/bin/ozengine /usr/bin/ozengine
+ dosym /usr/lib/mozart/bin/ozl /usr/bin/ozl
+ dosym /usr/lib/mozart/bin/ozplatform /usr/bin/ozplatform
+ dosym /usr/lib/mozart/bin/oztool /usr/bin/oztool
+ dosym /usr/lib/mozart/bin/pickle2text /usr/bin/pickle2text
+ dosym /usr/lib/mozart/bin/text2pickle /usr/bin/text2pickle
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+ fi
+
+ if use doc ; then
+ dohtml -r "${WORKDIR}"/mozart/doc/*
+ fi
+
+ dodoc README
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}