summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-02-28 21:55:22 +0000
committerMichał Górny <mgorny@gentoo.org>2015-02-28 21:55:22 +0000
commitd08e5673962960fbca97c2e81cf6135d0a245bbe (patch)
treed4e681e140c13b76cffe17ad69fd37f0b043f4f7 /dev-lang/ekopath
parentseccomp USE flag is now global, removing from metadata (diff)
downloadgentoo-2-d08e5673962960fbca97c2e81cf6135d0a245bbe.tar.gz
gentoo-2-d08e5673962960fbca97c2e81cf6135d0a245bbe.tar.bz2
gentoo-2-d08e5673962960fbca97c2e81cf6135d0a245bbe.zip
Version bump. Correct LICENSE.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-lang/ekopath')
-rw-r--r--dev-lang/ekopath/ChangeLog8
-rw-r--r--dev-lang/ekopath/ekopath-5.0.5_pre20150226.ebuild88
2 files changed, 95 insertions, 1 deletions
diff --git a/dev-lang/ekopath/ChangeLog b/dev-lang/ekopath/ChangeLog
index f40ee9e57c71..239b08739f80 100644
--- a/dev-lang/ekopath/ChangeLog
+++ b/dev-lang/ekopath/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/ekopath
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ChangeLog,v 1.22 2015/01/04 15:29:10 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ChangeLog,v 1.23 2015/02/28 21:55:22 mgorny Exp $
+
+*ekopath-5.0.5_pre20150226 (28 Feb 2015)
+
+ 28 Feb 2015; Michał Górny <mgorny@gentoo.org>
+ +ekopath-5.0.5_pre20150226.ebuild:
+ Version bump. Correct LICENSE.
04 Jan 2015; <anarchy@gentoo.org> ekopath-5.0.1_pre20131115.ebuild:
Use XT_PAX for marking the installer as EI_PAX is obsolete and PT_PAX breaks
diff --git a/dev-lang/ekopath/ekopath-5.0.5_pre20150226.ebuild b/dev-lang/ekopath/ekopath-5.0.5_pre20150226.ebuild
new file mode 100644
index 000000000000..b8940d645552
--- /dev/null
+++ b/dev-lang/ekopath/ekopath-5.0.5_pre20150226.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ekopath-5.0.5_pre20150226.ebuild,v 1.1 2015/02/28 21:55:22 mgorny Exp $
+
+EAPI=5
+
+inherit versionator multilib pax-utils
+
+MY_PV=$(get_version_component_range 1-3)
+DATE=$(get_version_component_range 4)
+DATE=${DATE/pre}
+DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
+
+DESCRIPTION="PathScale EKOPath Compiler Suite"
+HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
+SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${PN}-${DATE}-installer.run
+ -> ${P}.run"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="!!app-arch/rpm"
+RDEPEND=""
+
+RESTRICT="mirror"
+
+QA_PREBUILT="
+ opt/${PN}/lib/${MY_PV}/x8664/*
+ opt/${PN}/bin/*"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}"/${A} "${S}" || die
+ chmod +x "${S}"/${P}.run
+}
+
+src_prepare() {
+ cat > 99${PN} <<-EOF
+ PATH=${EROOT%/}/opt/${PN}/bin
+ ROOTPATH=${EROOT%/}/opt/${PN}/bin
+ LDPATH=${EROOT%/}/opt/${PN}/lib:${EROOT%/}/opt/${PN}/lib/${MY_PV}/x8664/64
+ MANPATH=${EROOT%/}/opt/${PN}/docs/man
+ EOF
+}
+
+src_install() {
+ # sad stuff bug #511016
+# local libdir
+# for libdir in $(get_all_libdirs); do
+# addpredict /${libdir}/libpthread.so.0
+# addpredict /${libdir}/libc.so.6
+# addpredict /${libdir}/ld-linux-x86-64.so.2
+# addpredict /usr/${libdir}/libpthread.a
+# addpredict /usr/${libdir}/libc.a
+# addpredict /usr/${libdir}/libpthread_nonshared.a
+# addpredict /usr/${libdir}/libc_nonshared.a
+# addpredict /usr/${libdir}/libdl.a
+# addpredict /usr/${libdir}/libm.a
+# addpredict /usr/${libdir}/libdl.so
+# addpredict /usr/${libdir}/libm.so
+# addpredict /usr/${libdir}/crti.o
+# addpredict /usr/${libdir}/crt1.o
+# addpredict /usr/${libdir}/crtn.o
+# done
+
+ # EI_PAX marking is obsolete and PT_PAX breaks the binary.
+ # We must use XT_PAX to run the installer.
+ if [[ ${PAX_MARKINGS} == "XT" ]]; then
+ pax-mark m ${P}.run
+ fi
+
+ ./${P}.run \
+ --prefix "${ED%/}/opt/${PN}" \
+ --mode unattended || die
+
+ # This is a temporary/partial fix to remove a RWX GNU STACK header
+ # from libstl.so. It still leaves libstl.a in bad shape.
+ # The correct fix is in the assembly atomic-cxx.S, which we don't get
+ # See http://www.gentoo.org/proj/en/hardened/gnu-stack.xml
+ # Section 6. How to fix the stack (in practice)
+# scanelf -Xe "${ED}/opt/ekopath/lib/${MY_PV}/x8664/64/libstl.so"
+
+ rm -r "${ED}"/opt/${PN}/uninstall || die
+ doenvd 99${PN}
+}