summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2015-03-04 23:21:13 +0000
committerJames Le Cuirot <chewi@gentoo.org>2015-03-04 23:21:13 +0000
commitaf03786ea7bece4482608e3b161bc4e5e63ab4f8 (patch)
treeb79168dac91d7763acf462cfd8985b15b0ace91f /dev-java
parentVersion bump. (diff)
downloadgentoo-2-af03786ea7bece4482608e3b161bc4e5e63ab4f8.tar.gz
gentoo-2-af03786ea7bece4482608e3b161bc4e5e63ab4f8.tar.bz2
gentoo-2-af03786ea7bece4482608e3b161bc4e5e63ab4f8.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 9C6D7DE4)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jackson-databind/ChangeLog11
-rw-r--r--dev-java/jackson-databind/files/2.3.1-build.xml101
-rw-r--r--dev-java/jackson-databind/files/real-cglib.patch29
-rw-r--r--dev-java/jackson-databind/jackson-databind-2.3.1.ebuild47
-rw-r--r--dev-java/jackson-databind/jackson-databind-2.5.1.ebuild66
5 files changed, 104 insertions, 150 deletions
diff --git a/dev-java/jackson-databind/ChangeLog b/dev-java/jackson-databind/ChangeLog
index 934a03ad79e7..a9b16acb9c10 100644
--- a/dev-java/jackson-databind/ChangeLog
+++ b/dev-java/jackson-databind/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/jackson-databind
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jackson-databind/ChangeLog,v 1.1 2014/01/12 18:53:43 ercpe Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jackson-databind/ChangeLog,v 1.2 2015/03/04 23:21:13 chewi Exp $
+
+*jackson-databind-2.5.1 (04 Mar 2015)
+
+ 04 Mar 2015; James Le Cuirot <chewi@gentoo.org> +files/real-cglib.patch,
+ +jackson-databind-2.5.1.ebuild, -files/2.3.1-build.xml,
+ -jackson-databind-2.3.1.ebuild:
+ Version bump.
*jackson-databind-2.3.1 (12 Jan 2014)
diff --git a/dev-java/jackson-databind/files/2.3.1-build.xml b/dev-java/jackson-databind/files/2.3.1-build.xml
deleted file mode 100644
index dafe4e3c044f..000000000000
--- a/dev-java/jackson-databind/files/2.3.1-build.xml
+++ /dev/null
@@ -1,101 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<project name="jackson-databind" default="jar" basedir=".">
- <property file="${user.home}/.m2/maven.properties" />
- <property file="maven-build.properties" />
-
- <property name="maven.build.finalName" value="${ant.project.name}" />
- <property name="maven.build.dir" value="target" />
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes" />
- <property name="maven.build.srcDir.0" value="src/main/java" />
- <property name="maven.build.resourceDir.0" value="src/main/resources" />
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes" />
- <property name="maven.build.testDir.0" value="src/test/java" />
- <property name="maven.build.testResourceDir.0" value="src/test/resources" />
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports" />
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site" />
-
- <property name="maven.repo.local" value="${user.home}/.m2/repository" />
- <property name="maven.settings.offline" value="false" />
- <property name="maven.settings.interactiveMode" value="true" />
-
- <path id="build.classpath" />
- <path id="build.test.classpath">
- </path>
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}" />
- </target>
-
- <target name="compile" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}" />
- <javac destdir="${maven.build.outputDir}" nowarn="true" debug="true" optimize="true" deprecation="false" target="1.6" verbose="false" fork="false" source="1.6">
- <src>
- <pathelement location="${maven.build.srcDir.0}" />
- </src>
- <classpath refid="build.classpath" />
- </javac>
- <copy todir="${maven.build.outputDir}">
- <fileset dir="${maven.build.resourceDir.0}" />
- </copy>
- </target>
-
- <target name="compile-tests" depends="compile" description="Compile the test code" unless="maven.test.skip">
- <mkdir dir="${maven.build.testOutputDir}" />
- <javac destdir="${maven.build.testOutputDir}" nowarn="true" debug="true" optimize="true" deprecation="false" target="1.6" verbose="false" fork="false" source="1.6">
- <src>
- <pathelement location="${maven.build.testDir.0}" />
- </src>
- <classpath>
- <path refid="build.test.classpath" />
- <pathelement location="${maven.build.outputDir}" />
- </classpath>
- </javac>
- </target>
-
- <target name="test" depends="compile-tests" description="Run the test cases">
- <mkdir dir="${maven.test.reports}" />
- <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
- <sysproperty key="basedir" value="." />
- <formatter type="xml" />
- <formatter type="plain" usefile="false" />
- <classpath>
- <path refid="build.test.classpath" />
- <pathelement location="${maven.build.outputDir}" />
- <pathelement location="${maven.build.testOutputDir}" />
- </classpath>
- <batchtest todir="${maven.test.reports}" unless="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/Test*.java" />
- <include name="**/*Test.java" />
- <include name="**/*TestCase.java" />
- <exclude name="**/*Abstract*Test.java" />
- <exclude name="**/Base*Test.java" />
- <exclude name="**/ConcurrencyReadTest.java" />
- <exclude name="**/TestConvertingSerializer.java" />
- <exclude name="**/TestCreatorWithPolymorphic113.java" />
- </fileset>
- </batchtest>
- <batchtest todir="${maven.test.reports}" if="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/${test}.java" />
- <exclude name="**/*Abstract*Test.java" />
- <exclude name="**/Base*Test.java" />
- <exclude name="**/ConcurrencyReadTest.java" />
- <exclude name="**/TestConvertingSerializer.java" />
- <exclude name="**/TestCreatorWithPolymorphic113.java" />
- </fileset>
- </batchtest>
- </junit>
- </target>
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}" packagenames="*" destdir="${maven.reporting.outputDirectory}/apidocs" access="protected" old="false" verbose="false" encoding="UTF-8" version="true" use="true" author="true" splitindex="false" nodeprecated="false" nodeprecatedlist="false" notree="false" noindex="false" nohelp="false" nonavbar="false" serialwarn="false" charset="ISO-8859-1" source="1.6" linksource="false" breakiterator="false" maxmemory="1g">
- </javadoc>
- </target>
-
- <target name="jar" depends="compile" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar" compress="true" index="false" basedir="${maven.build.outputDir}" excludes="**/package.html" />
- </target>
-
-</project>
diff --git a/dev-java/jackson-databind/files/real-cglib.patch b/dev-java/jackson-databind/files/real-cglib.patch
new file mode 100644
index 000000000000..15b7a65ceff7
--- /dev/null
+++ b/dev-java/jackson-databind/files/real-cglib.patch
@@ -0,0 +1,29 @@
+From 2dbcc7408ff1104b84a982a5cde77ef11bc0dd93 Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Wed, 4 Mar 2015 23:07:36 +0000
+Subject: [PATCH] Use the real cglib, not the repackaged version
+
+---
+ .../java/com/fasterxml/jackson/databind/interop/TestHibernate.java | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/test/java/com/fasterxml/jackson/databind/interop/TestHibernate.java b/src/test/java/com/fasterxml/jackson/databind/interop/TestHibernate.java
+index 48dc573..b7d89b6 100644
+--- a/src/test/java/com/fasterxml/jackson/databind/interop/TestHibernate.java
++++ b/src/test/java/com/fasterxml/jackson/databind/interop/TestHibernate.java
+@@ -3,9 +3,9 @@ package com.fasterxml.jackson.databind.interop;
+ import java.lang.reflect.Method;
+ import java.util.*;
+
+-import org.hibernate.repackage.cglib.proxy.Enhancer;
+-import org.hibernate.repackage.cglib.proxy.MethodInterceptor;
+-import org.hibernate.repackage.cglib.proxy.MethodProxy;
++import net.sf.cglib.proxy.Enhancer;
++import net.sf.cglib.proxy.MethodInterceptor;
++import net.sf.cglib.proxy.MethodProxy;
+
+ import com.fasterxml.jackson.databind.*;
+
+--
+2.0.4
+
diff --git a/dev-java/jackson-databind/jackson-databind-2.3.1.ebuild b/dev-java/jackson-databind/jackson-databind-2.3.1.ebuild
deleted file mode 100644
index 974a68f7ff79..000000000000
--- a/dev-java/jackson-databind/jackson-databind-2.3.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jackson-databind/jackson-databind-2.3.1.ebuild,v 1.1 2014/01/12 18:53:43 ercpe Exp $
-
-EAPI="5"
-
-JAVA_PKG_IUSE="source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="High-performance JSON processor"
-HOMEPAGE="http://jackson.codehaus.org"
-SRC_URI="https://github.com/FasterXML/${PN}/archive/${PN}-${PV}.tar.gz"
-
-LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
-SLOT="2"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-CDEPEND="dev-java/jackson:${SLOT}
- dev-java/jackson-annotations:${SLOT}"
-RDEPEND=">=virtual/jre-1.5
- ${CDEPEND}"
-DEPEND=">=virtual/jdk-1.5
- ${CDEPEND}"
-
-JAVA_ANT_REWRITE_CLASSPATH="true"
-EANT_GENTOO_CLASSPATH="jackson-${SLOT},jackson-annotations-${SLOT}"
-EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},junit-4,cglib-2.2,groovy"
-
-S="${WORKDIR}/${PN}-${PN}-${PV}"
-
-java_prepare() {
- cp "${FILESDIR}"/${PV}-build.xml "${S}"/build.xml || die
-
- sed -e 's:@package@:com.fasterxml.jackson.databind.cfg:g' \
- -e "s:@projectversion@:${PV}:g" \
- -e 's:@projectgroupid@:com.fasterxml.jackson.core:g' \
- -e 's:@projectartifactid@:jackson-databind:g' \
- "${S}/src/main/java/com/fasterxml/jackson/databind/cfg/PackageVersion.java.in" \
- > "${S}/src/main/java/com/fasterxml/jackson/databind/cfg/PackageVersion.java" || die
-}
-
-src_install() {
- java-pkg_dojar target/${PN}.jar
- use source && java-pkg_dosrc src/main/java/*
-}
diff --git a/dev-java/jackson-databind/jackson-databind-2.5.1.ebuild b/dev-java/jackson-databind/jackson-databind-2.5.1.ebuild
new file mode 100644
index 000000000000..ea362be5c76c
--- /dev/null
+++ b/dev-java/jackson-databind/jackson-databind-2.5.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jackson-databind/jackson-databind-2.5.1.ebuild,v 1.1 2015/03/04 23:21:13 chewi Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit eutils java-pkg-2 java-pkg-simple
+
+DESCRIPTION="High-performance JSON processor"
+HOMEPAGE="https://github.com/FasterXML/jackson-databind"
+SRC_URI="https://github.com/FasterXML/${PN}/archive/${PN}-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test" # 27/1306 failures :(
+
+CDEPEND="~dev-java/jackson-${PV}:${SLOT}
+ ~dev-java/jackson-annotations-${PV}:${SLOT}"
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.5
+ ${CDEPEND}
+ test? (
+ dev-java/cglib:2.2
+ dev-java/groovy:0
+ dev-java/junit:4
+ )"
+
+S="${WORKDIR}/${PN}-${P}/src"
+JAVA_SRC_DIR="main/java"
+JAVA_GENTOO_CLASSPATH="jackson-${SLOT},jackson-annotations-${SLOT}"
+
+java_prepare() {
+ epatch "${FILESDIR}/real-cglib.patch"
+
+ sed -e 's:@package@:com.fasterxml.jackson.databind.cfg:g' \
+ -e "s:@projectversion@:${PV}:g" \
+ -e 's:@projectgroupid@:com.fasterxml.jackson.core:g' \
+ -e 's:@projectartifactid@:jackson-databind:g' \
+ "${S}/main/java/com/fasterxml/jackson/databind/cfg/PackageVersion.java.in" \
+ > "${S}/main/java/com/fasterxml/jackson/databind/cfg/PackageVersion.java" || diee
+
+ # Requires newer JScience. Could be any class but they chose this!
+ rm "${S}/test/java/com/fasterxml/jackson/databind/deser/TestNoClassDefFoundDeserializer.java" || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc ../README.md ../release-notes/{CREDITS,VERSION}
+}
+
+src_test() {
+ cd test/java || die
+
+ local CP=".:../resources:${S}/${PN}.jar:$(java-pkg_getjars --with-dependencies cglib-2.2,groovy,junit-4,${JAVA_GENTOO_CLASSPATH})"
+ local TESTS=$(find * -name "Test*.java")
+ TESTS="${TESTS//.java}"
+ TESTS="${TESTS//\//.}"
+
+ ejavac -cp "${CP}" -d . $(find * -name "*.java")
+ ejunit4 -classpath "${CP}" ${TESTS}
+}