summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2015-03-04 23:20:10 +0000
committerJames Le Cuirot <chewi@gentoo.org>2015-03-04 23:20:10 +0000
commit7369529aef7a41f32f322f3a75920f34b41c19b7 (patch)
tree75aba959d4022228bf2404c39a429e8dec79c006 /dev-java
parentVersion bump. (diff)
downloadgentoo-2-7369529aef7a41f32f322f3a75920f34b41c19b7.tar.gz
gentoo-2-7369529aef7a41f32f322f3a75920f34b41c19b7.tar.bz2
gentoo-2-7369529aef7a41f32f322f3a75920f34b41c19b7.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 9C6D7DE4)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jackson-annotations/ChangeLog11
-rw-r--r--dev-java/jackson-annotations/files/2.3.0-build.xml100
-rw-r--r--dev-java/jackson-annotations/jackson-annotations-2.3.0.ebuild34
-rw-r--r--dev-java/jackson-annotations/jackson-annotations-2.5.1.ebuild29
4 files changed, 38 insertions, 136 deletions
diff --git a/dev-java/jackson-annotations/ChangeLog b/dev-java/jackson-annotations/ChangeLog
index f3924e29f8ba..a7f16c35e0d4 100644
--- a/dev-java/jackson-annotations/ChangeLog
+++ b/dev-java/jackson-annotations/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/jackson-annotations
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jackson-annotations/ChangeLog,v 1.1 2014/01/12 18:26:21 ercpe Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jackson-annotations/ChangeLog,v 1.2 2015/03/04 23:20:10 chewi Exp $
+
+*jackson-annotations-2.5.1 (04 Mar 2015)
+
+ 04 Mar 2015; James Le Cuirot <chewi@gentoo.org>
+ +jackson-annotations-2.5.1.ebuild, -files/2.3.0-build.xml,
+ -jackson-annotations-2.3.0.ebuild:
+ Version bump.
*jackson-annotations-2.3.0 (12 Jan 2014)
diff --git a/dev-java/jackson-annotations/files/2.3.0-build.xml b/dev-java/jackson-annotations/files/2.3.0-build.xml
deleted file mode 100644
index ce8ae1e304ec..000000000000
--- a/dev-java/jackson-annotations/files/2.3.0-build.xml
+++ /dev/null
@@ -1,100 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<project name="jackson-annotations" default="jar" basedir=".">
- <property file="${user.home}/.m2/maven.properties" />
- <property file="maven-build.properties" />
-
- <property name="maven.build.finalName" value="${ant.project.name}" />
- <property name="maven.build.dir" value="target" />
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes" />
- <property name="maven.build.srcDir.0" value="src/main/java" />
- <property name="maven.build.resourceDir.0" value="src/main/resources" />
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes" />
- <property name="maven.build.testDir.0" value="src/test/java" />
- <property name="maven.build.testResourceDir.0" value="src/test/resources" />
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports" />
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site" />
-
- <property name="maven.repo.local" value="${user.home}/.m2/repository" />
- <property name="maven.settings.offline" value="false" />
- <property name="maven.settings.interactiveMode" value="true" />
-
- <path id="build.classpath" />
- <path id="build.test.classpath">
- </path>
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}" />
- </target>
-
- <target name="compile" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}" />
- <javac destdir="${maven.build.outputDir}" nowarn="true" debug="true" optimize="true" deprecation="true" target="1.6" verbose="false" fork="false" source="1.6">
- <src>
- <pathelement location="${maven.build.srcDir.0}" />
- </src>
- <classpath refid="build.classpath" />
- </javac>
- <copy todir="${maven.build.outputDir}">
- <fileset dir="${maven.build.resourceDir.0}" />
- </copy>
- </target>
-
- <target name="compile-tests" depends="compile" description="Compile the test code" unless="maven.test.skip">
- <mkdir dir="${maven.build.testOutputDir}" />
- <javac destdir="${maven.build.testOutputDir}" nowarn="true" debug="true" optimize="true" deprecation="true" target="1.6" verbose="false" fork="false" source="1.6">
- <src>
- <pathelement location="${maven.build.testDir.0}" />
- </src>
- <classpath>
- <path refid="build.test.classpath" />
- <pathelement location="${maven.build.outputDir}" />
- </classpath>
- </javac>
- <copy todir="${maven.build.testOutputDir}">
- <fileset dir="${maven.build.testResourceDir.0}" />
- </copy>
- </target>
-
- <target name="test" depends="compile-tests" description="Run the test cases">
- <mkdir dir="${maven.test.reports}" />
- <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
- <sysproperty key="basedir" value="." />
- <formatter type="xml" />
- <formatter type="plain" usefile="false" />
- <classpath>
- <path refid="build.test.classpath" />
- <pathelement location="${maven.build.outputDir}" />
- <pathelement location="${maven.build.testOutputDir}" />
- </classpath>
- <batchtest todir="${maven.test.reports}" unless="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/Test*.java" />
- <include name="**/*Test.java" />
- <include name="**/*TestCase.java" />
- <exclude name="**/*Abstract*Test.java" />
- <exclude name="**/BaseTest.java" />
- <exclude name="**/ConcurrencyReadTest.java" />
- </fileset>
- </batchtest>
- <batchtest todir="${maven.test.reports}" if="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/${test}.java" />
- <exclude name="**/*Abstract*Test.java" />
- <exclude name="**/BaseTest.java" />
- <exclude name="**/ConcurrencyReadTest.java" />
- </fileset>
- </batchtest>
- </junit>
- </target>
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}" packagenames="*" destdir="${maven.reporting.outputDirectory}/apidocs" access="protected" old="false" verbose="false" encoding="UTF-8" version="true" use="true" author="true" splitindex="false" nodeprecated="false" nodeprecatedlist="false" notree="false" noindex="false" nohelp="false" nonavbar="false" serialwarn="false" charset="ISO-8859-1" source="1.6" linksource="false" breakiterator="false" maxmemory="1g">
- </javadoc>
- </target>
-
- <target name="jar" depends="compile" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar" compress="true" index="false" basedir="${maven.build.outputDir}" excludes="**/package.html" />
- </target>
-
-</project>
diff --git a/dev-java/jackson-annotations/jackson-annotations-2.3.0.ebuild b/dev-java/jackson-annotations/jackson-annotations-2.3.0.ebuild
deleted file mode 100644
index ec81446545ca..000000000000
--- a/dev-java/jackson-annotations/jackson-annotations-2.3.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jackson-annotations/jackson-annotations-2.3.0.ebuild,v 1.1 2014/01/12 18:26:21 ercpe Exp $
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="High-performance JSON processor"
-HOMEPAGE="http://jackson.codehaus.org"
-SRC_URI="https://github.com/FasterXML/${PN}/archive/${PN}-${PV}.tar.gz"
-
-LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
-SLOT="2"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=virtual/jre-1.5"
-DEPEND=">=virtual/jdk-1.5"
-
-S="${WORKDIR}/${PN}-${PN}-${PV}"
-
-java_prepare() {
- cp "${FILESDIR}"/${PV}-build.xml "${S}"/build.xml || die
-}
-
-src_install() {
- java-pkg_dojar target/${PN}.jar
-
- use doc && java-pkg_dojavadoc target/site/apidocs/
- use source && java-pkg_dosrc src/main/java/*
-}
diff --git a/dev-java/jackson-annotations/jackson-annotations-2.5.1.ebuild b/dev-java/jackson-annotations/jackson-annotations-2.5.1.ebuild
new file mode 100644
index 000000000000..976e45bfe456
--- /dev/null
+++ b/dev-java/jackson-annotations/jackson-annotations-2.5.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jackson-annotations/jackson-annotations-2.5.1.ebuild,v 1.1 2015/03/04 23:20:10 chewi Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="High-performance JSON processor"
+HOMEPAGE="https://github.com/FasterXML/jackson-annotations"
+SRC_URI="https://github.com/FasterXML/${PN}/archive/${PN}-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5"
+
+S="${WORKDIR}/${PN}-${P}/src"
+JAVA_SRC_DIR="main/java"
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc ../README.md ../release-notes/VERSION
+}