summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2008-07-14 21:59:47 +0000
committerVlastimil Babka <caster@gentoo.org>2008-07-14 21:59:47 +0000
commit0788af8cb0117c13a858b0c10b38911e3034fffc (patch)
treecad931e54b5161acfaf4aa34134149d3600c5b00 /dev-java/ant-junit4
parentVersion bump, bug #231776. (diff)
downloadgentoo-2-0788af8cb0117c13a858b0c10b38911e3034fffc.tar.gz
gentoo-2-0788af8cb0117c13a858b0c10b38911e3034fffc.tar.bz2
gentoo-2-0788af8cb0117c13a858b0c10b38911e3034fffc.zip
Version bump, bug #231776.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r4 x86_64)
Diffstat (limited to 'dev-java/ant-junit4')
-rw-r--r--dev-java/ant-junit4/ChangeLog7
-rw-r--r--dev-java/ant-junit4/ant-junit4-1.7.1.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-java/ant-junit4/ChangeLog b/dev-java/ant-junit4/ChangeLog
index 4e46b0a5db65..ec6323c2e60f 100644
--- a/dev-java/ant-junit4/ChangeLog
+++ b/dev-java/ant-junit4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/ant-junit4
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-junit4/ChangeLog,v 1.3 2008/03/08 11:33:52 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-junit4/ChangeLog,v 1.4 2008/07/14 21:59:47 caster Exp $
+
+*ant-junit4-1.7.1 (14 Jul 2008)
+
+ 14 Jul 2008; Vlastimil Babka <caster@gentoo.org> +ant-junit4-1.7.1.ebuild:
+ Version bump, bug #231776.
08 Mar 2008; Krzysiek Pawlik <nelchael@gentoo.org>
ant-junit4-1.7.0.ebuild:
diff --git a/dev-java/ant-junit4/ant-junit4-1.7.1.ebuild b/dev-java/ant-junit4/ant-junit4-1.7.1.ebuild
new file mode 100644
index 000000000000..d17e11f78c31
--- /dev/null
+++ b/dev-java/ant-junit4/ant-junit4-1.7.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-junit4/ant-junit4-1.7.1.ebuild,v 1.1 2008/07/14 21:59:47 caster Exp $
+
+EAPI=1
+
+ANT_TASK_JDKVER=1.5
+ANT_TASK_JREVER=1.5
+ANT_TASK_DEPNAME="junit-4"
+
+inherit ant-tasks
+
+DESCRIPTION="A copy of ant-junit package which uses junit-4 to run <junit> tasks."
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# xalan is a runtime dependency of the XalanExecutor task
+# which was for some reason moved to ant-junit by upstream
+DEPEND="dev-java/junit:4"
+RDEPEND="${DEPEND}
+ dev-java/xalan:0"
+
+src_compile() {
+ eant jar-junit
+}
+
+src_install() {
+ # no registration as ant-task, would be loaded together with ant-junit
+ java-pkg_newjar build/lib/ant-junit.jar
+ java-pkg_register-dependency xalan
+}