summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-07-02 03:59:05 +0000
committerMark Wright <gienah@gentoo.org>2014-07-02 03:59:05 +0000
commitf175393a0efea41d6ab4436f9ed66fcd92076826 (patch)
treec46d511ce7d0ca5fc2f5e7cabfb73ca386a8532f /dev-haskell/chell
parentBump boxes to 0.1.3 (diff)
downloadgentoo-2-f175393a0efea41d6ab4436f9ed66fcd92076826.tar.gz
gentoo-2-f175393a0efea41d6ab4436f9ed66fcd92076826.tar.bz2
gentoo-2-f175393a0efea41d6ab4436f9ed66fcd92076826.zip
Bump chell to 0.4
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/chell')
-rw-r--r--dev-haskell/chell/ChangeLog8
-rw-r--r--dev-haskell/chell/Manifest3
-rw-r--r--dev-haskell/chell/chell-0.4.ebuild36
-rw-r--r--dev-haskell/chell/metadata.xml48
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-haskell/chell/ChangeLog b/dev-haskell/chell/ChangeLog
new file mode 100644
index 000000000000..260d2d73f30e
--- /dev/null
+++ b/dev-haskell/chell/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-haskell/chell
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/chell/ChangeLog,v 1.1 2014/07/02 03:59:05 gienah Exp $
+
+*chell-0.4 (02 Jul 2014)
+
+ 02 Jul 2014; Mark Wright <gienah@gentoo.org> +chell-0.4.ebuild, +metadata.xml:
+ Bump chell to 0.4
diff --git a/dev-haskell/chell/Manifest b/dev-haskell/chell/Manifest
new file mode 100644
index 000000000000..acad7b233b29
--- /dev/null
+++ b/dev-haskell/chell/Manifest
@@ -0,0 +1,3 @@
+DIST chell-0.4.tar.gz 12437 SHA256 cf824e5ada55b18aa1e3fca93996fb04521cafcb7db0fccd1fec757eecc9d6c3 SHA512 8acbab62b84566ca03f44465de6911d72b3fae16292ff3f666bd6614c2e6c7bf9a2be04ca4a6b3d53802f29d23569034908371244a015b4159fea173b24f602c WHIRLPOOL 6771ad4bf27f5ce6852e74d3fe54b23048cc7d6594b94c29e7a725b63dd8beaee0b661840d389e59bf994e579bd442783123feabd28cee6d937a0fa0961f632f
+EBUILD chell-0.4.ebuild 1063 SHA256 e2107ac68bb1fae989ae3baea3094d19318a8fe3624294b67045fab3c2d1aed8 SHA512 9bfc9234f2bac06cc4c8e0fd7e11fd7470e86a4ea57a5da3f1584067cda5645f1829979b1bb0afbab174791ec9877be49b771e356edf09fa27276f23bf57b3ec WHIRLPOOL 4ebbd0c5f59f3461357beb4d3d04a83f23eec2e9a664a508a1e54fb39f683c2dcb22cab93f357f32b58a96f1b4c943d0b807239feb7d4028cadeb14f76ef2c2d
+MISC metadata.xml 1355 SHA256 11887b9036c4ecb7e0a955a3188d9deb24ba479713194cec686904bb33071b7e SHA512 fc0d3d6d8d7580723379e683a86ad37a48144cb5a06b5768772f2eea42f9c1a1804c431a7a78ebf7afaac6c8f925fe33960dff6c285209d3bf3a8e364d9cb2ad WHIRLPOOL 42612889418a574bf07d5bd01534311a6b796ce2393fdb36ffcce2aaec075caee2ef3a990d20036e6bc0d83bf29507e89a13a4744e7489fc237f38eea81155f6
diff --git a/dev-haskell/chell/chell-0.4.ebuild b/dev-haskell/chell/chell-0.4.ebuild
new file mode 100644
index 000000000000..691a1c64a032
--- /dev/null
+++ b/dev-haskell/chell/chell-0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/chell/chell-0.4.ebuild,v 1.1 2014/07/02 03:59:05 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A simple and intuitive library for automated testing."
+HOMEPAGE="https://john-millikin.com/software/chell/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+color-output"
+
+RDEPEND=">=dev-haskell/options-1.0:=[profile?] <dev-haskell/options-2.0:=[profile?]
+ >=dev-haskell/patience-0.1:=[profile?] <dev-haskell/patience-0.2:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ color-output? ( >=dev-haskell/ansi-terminal-0.5:=[profile?] <dev-haskell/ansi-terminal-0.7:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag color-output color-output)
+}
diff --git a/dev-haskell/chell/metadata.xml b/dev-haskell/chell/metadata.xml
new file mode 100644
index 000000000000..80f79b76a231
--- /dev/null
+++ b/dev-haskell/chell/metadata.xml
@@ -0,0 +1,48 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Chell is a simple and intuitive library for automated testing. It natively
+ supports assertion-based testing, and can use companion libraries
+ such as @chell-quickcheck@ to support more complex testing strategies.
+
+ An example test suite, which verifies the behavior of artithmetic operators.
+
+ @
+ &amp;#x7b;-\# LANGUAGE TemplateHaskell \#-&amp;#x7d;
+
+ import Test.Chell
+
+ tests_Math :: Suite
+ tests_Math = suite \&quot;math\&quot;
+ &amp;#x20; test_Addition
+ &amp;#x20; test_Subtraction
+
+ test_Addition :: Test
+ test_Addition = assertions \&quot;addition\&quot; $ do
+ &amp;#x20; $expect (equal (2 + 1) 3)
+ &amp;#x20; $expect (equal (1 + 2) 3)
+
+ test_Subtraction :: Test
+ test_Subtraction = assertions \&quot;subtraction\&quot; $ do
+ &amp;#x20; $expect (equal (2 - 1) 1)
+ &amp;#x20; $expect (equal (1 - 2) (-1))
+
+ main :: IO ()
+ main = defaultMain [tests_Math]
+ @
+
+ @
+ $ ghc --make chell-example.hs
+ $ ./chell-example
+ PASS: 2 tests run, 2 tests passed
+ @
+ </longdescription>
+ <use>
+ <flag name="color-output">use colors in program output</flag>
+ </use>
+</pkgmetadata>