summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-03-09 06:28:22 +0000
committerMark Wright <gienah@gentoo.org>2014-03-09 06:28:22 +0000
commit9198e93a94d404ffbd6743e2db3b1426619814b7 (patch)
tree69b4131c304753c4a14177c844a3bbe2691b8f19 /dev-haskell/aeson
parentBump aeson-pretty to 0.7.1 (diff)
downloadgentoo-2-9198e93a94d404ffbd6743e2db3b1426619814b7.tar.gz
gentoo-2-9198e93a94d404ffbd6743e2db3b1426619814b7.tar.bz2
gentoo-2-9198e93a94d404ffbd6743e2db3b1426619814b7.zip
Bump aeson to 0.7.0.2
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/aeson')
-rw-r--r--dev-haskell/aeson/ChangeLog9
-rw-r--r--dev-haskell/aeson/aeson-0.7.0.2.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-haskell/aeson/ChangeLog b/dev-haskell/aeson/ChangeLog
index dc76b8bd4e24..4deb9dbce5b9 100644
--- a/dev-haskell/aeson/ChangeLog
+++ b/dev-haskell/aeson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/aeson
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/aeson/ChangeLog,v 1.7 2013/11/24 19:32:30 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/aeson/ChangeLog,v 1.8 2014/03/09 06:28:22 gienah Exp $
+
+*aeson-0.7.0.2 (09 Mar 2014)
+
+ 09 Mar 2014; Mark Wright <gienah@gentoo.org> +aeson-0.7.0.2.ebuild:
+ Bump aeson to 0.7.0.2
24 Nov 2013; Agostino Sarubbo <ago@gentoo.org> aeson-0.6.2.1.ebuild:
Stable for x86, wrt bug #488750
diff --git a/dev-haskell/aeson/aeson-0.7.0.2.ebuild b/dev-haskell/aeson/aeson-0.7.0.2.ebuild
new file mode 100644
index 000000000000..553efe4ccd3b
--- /dev/null
+++ b/dev-haskell/aeson/aeson-0.7.0.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/aeson/aeson-0.7.0.2.ebuild,v 1.1 2014/03/09 06:28:22 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast JSON parsing and encoding"
+HOMEPAGE="https://github.com/bos/aeson"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="developer"
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.2.1:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?]
+ >=dev-haskell/dlist-0.2:=[profile?]
+ >=dev-haskell/hashable-1.1.2.0:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/scientific-0.2:=[profile?]
+ dev-haskell/syb:=[profile?]
+ >=dev-haskell/text-0.11.1.0:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.3.0:=[profile?]
+ >=dev-haskell/vector-0.7.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag developer developer)
+}