summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-12-03 01:41:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-12-03 01:41:58 +0000
commitd7353c28693a7adb59ecb29993dbb28fc14799fd (patch)
tree8c9b850d6aedaf73b588eac3759162ca0a7e8988 /dev-games
parentversion bump (diff)
downloadgentoo-2-d7353c28693a7adb59ecb29993dbb28fc14799fd.tar.gz
gentoo-2-d7353c28693a7adb59ecb29993dbb28fc14799fd.tar.bz2
gentoo-2-d7353c28693a7adb59ecb29993dbb28fc14799fd.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/ogre/ChangeLog8
-rw-r--r--dev-games/ogre/files/ogre-1.6.4-boost.patch10
-rw-r--r--dev-games/ogre/ogre-1.6.4.ebuild81
3 files changed, 98 insertions, 1 deletions
diff --git a/dev-games/ogre/ChangeLog b/dev-games/ogre/ChangeLog
index ebbc4fc812dd..2d7de586316b 100644
--- a/dev-games/ogre/ChangeLog
+++ b/dev-games/ogre/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/ogre
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ChangeLog,v 1.59 2009/11/18 14:15:44 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ChangeLog,v 1.60 2009/12/03 01:41:58 mr_bones_ Exp $
+
+*ogre-1.6.4 (03 Dec 2009)
+
+ 03 Dec 2009; Michael Sterrett <mr_bones_@gentoo.org> +ogre-1.6.4.ebuild,
+ +files/ogre-1.6.4-boost.patch:
+ version bump
18 Nov 2009; Alfredo Tupone <tupone@gentoo.org> ogre-1.6.3.ebuild,
+files/ogre-1.6.3-boost.patch:
diff --git a/dev-games/ogre/files/ogre-1.6.4-boost.patch b/dev-games/ogre/files/ogre-1.6.4-boost.patch
new file mode 100644
index 000000000000..9f1784c558cd
--- /dev/null
+++ b/dev-games/ogre/files/ogre-1.6.4-boost.patch
@@ -0,0 +1,10 @@
+--- OgreMain/include/OgreStdHeaders.h.old 2009-11-18 14:08:48.000000000 +0100
++++ OgreMain/include/OgreStdHeaders.h 2009-11-18 14:09:59.000000000 +0100
+@@ -110,6 +110,7 @@
+ # include <boost/thread/recursive_mutex.hpp>
+ # include <boost/thread/condition.hpp>
+ # include <boost/thread/thread.hpp>
++# include <boost/function.hpp>
+ #endif
+
+ #if defined ( OGRE_GCC_VISIBILITY )
diff --git a/dev-games/ogre/ogre-1.6.4.ebuild b/dev-games/ogre/ogre-1.6.4.ebuild
new file mode 100644
index 000000000000..cb6c281c8439
--- /dev/null
+++ b/dev-games/ogre/ogre-1.6.4.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ogre-1.6.4.ebuild,v 1.1 2009/12/03 01:41:58 mr_bones_ Exp $
+
+EAPI=2
+inherit multilib eutils autotools flag-o-matic
+
+DESCRIPTION="Object-oriented Graphics Rendering Engine"
+HOMEPAGE="http://www.ogre3d.org/"
+SRC_URI="mirror://sourceforge/ogre/ogre-v${PV//./-}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc cg devil double-precision examples gtk threads"
+RESTRICT="test" #139905
+
+RDEPEND="dev-libs/zziplib
+ media-libs/freetype:2
+ virtual/opengl
+ virtual/glu
+ x11-libs/libXt
+ x11-libs/libXaw
+ x11-libs/libXrandr
+ x11-libs/libX11
+ cg? ( media-gfx/nvidia-cg-toolkit )
+ devil? ( media-libs/devil )
+ gtk? ( x11-libs/gtk+:2 )
+ threads? ( || ( >=dev-libs/boost-1.34.1 dev-libs/boost[threads] ) )"
+DEPEND="${RDEPEND}
+ x11-proto/xf86vidmodeproto
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ ecvs_clean
+ if use examples ; then
+ cp -r Samples install-examples || die
+ find install-examples \
+ '(' -name .keepme -o -name '*.cbp' -o -name '*.vcproj*' ')' \
+ -print0 | xargs -0 rm -rf
+ find install-examples -type d -print0 | xargs -0 rmdir 2> /dev/null
+ sed -i \
+ -e "s:/usr/local/lib/OGRE:/usr/$(get_libdir)/OGRE:" \
+ $(grep -rl /usr/local/lib/OGRE install-examples) \
+ || die "sed failed"
+ fi
+ sed -i -e '/CPPUNIT/d' configure.in || die "sed failed"
+ epatch "${FILESDIR}"/${P}-boost.patch
+ eautoreconf
+}
+
+src_configure() {
+ strip-flags
+ econf \
+ --disable-dependency-tracking \
+ --disable-freeimage \
+ --disable-openexr \
+ --disable-ogre-demos \
+ --enable-static \
+ --with-platform=GLX \
+ --with-gui=$(usev gtk || echo Xt) \
+ $(use_enable cg) \
+ $(use_enable devil) \
+ $(use_enable double-precision double) \
+ $(use_enable threads threading)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/html
+ doins -r Docs/* || die "doins Docs failed"
+ fi
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/Samples
+ doins -r install-examples/* || die "doins Samples failed"
+ fi
+ dodoc AUTHORS BUGS LINUX.DEV README
+}