summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2007-11-17 18:50:16 +0000
committerIlya Volynets <iluxa@gentoo.org>2007-11-17 18:50:16 +0000
commitdffe86da1ae8eb5ebf8aa4dd3b1ff0fef4d5693d (patch)
tree827a5f205b4c9a763d5b64a7043bbaef12d4cacb /dev-cpp
parentStable on ppc wrt bug 199332 (diff)
downloadgentoo-2-dffe86da1ae8eb5ebf8aa4dd3b1ff0fef4d5693d.tar.gz
gentoo-2-dffe86da1ae8eb5ebf8aa4dd3b1ff0fef4d5693d.tar.bz2
gentoo-2-dffe86da1ae8eb5ebf8aa4dd3b1ff0fef4d5693d.zip
build SPTK as shared libraries
(Portage version: 2.1.3.16)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/sptk/ChangeLog5
-rw-r--r--dev-cpp/sptk/sptk-3.5.6.ebuild4
2 files changed, 7 insertions, 2 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index c71b94715955..14affd56f62b 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-cpp/sptk
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.25 2007/11/17 15:20:50 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.26 2007/11/17 18:50:16 iluxa Exp $
+
+ 17 Nov 2007; <ilya@gentoo.org> sptk-3.5.6.ebuild:
+ Build SPTK as shared libraries
*sptk-3.5.6 (17 Nov 2007)
diff --git a/dev-cpp/sptk/sptk-3.5.6.ebuild b/dev-cpp/sptk/sptk-3.5.6.ebuild
index 594f1ac8f4e3..d637d49048a9 100644
--- a/dev-cpp/sptk/sptk-3.5.6.ebuild
+++ b/dev-cpp/sptk/sptk-3.5.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 2006-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.6.ebuild,v 1.1 2007/11/17 15:20:50 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.6.ebuild,v 1.2 2007/11/17 18:50:16 iluxa Exp $
inherit eutils flag-o-matic autotools
@@ -42,6 +42,8 @@ src_unpack() {
check_use fltk FLTK
check_use excel EXCEL
+ sed -r -i -e 's|SET \(LIBRARY_TYPE STATIC\)|SET \(LIBRARY_TYPE SHARED\)|' src/CMakeLists.txt
+
cmake -D CMAKE_INSTALL_PREFIX:PATH=/usr ${SPTK_OPTIONS} . || die "Configuration Failed"
}