summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-09-13 15:53:20 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-09-13 15:53:20 +0000
commit28b61f25b62e898b119288df2996cd5d6623d5c7 (patch)
treef56a3a5be41e80805d8e2bddce45c6064039fee5 /dev-cpp/libcmis
parentPunt older keep only latest stable. (diff)
downloadgentoo-2-28b61f25b62e898b119288df2996cd5d6623d5c7.tar.gz
gentoo-2-28b61f25b62e898b119288df2996cd5d6623d5c7.tar.bz2
gentoo-2-28b61f25b62e898b119288df2996cd5d6623d5c7.zip
Slot cmis as 0.3 is not compatible with 3.6 again. Revbumps are needed for proper blockers. 0.1 and 0.2 sadly use same 0.2 soname, stupid.
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-cpp/libcmis')
-rw-r--r--dev-cpp/libcmis/ChangeLog12
-rw-r--r--dev-cpp/libcmis/libcmis-0.1.0-r1.ebuild (renamed from dev-cpp/libcmis/libcmis-0.1.0.ebuild)15
-rw-r--r--dev-cpp/libcmis/libcmis-0.2.3-r1.ebuild (renamed from dev-cpp/libcmis/libcmis-0.2.3.ebuild)15
-rw-r--r--dev-cpp/libcmis/libcmis-0.3.0.ebuild60
-rw-r--r--dev-cpp/libcmis/libcmis-9999.ebuild25
5 files changed, 114 insertions, 13 deletions
diff --git a/dev-cpp/libcmis/ChangeLog b/dev-cpp/libcmis/ChangeLog
index 92ae331caaee..e2a420b26526 100644
--- a/dev-cpp/libcmis/ChangeLog
+++ b/dev-cpp/libcmis/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-cpp/libcmis
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/ChangeLog,v 1.13 2012/08/09 08:27:31 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/ChangeLog,v 1.14 2012/09/13 15:53:20 scarabeus Exp $
+
+*libcmis-0.2.3-r1 (13 Sep 2012)
+*libcmis-0.3.0 (13 Sep 2012)
+*libcmis-0.1.0-r1 (13 Sep 2012)
+
+ 13 Sep 2012; Tomáš Chvátal <scarabeus@gentoo.org> +libcmis-0.1.0-r1.ebuild,
+ +libcmis-0.2.3-r1.ebuild, +libcmis-0.3.0.ebuild, -libcmis-0.1.0.ebuild,
+ -libcmis-0.2.3.ebuild, libcmis-9999.ebuild:
+ Slot cmis as 0.3 is not compatible with 3.6 again. Revbumps are needed for
+ proper blockers. 0.1 and 0.2 sadly use same 0.2 soname, stupid.
09 Aug 2012; Tomáš Chvátal <scarabeus@gentoo.org>
+files/libcmis-0.2.3-do-not-override-phases.patch, libcmis-0.2.3.ebuild:
diff --git a/dev-cpp/libcmis/libcmis-0.1.0.ebuild b/dev-cpp/libcmis/libcmis-0.1.0-r1.ebuild
index 2622a8d75da2..e1c400cf65ac 100644
--- a/dev-cpp/libcmis/libcmis-0.1.0.ebuild
+++ b/dev-cpp/libcmis/libcmis-0.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/libcmis-0.1.0.ebuild,v 1.9 2012/08/02 18:22:52 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/libcmis-0.1.0-r1.ebuild,v 1.1 2012/09/13 15:53:20 scarabeus Exp $
EAPI=4
@@ -14,11 +14,12 @@ HOMEPAGE="https://sourceforge.net/projects/libcmis/"
[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
-SLOT="0"
+SLOT="0.2"
[[ ${PV} == 9999 ]] || KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
IUSE="static-libs test"
RDEPEND="
+ !dev-cpp/libcmis:0
dev-libs/boost
dev-libs/libxml2
<net-misc/curl-7.27.0
@@ -37,6 +38,8 @@ src_prepare() {
src_configure() {
econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --program-suffix=-${SLOT} \
--disable-werror \
$(use_enable static-libs static) \
$(use_enable test tests) \
@@ -47,3 +50,11 @@ src_install() {
default
find "${ED}" -name '*.la' -exec rm -f {} +
}
+
+pkg_postinst() {
+ alternatives_auto_makesym /usr/bin/cmis-client "/usr/bin/cmis-client-[0-9].[0-9]"
+}
+
+pkg_postrm() {
+ alternatives_auto_makesym /usr/bin/cmis-client "/usr/bin/cmis-client-[0-9].[0-9]"
+}
diff --git a/dev-cpp/libcmis/libcmis-0.2.3.ebuild b/dev-cpp/libcmis/libcmis-0.2.3-r1.ebuild
index a5d7ff51a27e..1b2a40b565a8 100644
--- a/dev-cpp/libcmis/libcmis-0.2.3.ebuild
+++ b/dev-cpp/libcmis/libcmis-0.2.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/libcmis-0.2.3.ebuild,v 1.3 2012/08/09 08:27:31 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/libcmis-0.2.3-r1.ebuild,v 1.1 2012/09/13 15:53:20 scarabeus Exp $
EAPI=4
@@ -14,11 +14,12 @@ HOMEPAGE="https://sourceforge.net/projects/libcmis/"
[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
-SLOT="0"
+SLOT="0.2"
[[ ${PV} == 9999 ]] || KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="static-libs man test"
RDEPEND="
+ !dev-cpp/libcmis:0
dev-libs/boost
dev-libs/libxml2
net-misc/curl
@@ -39,6 +40,8 @@ src_prepare() {
src_configure() {
econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --program-suffix=-${SLOT} \
--disable-werror \
$(use_with man) \
$(use_enable static-libs static) \
@@ -50,3 +53,11 @@ src_install() {
default
find "${ED}" -name '*.la' -exec rm -f {} +
}
+
+pkg_postinst() {
+ alternatives_auto_makesym /usr/bin/cmis-client "/usr/bin/cmis-client-[0-9].[0-9]"
+}
+
+pkg_postrm() {
+ alternatives_auto_makesym /usr/bin/cmis-client "/usr/bin/cmis-client-[0-9].[0-9]"
+}
diff --git a/dev-cpp/libcmis/libcmis-0.3.0.ebuild b/dev-cpp/libcmis/libcmis-0.3.0.ebuild
new file mode 100644
index 000000000000..6d7b0aa0d5c7
--- /dev/null
+++ b/dev-cpp/libcmis/libcmis-0.3.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/libcmis-0.3.0.ebuild,v 1.1 2012/09/13 15:53:20 scarabeus Exp $
+
+EAPI=4
+
+EGIT_REPO_URI="git://gitorious.org/libcmis/libcmis.git"
+[[ ${PV} == 9999 ]] && SCM_ECLASS="git-2"
+inherit eutils alternatives autotools ${SCM_ECLASS}
+unset SCM_ECLASS
+
+DESCRIPTION="C++ client library for the CMIS interface"
+HOMEPAGE="https://sourceforge.net/projects/libcmis/"
+[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
+SLOT="0.3"
+[[ ${PV} == 9999 ]] || KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs man test"
+
+RDEPEND="
+ !dev-cpp/libcmis:0
+ dev-libs/boost
+ dev-libs/libxml2
+ net-misc/curl
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ man? ( app-text/docbook2X )
+ test? ( dev-util/cppunit )
+"
+
+src_prepare() {
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --program-suffix=-${SLOT} \
+ --disable-werror \
+ $(use_with man) \
+ $(use_enable static-libs static) \
+ $(use_enable test tests) \
+ --disable-long-tests \
+ --enable-client
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
+
+pkg_postinst() {
+ alternatives_auto_makesym /usr/bin/cmis-client "/usr/bin/cmis-client-[0-9].[0-9]"
+}
+
+pkg_postrm() {
+ alternatives_auto_makesym /usr/bin/cmis-client "/usr/bin/cmis-client-[0-9].[0-9]"
+}
diff --git a/dev-cpp/libcmis/libcmis-9999.ebuild b/dev-cpp/libcmis/libcmis-9999.ebuild
index 6ae491e7bad4..d5bd88196cab 100644
--- a/dev-cpp/libcmis/libcmis-9999.ebuild
+++ b/dev-cpp/libcmis/libcmis-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/libcmis-9999.ebuild,v 1.6 2012/06/21 15:31:11 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/libcmis-9999.ebuild,v 1.7 2012/09/13 15:53:20 scarabeus Exp $
EAPI=4
EGIT_REPO_URI="git://gitorious.org/libcmis/libcmis.git"
[[ ${PV} == 9999 ]] && SCM_ECLASS="git-2"
-inherit autotools ${SCM_ECLASS}
+inherit eutils alternatives autotools ${SCM_ECLASS}
unset SCM_ECLASS
DESCRIPTION="C++ client library for the CMIS interface"
@@ -14,11 +14,12 @@ HOMEPAGE="https://sourceforge.net/projects/libcmis/"
[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
-SLOT="0"
+SLOT="0.3"
[[ ${PV} == 9999 ]] || KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="static-libs man test"
RDEPEND="
+ !dev-cpp/libcmis:0
dev-libs/boost
dev-libs/libxml2
net-misc/curl
@@ -29,23 +30,31 @@ DEPEND="${RDEPEND}
test? ( dev-util/cppunit )
"
-# It fetches the apache chemistry webapp and then try to run some magic on it
-RESTRICT="test"
-
src_prepare() {
- eautoreconf
+ [[ ${PV} == 9999 ]] && eautoreconf
}
src_configure() {
econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --program-suffix=-${SLOT} \
--disable-werror \
$(use_with man) \
$(use_enable static-libs static) \
$(use_enable test tests) \
+ --disable-long-tests \
--enable-client
}
src_install() {
default
- find "${ED}" -name '*.la' -exec rm -f {} +
+ prune_libtool_files --all
+}
+
+pkg_postinst() {
+ alternatives_auto_makesym /usr/bin/cmis-client "/usr/bin/cmis-client-[0-9].[0-9]"
+}
+
+pkg_postrm() {
+ alternatives_auto_makesym /usr/bin/cmis-client "/usr/bin/cmis-client-[0-9].[0-9]"
}