summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-10-25 11:26:30 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-10-25 11:26:30 +0000
commitb9894d7c691fce42c2a9febda4b5504f4c4ed2c5 (patch)
tree345537604c480db4b19ca7cefa2d9d3b82f6244c /app-text/pdf2djvu
parentVersion bump to latest. Punt older. Add some more keywords tested by me. (diff)
downloadgentoo-2-b9894d7c691fce42c2a9febda4b5504f4c4ed2c5.tar.gz
gentoo-2-b9894d7c691fce42c2a9febda4b5504f4c4ed2c5.tar.bz2
gentoo-2-b9894d7c691fce42c2a9febda4b5504f4c4ed2c5.zip
Version bump and make test work correctly.
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'app-text/pdf2djvu')
-rw-r--r--app-text/pdf2djvu/ChangeLog9
-rw-r--r--app-text/pdf2djvu/pdf2djvu-0.7.13.ebuild44
-rw-r--r--app-text/pdf2djvu/pdf2djvu-0.7.15.ebuild (renamed from app-text/pdf2djvu/pdf2djvu-0.7.12.ebuild)33
3 files changed, 25 insertions, 61 deletions
diff --git a/app-text/pdf2djvu/ChangeLog b/app-text/pdf2djvu/ChangeLog
index 639e3125a69f..7a9050bd5213 100644
--- a/app-text/pdf2djvu/ChangeLog
+++ b/app-text/pdf2djvu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/pdf2djvu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2djvu/ChangeLog,v 1.14 2012/09/20 02:16:28 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2djvu/ChangeLog,v 1.15 2012/10/25 11:26:30 scarabeus Exp $
+
+*pdf2djvu-0.7.15 (25 Oct 2012)
+
+ 25 Oct 2012; Tomáš Chvátal <scarabeus@gentoo.org> +pdf2djvu-0.7.15.ebuild,
+ -pdf2djvu-0.7.12.ebuild, -pdf2djvu-0.7.13.ebuild:
+ Version bump and make test work correctly.
*pdf2djvu-0.7.14 (20 Sep 2012)
@@ -67,4 +73,3 @@
23 Jun 2010; Samuli Suominen <ssuominen@gentoo.org>
+pdf2djvu-0.7.4.ebuild:
Initial commit wrt #205675 by Dmitry S. Kulyabov.
-
diff --git a/app-text/pdf2djvu/pdf2djvu-0.7.13.ebuild b/app-text/pdf2djvu/pdf2djvu-0.7.13.ebuild
deleted file mode 100644
index 1d0bfebe9426..000000000000
--- a/app-text/pdf2djvu/pdf2djvu-0.7.13.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2djvu/pdf2djvu-0.7.13.ebuild,v 1.2 2012/08/08 16:23:01 dilfridge Exp $
-
-EAPI=4
-inherit toolchain-funcs
-
-DESCRIPTION="A tool to create DjVu files from PDF files"
-HOMEPAGE="http://code.google.com/p/pdf2djvu/"
-SRC_URI="http://pdf2djvu.googlecode.com/files/${PN}_${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+graphicsmagick nls openmp"
-
-RDEPEND=">=app-text/djvu-3.5.21
- >=app-text/poppler-0.16.7[xpdf-headers(+)]
- dev-libs/libxml2
- dev-libs/libxslt
- graphicsmagick? ( media-gfx/graphicsmagick )"
-DEPEND="${RDEPEND}
- dev-cpp/pstreams
- virtual/pkgconfig
- nls? ( sys-devel/gettext )"
-
-src_configure() {
- local openmp=disable
- use openmp && tc-has-openmp && openmp=enable
-
- econf \
- --${openmp}-openmp \
- $(use_enable nls) \
- $(use_with graphicsmagick)
-}
-
-src_test() {
- use graphicsmagick && emake test
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc doc/{changelog,{cjk,credits,djvudigital}.txt}
-}
diff --git a/app-text/pdf2djvu/pdf2djvu-0.7.12.ebuild b/app-text/pdf2djvu/pdf2djvu-0.7.15.ebuild
index 63a042ef06dc..efae9e4fda78 100644
--- a/app-text/pdf2djvu/pdf2djvu-0.7.12.ebuild
+++ b/app-text/pdf2djvu/pdf2djvu-0.7.15.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2djvu/pdf2djvu-0.7.12.ebuild,v 1.3 2012/08/08 16:23:01 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2djvu/pdf2djvu-0.7.15.ebuild,v 1.1 2012/10/25 11:26:30 scarabeus Exp $
+
+EAPI=5
-EAPI=4
inherit toolchain-funcs
DESCRIPTION="A tool to create DjVu files from PDF files"
@@ -12,33 +13,35 @@ SRC_URI="http://pdf2djvu.googlecode.com/files/${PN}_${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+graphicsmagick nls openmp"
+IUSE="+graphicsmagick nls openmp test"
-RDEPEND=">=app-text/djvu-3.5.21
- >=app-text/poppler-0.16.7[xpdf-headers(+)]
+RDEPEND="
+ >=app-text/djvu-3.5.21
+ >=app-text/poppler-0.16.7
dev-libs/libxml2
dev-libs/libxslt
- graphicsmagick? ( media-gfx/graphicsmagick )"
+ graphicsmagick? ( media-gfx/graphicsmagick )
+"
DEPEND="${RDEPEND}
dev-cpp/pstreams
virtual/pkgconfig
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext )
+ test? ( dev-python/nose )
+"
+
+REQUIRED_USE="test? ( graphicsmagick )"
src_configure() {
- local openmp=disable
- use openmp && tc-has-openmp && openmp=enable
+ local openmp=--disable-openmp
+ use openmp && tc-has-openmp && openmp=--enable-openmp
econf \
- --${openmp}-openmp \
+ ${openmp} \
$(use_enable nls) \
$(use_with graphicsmagick)
}
-src_test() {
- use graphicsmagick && emake test
-}
-
src_install() {
- emake DESTDIR="${D}" install
+ default
dodoc doc/{changelog,{cjk,credits,djvudigital}.txt}
}