summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-09-13 08:57:12 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-09-13 08:57:12 +0000
commit97d1a0ab2c42cdf14145da7a0f09a469042c3778 (patch)
tree7a9adf0312732fef4647e83b84b368340a4f4f1a /app-text/libetonyek
parentRestrict libabw, libebook, and libetonyek dependency. (diff)
downloadgentoo-2-97d1a0ab2c42cdf14145da7a0f09a469042c3778.tar.gz
gentoo-2-97d1a0ab2c42cdf14145da7a0f09a469042c3778.tar.bz2
gentoo-2-97d1a0ab2c42cdf14145da7a0f09a469042c3778.zip
Version bump. Thanks to Andreas Sturmlechner.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'app-text/libetonyek')
-rw-r--r--app-text/libetonyek/ChangeLog8
-rw-r--r--app-text/libetonyek/libetonyek-0.1.1.ebuild54
-rw-r--r--app-text/libetonyek/libetonyek-9999.ebuild10
3 files changed, 66 insertions, 6 deletions
diff --git a/app-text/libetonyek/ChangeLog b/app-text/libetonyek/ChangeLog
index ed79c59aef82..30f35cbcc676 100644
--- a/app-text/libetonyek/ChangeLog
+++ b/app-text/libetonyek/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/libetonyek
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libetonyek/ChangeLog,v 1.6 2014/06/29 16:43:31 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libetonyek/ChangeLog,v 1.7 2014/09/13 08:57:12 dilfridge Exp $
+
+*libetonyek-0.1.1 (13 Sep 2014)
+
+ 13 Sep 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ +libetonyek-0.1.1.ebuild, libetonyek-9999.ebuild:
+ Version bump. Thanks to Andreas Sturmlechner.
29 Jun 2014; Agostino Sarubbo <ago@gentoo.org> libetonyek-0.0.3.ebuild:
Stable for x86, wrt bug #514886
diff --git a/app-text/libetonyek/libetonyek-0.1.1.ebuild b/app-text/libetonyek/libetonyek-0.1.1.ebuild
new file mode 100644
index 000000000000..822880c6a28d
--- /dev/null
+++ b/app-text/libetonyek/libetonyek-0.1.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libetonyek/libetonyek-0.1.1.ebuild,v 1.1 2014/09/13 08:57:12 dilfridge Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libetonyek"
+inherit base eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-2
+
+DESCRIPTION="Library parsing Apple Keynote presentations"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libetonyek"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs test"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ dev-util/gperf
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+
+src_prepare() {
+ [[ -d m4 ]] || mkdir "m4"
+ base_src_prepare
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable static-libs static) \
+ --disable-werror \
+ $(use_enable test tests) \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/app-text/libetonyek/libetonyek-9999.ebuild b/app-text/libetonyek/libetonyek-9999.ebuild
index ae31c4bae8c2..c7c118ea555f 100644
--- a/app-text/libetonyek/libetonyek-9999.ebuild
+++ b/app-text/libetonyek/libetonyek-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libetonyek/libetonyek-9999.ebuild,v 1.3 2014/01/15 08:00:39 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libetonyek/libetonyek-9999.ebuild,v 1.4 2014/09/13 08:57:12 dilfridge Exp $
EAPI=5
@@ -9,18 +9,18 @@ inherit base eutils
[[ ${PV} == 9999 ]] && inherit autotools git-2
DESCRIPTION="Library parsing Apple Keynote presentations"
-HOMEPAGE="http://www.freedesktop.org/wiki/Software/libetonyek"
-[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.xz"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libetonyek"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
SLOT="0"
[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~ppc ~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="doc static-libs test"
RDEPEND="
- app-text/libwpd:0.9
dev-libs/boost:=
+ dev-libs/librevenge
dev-libs/libxml2
sys-libs/zlib
"