summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-11-30 12:59:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-11-30 12:59:06 +0000
commitc7a66e836d3a18fabd4650b6da5c3b0198680832 (patch)
treedad6ec47f2092cb6f8198017b8b6cf841372266d /app-text/htmlc
parentsupport for rust-lldb symlink (diff)
downloadgentoo-2-c7a66e836d3a18fabd4650b6da5c3b0198680832.tar.gz
gentoo-2-c7a66e836d3a18fabd4650b6da5c3b0198680832.tar.bz2
gentoo-2-c7a66e836d3a18fabd4650b6da5c3b0198680832.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'app-text/htmlc')
-rw-r--r--app-text/htmlc/ChangeLog9
-rw-r--r--app-text/htmlc/htmlc-2.60.0.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/app-text/htmlc/ChangeLog b/app-text/htmlc/ChangeLog
index 624ee1b1151e..83e0d2b3afa3 100644
--- a/app-text/htmlc/ChangeLog
+++ b/app-text/htmlc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/htmlc
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmlc/ChangeLog,v 1.7 2013/12/24 12:55:56 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmlc/ChangeLog,v 1.8 2014/11/30 12:59:06 aballier Exp $
+
+*htmlc-2.60.0 (30 Nov 2014)
+
+ 30 Nov 2014; Alexis Ballier <aballier@gentoo.org> +htmlc-2.60.0.ebuild:
+ version bump
24 Dec 2013; Agostino Sarubbo <ago@gentoo.org> htmlc-2.40.0.ebuild:
Stable for x86, wrt bug #491944
diff --git a/app-text/htmlc/htmlc-2.60.0.ebuild b/app-text/htmlc/htmlc-2.60.0.ebuild
new file mode 100644
index 000000000000..5c79bc0007f5
--- /dev/null
+++ b/app-text/htmlc/htmlc-2.60.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmlc/htmlc-2.60.0.ebuild,v 1.1 2014/11/30 12:59:06 aballier Exp $
+
+EAPI=5
+
+# Override version: 2.4.0 > 2.21.0 so we name it 2.40.0
+MY_P="${P/0[.]/.}"
+
+DESCRIPTION="HTML template files expander"
+HOMEPAGE="http://htmlc.inria.fr/"
+SRC_URI="http://htmlc.inria.fr/${MY_P%.0}.tgz"
+
+LICENSE="htmlc"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+ocamlopt"
+# Files for the tests are missing...
+#RESTRICT="test"
+
+DEPEND=">=dev-lang/ocaml-3.11.2:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ ./configure \
+ --install-root-dir "${ED}usr" \
+ || die
+}
+
+src_compile() {
+ if use ocamlopt ; then
+ emake bin
+ else
+ emake byt
+ fi
+}
+
+src_install() {
+ if use ocamlopt ; then
+ emake installbin
+ else
+ emake installbyt
+ fi
+ emake MANDIR='$(PREFIXINSTALLDIR)/share/man/man$(MANEXT)' installman
+ dodoc README Announce* CHANGES
+}