summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-04-29 22:53:16 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-04-29 22:53:16 +0000
commitaa0e62bad39b7a03ef018d29bcc4115670c07c00 (patch)
treefe131952787d4445030504b299510515e95b98e5 /app-text/gocr/gocr-0.47.ebuild
parentMarking libmodplug-0.7 ppc for bug 266913 (diff)
downloadgentoo-2-aa0e62bad39b7a03ef018d29bcc4115670c07c00.tar.gz
gentoo-2-aa0e62bad39b7a03ef018d29bcc4115670c07c00.tar.bz2
gentoo-2-aa0e62bad39b7a03ef018d29bcc4115670c07c00.zip
version bump, bug #187942
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'app-text/gocr/gocr-0.47.ebuild')
-rw-r--r--app-text/gocr/gocr-0.47.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-text/gocr/gocr-0.47.ebuild b/app-text/gocr/gocr-0.47.ebuild
new file mode 100644
index 000000000000..3659491771bc
--- /dev/null
+++ b/app-text/gocr/gocr-0.47.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/gocr-0.47.ebuild,v 1.1 2009/04/29 22:53:15 aballier Exp $
+
+inherit eutils
+
+DESCRIPTION="An OCR (Optical Character Recognition) reader"
+HOMEPAGE="http://jocr.sourceforge.net"
+SRC_URI="mirror://sourceforge/jocr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc tk"
+
+DEPEND=">=media-libs/netpbm-9.12
+ doc? ( >=media-gfx/transfig-3.2 virtual/ghostscript )
+ tk? ( dev-lang/tk )"
+
+DOCS="AUTHORS BUGS CREDITS HISTORY RE* TODO"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ local mymakes="src man"
+
+ use doc && mymakes="${mymakes} doc examples"
+
+ econf || die "econf failed"
+ emake ${mymakes} || die "make ${mymakes} failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="/usr" exec_prefix="/usr" install || die "make install failed"
+ # remove the tk frontend if tk is not selected
+ use tk || rm "${D}"/usr/bin/gocr.tcl
+ # and install the documentation and examples
+ if use doc ; then
+ DOCS="${DOCS} doc/gocr.html doc/examples.txt doc/unicode.txt"
+ insinto /usr/share/doc/${P}/examples
+ doins "${S}"/examples/*.{fig,tex,pcx}
+ fi
+ # and then install all the docs
+ dodoc ${DOCS}
+}