summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-30 00:08:01 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-30 00:08:01 +0000
commitf0e639151073fdb2ccfc164c1dd9d00eb0f7f296 (patch)
treedd8ddf943a701bf281e253a6ccca7b485b965376 /app-shells
parentalpha + ~ia64 keywords. (diff)
downloadgentoo-2-f0e639151073fdb2ccfc164c1dd9d00eb0f7f296.tar.gz
gentoo-2-f0e639151073fdb2ccfc164c1dd9d00eb0f7f296.tar.bz2
gentoo-2-f0e639151073fdb2ccfc164c1dd9d00eb0f7f296.zip
Move /etc/skel/.bash* files from baselayout to bash.
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog6
-rw-r--r--app-shells/bash/bash-3.0-r11.ebuild6
-rw-r--r--app-shells/bash/files/dot-bash_logout6
-rw-r--r--app-shells/bash/files/dot-bash_profile7
-rw-r--r--app-shells/bash/files/dot-bashrc40
5 files changed, 63 insertions, 2 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index a3adc8c820e3..4f3fe85285af 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.61 2005/04/29 22:21:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.62 2005/04/30 00:08:01 vapier Exp $
+
+ 30 Apr 2005; Mike Frysinger <vapier@gentoo.org> +files/dot-bash_logout,
+ +files/dot-bash_profile, +files/dot-bashrc, bash-3.0-r11.ebuild:
+ Move /etc/skel/.bash* files from baselayout to bash.
*bash-3.0-r11 (29 Apr 2005)
diff --git a/app-shells/bash/bash-3.0-r11.ebuild b/app-shells/bash/bash-3.0-r11.ebuild
index e59545296390..65629541fb3b 100644
--- a/app-shells/bash/bash-3.0-r11.ebuild
+++ b/app-shells/bash/bash-3.0-r11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r11.ebuild,v 1.1 2005/04/29 22:21:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r11.ebuild,v 1.2 2005/04/30 00:08:01 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -122,6 +122,10 @@ src_install() {
insinto /etc/bash
doins "${FILESDIR}"/{bashrc,bash_logout}
+ insinto /etc/skel
+ for f in bash{_logout,_profile,rc} ; do
+ newins "${FILESDIR}"/dot-${f} .${f}
+ done
if use build ; then
rm -rf "${D}"/usr
diff --git a/app-shells/bash/files/dot-bash_logout b/app-shells/bash/files/dot-bash_logout
new file mode 100644
index 000000000000..2eb908bfc336
--- /dev/null
+++ b/app-shells/bash/files/dot-bash_logout
@@ -0,0 +1,6 @@
+# /etc/skel/.bash_profile:
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/files/dot-bash_logout,v 1.1 2005/04/30 00:08:01 vapier Exp $
+
+# This file is sourced when a login shell terminates.
+# Clear the screen for security's sake.
+clear
diff --git a/app-shells/bash/files/dot-bash_profile b/app-shells/bash/files/dot-bash_profile
new file mode 100644
index 000000000000..8ae3154ccb21
--- /dev/null
+++ b/app-shells/bash/files/dot-bash_profile
@@ -0,0 +1,7 @@
+# /etc/skel/.bash_profile:
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/files/dot-bash_profile,v 1.1 2005/04/30 00:08:01 vapier Exp $
+
+# This file is sourced by bash for login shells. The following line
+# runs your .bashrc and is recommended by the bash info pages.
+[[ -f ~/.bashrc ]] && . ~/.bashrc
+
diff --git a/app-shells/bash/files/dot-bashrc b/app-shells/bash/files/dot-bashrc
new file mode 100644
index 000000000000..bf58f7519fc7
--- /dev/null
+++ b/app-shells/bash/files/dot-bashrc
@@ -0,0 +1,40 @@
+# /etc/skel/.bashrc:
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/files/dot-bashrc,v 1.1 2005/04/30 00:08:01 vapier Exp $
+#
+# This file is sourced by all *interactive* bash shells on startup,
+# including some apparently interactive shells such as scp and rcp
+# that can't tolerate any output.
+
+
+# Test for an interactive shell. There is no need to set anything
+# past this point for scp and rcp, and it's important to refrain from
+# outputting anything in those cases.
+if [[ $- != *i* ]]; then
+ # Shell is non-interactive. Be done now
+ return
+fi
+
+# Shell is interactive. It is okay to produce output at this point,
+# though this example doesn't produce any. Do setup for
+# command-line interactivity.
+
+# colors for ls, etc. Prefer ~/.dir_colors #64489
+if [[ -f ~/.dir_colors ]]; then
+ eval `dircolors -b ~/.dir_colors`
+else
+ eval `dircolors -b /etc/DIR_COLORS`
+fi
+alias ls="ls --color=auto"
+
+# Change the window title of X terminals
+case $TERM in
+ xterm*|rxvt|Eterm|eterm)
+ PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME%%.*}:${PWD/$HOME/~}\007"'
+ ;;
+ screen)
+ PROMPT_COMMAND='echo -ne "\033_${USER}@${HOSTNAME%%.*}:${PWD/$HOME/~}\033\\"'
+ ;;
+esac
+
+# uncomment the following to activate bash-completion:
+#[ -f /etc/profile.d/bash-completion ] && source /etc/profile.d/bash-completion