summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2009-09-30 20:13:37 +0000
committerFabian Groffen <grobian@gentoo.org>2009-09-30 20:13:37 +0000
commit572582ac27fb176b8b5baf2e165a05f23e423fce (patch)
treea574a51a1037845788293ca4bbf51372eee6b986 /app-shells/tcsh
parentamd64 stable wrt #282290 (diff)
downloadgentoo-2-572582ac27fb176b8b5baf2e165a05f23e423fce.tar.gz
gentoo-2-572582ac27fb176b8b5baf2e165a05f23e423fce.tar.bz2
gentoo-2-572582ac27fb176b8b5baf2e165a05f23e423fce.zip
Merge Prefix changes, no differences in functionality or behaviour
(Portage version: 2.2.00.14456-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'app-shells/tcsh')
-rw-r--r--app-shells/tcsh/ChangeLog7
-rw-r--r--app-shells/tcsh/tcsh-6.16.ebuild48
2 files changed, 42 insertions, 13 deletions
diff --git a/app-shells/tcsh/ChangeLog b/app-shells/tcsh/ChangeLog
index 26a75257c657..5c485dd9bc5c 100644
--- a/app-shells/tcsh/ChangeLog
+++ b/app-shells/tcsh/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-shells/tcsh
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.94 2009/04/10 19:52:35 grobian Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.95 2009/09/30 20:13:37 grobian Exp $
+
+ 30 Sep 2009; Fabian Groffen <grobian@gentoo.org> tcsh-6.16.ebuild:
+ Merge Prefix changes, no differences in functionality or behaviour
10 Apr 2009; Fabian Groffen <grobian@gentoo.org> tcsh-6.16.ebuild:
Bump patchset to remove cr0 from stty call, since this is non-POSIX, and
diff --git a/app-shells/tcsh/tcsh-6.16.ebuild b/app-shells/tcsh/tcsh-6.16.ebuild
index f2ec87507aa1..2de51f3a3c7a 100644
--- a/app-shells/tcsh/tcsh-6.16.ebuild
+++ b/app-shells/tcsh/tcsh-6.16.ebuild
@@ -1,36 +1,39 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.16.ebuild,v 1.8 2009/04/10 19:52:35 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.16.ebuild,v 1.9 2009/09/30 20:13:37 grobian Exp $
-inherit eutils
+inherit eutils flag-o-matic autotools prefix
-CONFVER="1.7"
+CONFVER="1.8"
MY_P="${P}.00"
DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
HOMEPAGE="http://www.tcsh.org/"
SRC_URI="ftp://ftp.astron.com/pub/tcsh/${MY_P}.tar.gz
- mirror://gentoo/tcsh-config-${CONFVER}.tar.bz2
- http://www.gentoo.org/~grobian/distfiles/tcsh-config-${CONFVER}.tar.bz2"
+ http://www.gentoo.org/~grobian/distfiles/tcsh-gentoo-patches-r${CONFVER}.tar.bz2"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="perl catalogs"
RESTRICT="test"
+# we need gettext because we run autoconf
DEPEND=">=sys-libs/ncurses-5.1
- perl? ( dev-lang/perl )
- !app-shells/csh" # bug #119703
+ sys-devel/gettext
+ perl? ( dev-lang/perl )"
RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
+CONFDIR=${WORKDIR}/tcsh-gentoo-patches-r${CONFVER}
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${MY_P/16/14}"-debian-dircolors.patch # bug #120792
epatch "${FILESDIR}"/${PN}-6.14-makefile.patch # bug #151951
+ epatch "${FILESDIR}"/${PN}-6.14-use-ncurses.patch
+ eautoreconf
if use catalogs ; then
einfo "enabling NLS catalogs support..."
@@ -38,10 +41,33 @@ src_unpack() {
config_f.h || die
eend $?
fi
+
+ # unify ECHO behaviour
+ echo "#undef ECHO_STYLE" >> config_f.h
+ echo "#define ECHO_STYLE BOTH_ECHO" >> config_f.h
+
+ eprefixify "${CONFDIR}"/*
+ # activate the right default PATH
+ if [[ -z ${EPREFIX} ]] ; then
+ sed -i \
+ -e 's/^#MAIN//' -e '/^#PREFIX/d' \
+ "${CONFDIR}"/csh.login || die
+ else
+ sed -i \
+ -e 's/^#PREFIX//' -e '/^#MAIN/d' \
+ "${CONFDIR}"/csh.login || die
+ fi
}
src_compile() {
- econf --prefix=/ || die "econf failed"
+ # make tcsh look and live along the lines of the prefix
+ append-flags -D_PATH_DOTCSHRC="'"'"${EPREFIX}/etc/csh.cshrc"'"'"
+ append-flags -D_PATH_DOTLOGIN="'"'"${EPREFIX}/etc/csh.login"'"'"
+ append-flags -D_PATH_DOTLOGOUT="'"'"${EPREFIX}/etc/csh.logout"'"'"
+ append-flags -D_PATH_USRBIN="'"'"${EPREFIX}/usr/bin"'"'"
+ append-flags -D_PATH_BIN="'"'"${EPREFIX}/bin"'"'"
+
+ econf --prefix="${EPREFIX:-/}" || die "econf failed"
emake || die "compile problem"
}
@@ -55,8 +81,8 @@ src_install() {
insinto /etc
doins \
- "${WORKDIR}"/tcsh-config/csh.cshrc \
- "${WORKDIR}"/tcsh-config/csh.login
+ "${CONFDIR}"/csh.cshrc \
+ "${CONFDIR}"/csh.login
dodoc FAQ Fixes NewThings Ported README WishList Y2K