summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-30 20:43:29 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-30 20:43:29 +0000
commitc70aded8a75803f1e58c9607f47b1e552b185194 (patch)
tree02b1409961bc357cfa6a7655976fe4223dfdcf24 /app-shells/esh
parentQA: Respect CC (bug 243698) (diff)
downloadgentoo-2-c70aded8a75803f1e58c9607f47b1e552b185194.tar.gz
gentoo-2-c70aded8a75803f1e58c9607f47b1e552b185194.tar.bz2
gentoo-2-c70aded8a75803f1e58c9607f47b1e552b185194.zip
QA: Respect CC (bug 243700)
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-shells/esh')
-rw-r--r--app-shells/esh/ChangeLog7
-rw-r--r--app-shells/esh/esh-0.8.5.ebuild15
2 files changed, 13 insertions, 9 deletions
diff --git a/app-shells/esh/ChangeLog b/app-shells/esh/ChangeLog
index 9fc71c96694a..f851189cd079 100644
--- a/app-shells/esh/ChangeLog
+++ b/app-shells/esh/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-shells/esh
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/ChangeLog,v 1.17 2007/05/15 09:27:31 bangert Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/ChangeLog,v 1.18 2008/12/30 20:43:29 angelos Exp $
+
+ 30 Dec 2008; Christoph Mende <angelos@gentoo.org> esh-0.8.5.ebuild:
+ QA: Respect CC (bug 243700)
15 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd>no-herd</herd>
diff --git a/app-shells/esh/esh-0.8.5.ebuild b/app-shells/esh/esh-0.8.5.ebuild
index 7dfb2dce7e6a..57b2506dbf9f 100644
--- a/app-shells/esh/esh-0.8.5.ebuild
+++ b/app-shells/esh/esh-0.8.5.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8.5.ebuild,v 1.16 2005/04/24 02:54:34 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8.5.ebuild,v 1.17 2008/12/30 20:43:29 angelos Exp $
+
+inherit toolchain-funcs
DESCRIPTION="A UNIX Shell with a simplified Scheme syntax"
HOMEPAGE="http://slon.ttk.ru/esh/"
@@ -11,22 +13,21 @@ SLOT="0"
KEYWORDS="x86 ppc sparc"
IUSE=""
-DEPEND="virtual/libc
- >=sys-libs/ncurses-5.1
+DEPEND=">=sys-libs/ncurses-5.1
>=sys-libs/readline-4.1"
S=${WORKDIR}/${PN}
src_compile() {
sed -i \
- -e "s:^CFLAGS=:CFLAGS=${CFLAGS/-fomit-frame-pointer/} :" \
+ -e "/^CFLAGS/s/-g/${CFLAGS}/" \
-e "s:^LIB=:LIB=-lncurses :" \
-e "s:-ltermcap::" \
Makefile
# For some reason, this tarball has binary files in it for x86.
# Make clean so we can rebuild for our arch and optimization.
- make clean
- make || die
+ emake clean
+ emake CC="$(tc-getCC)" || die "emake failed"
}
src_install() {