summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-07-10 21:37:11 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-07-10 21:37:11 +0000
commitd22db324824f8bec6eee7e60e24611ba9cc3c39a (patch)
treebf08242f7d40d233e75dadca6b327e3dfe4f2b25 /app-portage
parentAllow public calls to checkconfig and gen_keys, for helping automation and sa... (diff)
downloadgentoo-2-d22db324824f8bec6eee7e60e24611ba9cc3c39a.tar.gz
gentoo-2-d22db324824f8bec6eee7e60e24611ba9cc3c39a.tar.bz2
gentoo-2-d22db324824f8bec6eee7e60e24611ba9cc3c39a.zip
PyQt4 use dep, #272142
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/etc-proposals/ChangeLog8
-rw-r--r--app-portage/etc-proposals/etc-proposals-1.4.3-r1.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/app-portage/etc-proposals/ChangeLog b/app-portage/etc-proposals/ChangeLog
index ca9e5c3027f7..9d75245ab748 100644
--- a/app-portage/etc-proposals/ChangeLog
+++ b/app-portage/etc-proposals/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/etc-proposals
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/etc-proposals/ChangeLog,v 1.9 2009/01/12 20:37:32 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/etc-proposals/ChangeLog,v 1.10 2009/07/10 21:37:11 dertobi123 Exp $
+
+*etc-proposals-1.4.3-r1 (10 Jul 2009)
+
+ 10 Jul 2009; Tobias Scherbaum <dertobi123@gentoo.org>
+ +etc-proposals-1.4.3-r1.ebuild:
+ PyQt4 use dep, #272142
12 Jan 2009; Ferris McCormick <fmccor@gentoo.org>
etc-proposals-1.4.3.ebuild:
diff --git a/app-portage/etc-proposals/etc-proposals-1.4.3-r1.ebuild b/app-portage/etc-proposals/etc-proposals-1.4.3-r1.ebuild
new file mode 100644
index 000000000000..a3ca7043c8a2
--- /dev/null
+++ b/app-portage/etc-proposals/etc-proposals-1.4.3-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/etc-proposals/etc-proposals-1.4.3-r1.ebuild,v 1.1 2009/07/10 21:37:11 dertobi123 Exp $
+
+EAPI=2
+
+NEED_PYTHON="2.5"
+
+inherit distutils
+
+DESCRIPTION="a set of tools for updating gentoo config files"
+HOMEPAGE="http://developer.berlios.de/projects/etc-proposals/"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.gz"
+
+IUSE="gtk qt4"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="gtk? ( >=dev-python/pygtk-2.10 )
+ qt4? ( >=dev-python/PyQt4-4.1.1[X] )"
+RDEPEND="${DEPEND}"
+
+src_install(){
+ distutils_src_install
+ dosbin "${D}"/usr/bin/etc-proposals
+ rm -rf "${D}"/usr/bin
+}
+
+pkg_postinst() {
+ elog "The configuration file has been installed to /etc/etc-proposals.conf"
+ elog "If you are installing etc-proposals for the first time or updating"
+ elog "from a version < 1.3 you should run the following command once:"
+ elog "etc-proposals --init-db"
+ ewarn "A full backup of /etc and other files managed by CONFIG_PROTECT"
+ ewarn "is highly advised before testing this tool!"
+}